Hi,
I am trying to update review of request 11 with the changes performed in my 
directory.

Here is the error I got while running with --debug option.

==> HTTP Authentication Required
Enter authorization information for "Web API" at 47.168.250.43
Username: admin
Password: 
>>> Got API Error 207 (HTTP code 400): The file was not found in the 
repository
>>> Error data: {u'stat': u'fail', u'file': 
u'/vgd/modules/sip/trunk/test/Makefile', u'err': {u'msg': u'The file was 
not found in the repository', u'code': 207}, u'revision': u'425'}
Traceback (most recent call last):
  File "/usr/bin/rbt", line 9, in <module>
    load_entry_point('RBTools==0.6', 'console_scripts', 'rbt')()
  File 
"/usr/lib/python2.6/site-packages/RBTools-0.6-py2.6.egg/rbtools/commands/main.py",
 
line 134, in main
    command.run_from_argv([RB_MAIN, command_name] + args)
  File 
"/usr/lib/python2.6/site-packages/RBTools-0.6-py2.6.egg/rbtools/commands/__init__.py",
 
line 422, in run_from_argv
    exit_code = self.main(*args) or 0
  File 
"/usr/lib/python2.6/site-packages/RBTools-0.6-py2.6.egg/rbtools/commands/post.py",
 
line 769, in main
    submit_as=self.options.submit_as)
  File 
"/usr/lib/python2.6/site-packages/RBTools-0.6-py2.6.egg/rbtools/commands/post.py",
 
line 545, in post_request
    raise CommandError('\n'.join(error_msg))
rbtools.commands.CommandError: Error uploading diff


The file was not found in the repository (HTTP 400, API Error 207)

Your review request still exists, but the diff is not attached.

[root@arda test]# 
 

On Friday, April 25, 2014 10:32:08 AM UTC+3, David Trowbridge wrote:
>
> Are you trying to post revision 11 or update review request 11 with the 
> changes in your working copy?
>
> Can you run rbt post with --debug and send the output?
>
> -David
>
>
> On Wed, Apr 23, 2014 at 10:58 PM, Fevzi Kahraman 
> <fevzik...@gmail.com<javascript:>
> > wrote:
>
>> Hi,
>> I have installed the reviewboard a seprate server than SVN rep. server. I 
>> can create review requests and assign to someone. However I can not see the 
>> changed code part in review.
>>
>> After some digging I realized that RBTools needs to be installed on 
>> client side. RBTools has been installed and  REVIEWBOARD_URL = "
>> http://localhost"; has been added at the top of local svn directory. 
>> After doing some code changes, following command executed for posting code 
>> changes to reviewboard.
>>
>> [root@arda test]# rbt post -r 11
>>
>>
>> However I got following error just after login prompt.
>>
>> ERROR: Error uploading diff
>>
>>
>> The file was not found in the repository (HTTP 400, API Error 207)
>>
>> Your review request still exists, but the diff is not attached.
>>
>>
>> SO my question is how can I get rid of this error and post my code 
>> changed to reviwe reguest ?
>>
>> Thanks,
>> Fevzi
>>
>>
>>
>>
>>
>>  -- 
>> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
>> ---
>> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
>> ---
>> Happy user? Let us know at http://www.reviewboard.org/users/
>> --- 
>> You received this message because you are subscribed to the Google Groups 
>> "reviewboard" group.
>> To unsubscribe from this group and stop receiving emails from it, send an 
>> email to reviewboard...@googlegroups.com <javascript:>.
>> For more options, visit https://groups.google.com/d/optout.
>>
>
>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to