We always had trouble with the search largely due to this bug: 

Now with 2.0 I tried the search again and it worked a little bit better - 
instead of coming up with an error 500 I always got "No results"

So I figured maybe I need to rebuild the index which I did with sudo 
rb-site manage /var/www/codereview/ rebuild_index

It warned me that it will delete all indices and then claimed "Indexing 1 
review request" - hm, we have about 11,000+ review requests in the system 
so that is a bit weird
Also the search is now broken - I'm getting a server error 500 again and 
the stack trace points to:

IOError: The path to your Whoosh index '/var/www/codereview/index' is not 
> writable for the current user/group.
Typing something into the search box will yield perfectly good results 
after a little while in the drop down (as long as what I'm looking for is 
part of the Summary) just hitting enter on the search box won't work 

So my questions are:

1. How do I properly configure the search - mainly which user should own 
the index? Apparently not root because that's what it is now and that's not 

2. How can I track down the indexing problem (in the sense that it claims 
it can only index 1 request)?


Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
Happy user? Let us know at http://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to