Trying to get up to 2.x to work on the SSL certificate errors. Environment 

Centos 65 updated.
Python 2.6 (yum installed)
ReviewBoard 1.7.25 (yum installed)

Setuptools are installed, so easy_install is available.

Attempting to do ANY upgrade (easy_install -U reviewboard or 
reviewboard=1.7.27) seems to succeed. Attempts to access after "rb-site 
upgrade" is run gets a "ReviewBoard is taking a nap" error on the browser 
and the logs show activity only in the access & error logs:

==> error_log <==
[Wed Jul 30 12:16:13 2014] [error] [client] mod_wsgi 
(pid=2720): Target WSGI script 
'/var/www/' cannot be loaded 
as Python module.
[Wed Jul 30 12:16:13 2014] [error] [client] mod_wsgi 
(pid=2720): Exception occurred processing WSGI script 
[Wed Jul 30 12:16:13 2014] [error] [client] Traceback (most 
recent call last):
[Wed Jul 30 12:16:13 2014] [error] [client]   File 
"/var/www/", line 3, in 
[Wed Jul 30 12:16:13 2014] [error] [client]     import 
[Wed Jul 30 12:16:13 2014] [error] [client]   File 
"build/bdist.linux-x86_64/egg/", line 2876, in <module>
[Wed Jul 30 12:16:13 2014] [error] [client]   File 
"build/bdist.linux-x86_64/egg/", line 449, in _build_master
[Wed Jul 30 12:16:13 2014] [error] [client]   File 
"build/bdist.linux-x86_64/egg/", line 745, in require
[Wed Jul 30 12:16:13 2014] [error] [client]   File 
"build/bdist.linux-x86_64/egg/", line 639, in resolve
[Wed Jul 30 12:16:13 2014] [error] [client] 
DistributionNotFound: Whoosh
==> access_log <== - - [30/Jul/2014:12:16:13 -0500] "GET / HTTP/1.1" 500 1372 "-" 
"Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; rv:11.0) like Gecko"

Obviously domain name has been changed. Again, this is a very basic install 
with no activity yet. I am running hyper-v and have snapshots, which make 
testing various configs easy. I have seen references to upgrading the 
python to 2.7 however when I tried this also it looked like several 
reviewboard modules were looking for files under 2.6, even after aliasing 
python itself. I also tried upgrading python first before upgrading the 
reviewboard but that failed as well.

 I see no difference when I compare the reviewboard.wsgi file to the one 
after upgrade, and in fact the date stamps remain as before. Is there a 
step by step so I can see what I am missing? The best results with the 
fewest errors seem to be easy_install -U django_evolution followed by the 
-U reviewboard, but this simply gives the browser the nap message with the 
above errors in the logs... 

Get the Review Board Power Pack at
Sign up for Review Board hosting at RBCommons:
Happy user? Let us know at
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to