Hi,

We have a situation this morning where a published review will no longer 
accept new diff sets (changes from review rework to address comments) from 
rbt post (Perforce). The user tells me that they posted a diff set but then 
cancelled the publication of the diffset in the browser. Subsequent rbt 
post's of the pending change no longer appears to update the review, even 
when we add new deltas. I've checked the user is using rbt correctly so 
that is not the issue. When I examine the database via the admin interface 
I can see the specific file diff that the user expects to see on the review 
but I don't know how to fix this so I've avoided carrying out any admin 
actions.

When we try to post the diffs again we see the following in the RB log but 
not much else:

2014-07-31 10:13:26,397 - DEBUG -  - DiffParser.parse: Beginning parse of 
diff, size = 3064
2014-07-31 10:13:26,397 - DEBUG -  - DiffParser.parse: Finished parsing 
diff.

When we open the review in the browser following the post the review is in 
a published state with no pending changes to publish i.e. no green banner.

I'm not sure what info I need to post and what I can safely post here to 
help diagnose this problem or to get the review working again. For now I've 
advised the user to start a new review. I will also be asking users not to 
cancel the publication of diff sets to avoid this problem in the future.

Any ideas on a better solution/workaround?

Thanks,
Stephen.

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to