I've been doing a fair amount of testing of RBTools in preparation for 
moving to RB 2.0 and I've come across a few important issues that are 
preventing us from moving to RBTools 0.7.  The 2 most significant ones 
appear to be regressions as my tests pass in 0.6.3 but fail in 0.7.2.

The first issue has already been reported by someone else as issue 3843. 
 I've reproduced it and added a comment saying that it doesn't happen in 
0.6.3 and I can provide a test file if desired.

The second issue comes up when I try to post a review using a range of 
perforce change lists.  This always worked for us with post-review, and it 
works with RBTools 0.6.3, but fails with 0.7.2.  Here's an example:

$  rbt --version
RBTools 0.6.3
$ rbt post  //depot/Jam/MAIN/src/...@813,@823
Review request #11 posted.


I discarded that review and then ran the same exact command against the 
same repo using RBTools 0.7.2. I had to add the debug option to get any 
useful output:
$  rbt --version
RBTools 0.7.2
$ rbt post  -d  //depot/Jam/MAIN/src/...@813,@823


+Test submitting a review with a shelve and no ship its.
>>> Writing "//depot/Jam/MAIN/src/RELNOTES#77" to "/tmp/tmpQNewPu"
>>> Running: p4 print -o /tmp/tmpQNewPu -q //depot/Jam/MAIN/src/RELNOTES#77
>>> Writing "//depot/Jam/MAIN/src/RELNOTES#78" to "/tmp/tmpUJo72G"
>>> Running: p4 print -o /tmp/tmpUJo72G -q //depot/Jam/MAIN/src/RELNOTES#78
>>> Running: diff -urNp /tmp/tmpQNewPu /tmp/tmpUJo72G
>>> Command exited with rc 1: [u'diff', u'-urNp', '/tmp/tmpQNewPu', 
--- /tmp/tmpQNewPu      2015-05-05 17:54:57.889010010 -0700
+++ /tmp/tmpUJo72G      2015-05-05 17:54:57.893009847 -0700
@@ -548,3 +548,4 @@ Release notes for Jam 2.0.
        A poorly set $(JAMSHELL) is likely to result in silent
+Test creating with 2 jobs.
>>> Making HTTP GET request to http://localhost/api/validation/diffs/
>>> Cached response for HTTP GET http://localhost/api/validation/diffs/ 
expired and was modified
>>> Making HTTP POST request to http://localhost/api/validation/diffs/
Traceback (most recent call last):
  File "/home/sallan/envs/rbtools-0.7.2/bin/rbt", line 9, in <module>
    load_entry_point('RBTools==0.7.2', 'console_scripts', 'rbt')()
line 133, in main
    command.run_from_argv([RB_MAIN, command_name] + args)
line 555, in run_from_argv
    exit_code = self.main(*args) or 0
line 714, in main
line 553, in check_guess_fields
    assert self.revisions

When I ran it under a debugger, I found that it was trying to run 

p4 change  //depot/Jam/MAIN/src/...@813,@823

which understandably failed.  So something changed drastically between 0.6 
and 0.7.  Any ideas as to why this use case no longer works in 0.7? 

Please let me know if I can provide any more information.



Supercharge your Review Board with Power Pack: 
Want us to host Review Board for you? Check out RBCommons: 
Happy user? Let us know! https://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to