Just an FYI -- I did run into a few minor problems upgrading reviewboard 
from 2.0.5 (yes, I haven't upgraded in a while) to 2.5.4. They'd been 
previously reported (here or other places online), and the work-arounds 
given worked for me too.
When I first ran the "rb-site upgrade /var/www/reboard.com" command I got 
an error:

ImportError: No module named PIL

The advice I found was uninstall PIL, install Pillow:

easy_install -m pil
rm -Rf PIL-1.1.7-py2.7-linux-x86_64.egg

Next, I got a problem when I ran "easy_install -U Pillow": 

ValueError: jpeg is required unless explicitly disabled using 
--disable-jpeg, aborting

The fix for this was to install the missing package, then Pillow:

zypper install libjpeg8-devel
easy_install  Pillow

Next, I got the following error when I re-tired "rb-site upgrade 

CommandError: Error applying evolution: relation 
"scmtools_repository_8c446842" already exists

I'm using postgresql, so the suggested fix was to manually drop this table 

psql -U postgres -d reviewboard -q -c "DROP index 

After this, the upgrade worked fine. The new version looks good so far. 


Supercharge your Review Board with Power Pack: 
Want us to host Review Board for you? Check out RBCommons: 
Happy user? Let us know! https://www.reviewboard.org/users/
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to