Hmmm, I did a few things since yesterday, reinstalled ReviewBoard, did the 
rb-site upgrade again and now the site is showing in the browser but there 
are no review requests, nothing in console, and nothing new in the 
reviewboard log.

Any ideas?

Thanks,
Chris

On Monday, March 12, 2018 at 6:59:32 PM UTC-7, Christian Hammond wrote:
>
> Hi Chris,
>
> Looks like it’s using PIL, which is deprecated and in your case missing 
> some dependency. You’ll need to uninstall it and install pillow instead 
> (which can probably be fetched from your distro, or if not, pip — upgrade 
> pip first).
>
> If you use pip, watch its output for the dependencies it finds. If any are 
> missing, you’ll need the development packages from your distro.
>
> Christian
>
>
> On Mon, Mar 12, 2018 at 14:08 Chris Lang <crla...@gmail.com <javascript:>> 
> wrote:
>
>> Hey Christian,
>>
>> It almost all went smoothly. Currently I'm getting a 500 error from 
>> reviewboard.
>> I checked the log and found the following error:
>>
>> 2018-03-12 07:46:54,793 - ERROR -  - Error thumbnailing image file 
>> uploaded/files/2018/03/12/59e3f458-2488-4a83-8236-5542dfd7337a__cloverleaf.gif
>>  
>> and saving as 
>> uploaded/files/2018/03/12/59e3f458-2488-4a83-8236-5542dfd7337a__cloverleaf_800x200.gif:
>>  
>> encoder zip not available
>> Traceback (most recent call last):
>>   File 
>> "/usr/lib/python2.7/site-packages/Djblets-0.8.23-py2.7.egg/djblets/util/templatetags/djblets_images.py",
>>  
>> line 120, in thumbnail
>>     save_image_to_storage(image, storage, miniature)
>>   File 
>> "/usr/lib/python2.7/site-packages/Djblets-0.8.23-py2.7.egg/djblets/util/templatetags/djblets_images.py",
>>  
>> line 48, in save_image_to_storage
>>     image.save(file, 'png')
>>   File 
>> "/usr/lib/python2.7/site-packages/PIL-1.1.7-py2.7-linux-x86_64.egg/Image.py",
>>  
>> line 1439, in save
>>     save_handler(self, fp, filename)
>>   File 
>> "/usr/lib/python2.7/site-packages/PIL-1.1.7-py2.7-linux-x86_64.egg/PngImagePlugin.py",
>>  
>> line 572, in _save
>>     ImageFile._save(im, _idat(fp, chunk), [("zip", (0,0)+im.size, 0, 
>> rawmode)])
>>   File 
>> "/usr/lib/python2.7/site-packages/PIL-1.1.7-py2.7-linux-x86_64.egg/ImageFile.py",
>>  
>> line 481, in _save
>>     e = Image._getencoder(im.mode, e, a, im.encoderconfig)
>>   File 
>> "/usr/lib/python2.7/site-packages/PIL-1.1.7-py2.7-linux-x86_64.egg/Image.py",
>>  
>> line 401, in _getencoder
>>     raise IOError("encoder %s not available" % encoder_name)
>> IOError: encoder zip not available
>>
>> Let me know if you've seen this before, otherwise I'm still looking into 
>> how to resolve it.
>>
>> Just wanted to give an update.
>>
>> @Stephen, yea I went and tried to do yum install ReviewBoard but it gave 
>> me 2.5 as you pointed out. Easy_install seems to have worked well for the 
>> most part but ya it'd be nice to have the lastest version of ReviewBoard in 
>> EPEL.
>>
>>
>> On Friday, March 9, 2018 at 7:53:04 PM UTC-8, Stephen Gallagher wrote:
>>
>>> Just to mention, I maintain an RPM packaged version of the 2.5 series 
>>> for RHEL and Centos in the EPEL repository which should avoid the version 
>>> compatibility question. (I don't work for Beanbag Inc., it's a volunteer 
>>> effort)
>>>
>>> I have it on my TO DO list to get 3.x out for EPEL, but my regular job 
>>> has kept me swamped for the last couple months. Hopefully soon, though.
>>>
>>> On Fri, Mar 9, 2018, 3:23 PM Chris Lang <crla...@gmail.com> wrote:
>>>
>>>> I will take your advice and upgrade, thats great to hear that I will be 
>>>> able to install the newer version.
>>>> I'll go ahead and try that out and then let you know how it goes.
>>>>
>>>> Thanks for your help Christian!
>>>>
>>>>
>>>> On Thursday, March 8, 2018 at 6:52:53 PM UTC-8, Christian Hammond wrote:
>>>>
>>>>> As long as you have a backup of the database and site directory, you 
>>>>> have nothing to worry about. It's perfectly safe to install a newer 
>>>>> version 
>>>>> of Review Board on the target server, copy the site directory over to the 
>>>>> same path as on the old server, and then do a 'rb-site upgrade'. It will 
>>>>> upgrade the database to Review Board 3.0.
>>>>>
>>>>> (3.0 is the recommended version at this point.)
>>>>>
>>>>> If you want to use the older version on the new server for now, you 
>>>>> can locate the site-packages directory containing the old Review Board 
>>>>> install and see the versions of the packages you were using there. You 
>>>>> can 
>>>>> force the installation of the appropriate versions with:
>>>>>
>>>>>     sudo easy_install package_name==version
>>>>>
>>>>> Christian
>>>>>
>>>>
>>>>> On Thu, Mar 8, 2018 at 12:30 PM, Chris Lang <crla...@gmail.com> wrote:
>>>>>
>>>>>> I'm thinking it'll be safer to move to the new machine first and then 
>>>>>> upgrade, and in case anything goes wrong with the upgrade, the team can 
>>>>>> continue using the old server.
>>>>>>
>>>>>>
>>>>>> On Thursday, March 8, 2018 at 12:24:40 PM UTC-8, Chris Lang wrote:
>>>>>>>
>>>>>>> Do you think it'd be easier to upgrade first and then move to the 
>>>>>>> new server? CentOS -> Redhat.
>>>>>>> I'm trying to minimize downtime since our developers use it around 
>>>>>>> the clock.
>>>>>>>
>>>>>>> On Thursday, March 8, 2018 at 12:17:42 PM UTC-8, Chris Lang wrote:
>>>>>>>>
>>>>>>>> Hey Christian,
>>>>>>>>
>>>>>>>> Yes, I'm moving between servers for security reasons. What version 
>>>>>>>> of ReviewBoard would you recommend upgrading to?
>>>>>>>>
>>>>>>>> Regards,
>>>>>>>> Chris
>>>>>>>>
>>>>>>>> On Thursday, March 8, 2018 at 12:08:03 PM UTC-8, Christian Hammond 
>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>> Hi Chris,
>>>>>>>>>
>>>>>>>>> Django 1.6.11 is correct. You likely have something installed on 
>>>>>>>>> the server that wants a newer version. It’s possible some dependency 
>>>>>>>>> required by Review Board or another of its dependencies picked it up.
>>>>>>>>>
>>>>>>>>> This is fixable, but first, can you tell me why you’re installing 
>>>>>>>>> 2.0.20? Are you moving between servers?  I ask because except for 
>>>>>>>>> major 
>>>>>>>>> security issues, we’re no longer maintaining this release outside of 
>>>>>>>>> support contracts.
>>>>>>>>>
>>>>>>>>> Christian
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On Thu, Mar 8, 2018 at 10:56 Chris Lang <crla...@gmail.com> wrote:
>>>>>>>>>
>>>>>>>>>> Hi,
>>>>>>>>>>
>>>>>>>>>> I'm trying to install ReviewBoard 2.0.20 on RedHat 7.4 but am 
>>>>>>>>>> getting an error when running rb-site install.
>>>>>>>>>>
>>>>>>>>>> I initially installed ReviewBoard with easy_install 
>>>>>>>>>> ReviewBoard==2.0.20.
>>>>>>>>>>
>>>>>>>>>> The current errors I'm getting are:
>>>>>>>>>>
>>>>>>>>>>   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 
>>>>>>>>>> 626, in resolve
>>>>>>>>>>     raise DistributionNotFound(req)
>>>>>>>>>> pkg_resources.DistributionNotFound: Django>=1.6.11,<1.7
>>>>>>>>>>
>>>>>>>>>> and 
>>>>>>>>>>
>>>>>>>>>>   File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 
>>>>>>>>>> 630, in resolve
>>>>>>>>>>     raise VersionConflict(dist,req) # XXX put more info here
>>>>>>>>>> pkg_resources.VersionConflict: (Django 1.6.11 
>>>>>>>>>> (/usr/lib/python2.7/site-packages), 
>>>>>>>>>> Requirement.parse('Django>=1.8,<1.12'))
>>>>>>>>>>
>>>>>>>>>> I cannot get a version of Django that satisfies both. Not sure 
>>>>>>>>>> what to do from here.
>>>>>>>>>>
>>>>>>>>>> Thanks,
>>>>>>>>>> Chris
>>>>>>>>>>
>>>>>>>>>> -- 
>>>>>>>>>> Supercharge your Review Board with Power Pack: 
>>>>>>>>>> https://www.reviewboard.org/powerpack/
>>>>>>>>>> Want us to host Review Board for you? Check out RBCommons: 
>>>>>>>>>> https://rbcommons.com/
>>>>>>>>>> Happy user? Let us know! https://www.reviewboard.org/users/
>>>>>>>>>> --- 
>>>>>>>>>> You received this message because you are subscribed to the 
>>>>>>>>>> Google Groups "Review Board Community" group.
>>>>>>>>>> To unsubscribe from this group and stop receiving emails from it, 
>>>>>>>>>> send an email to reviewboard...@googlegroups.com.
>>>>>>>>>> For more options, visit https://groups.google.com/d/optout.
>>>>>>>>>>
>>>>>>>>> -- 
>>>>>>>>> -- 
>>>>>>>>> Christian Hammond
>>>>>>>>> President/CEO of Beanbag
>>>>>>>>> Makers of Review Board
>>>>>>>>>
>>>>>>>> -- 
>>>>>> Supercharge your Review Board with Power Pack: 
>>>>>> https://www.reviewboard.org/powerpack/
>>>>>> Want us to host Review Board for you? Check out RBCommons: 
>>>>>> https://rbcommons.com/
>>>>>> Happy user? Let us know! https://www.reviewboard.org/users/
>>>>>> --- 
>>>>>> You received this message because you are subscribed to the Google 
>>>>>> Groups "Review Board Community" group.
>>>>>> To unsubscribe from this group and stop receiving emails from it, 
>>>>>> send an email to reviewboard...@googlegroups.com.
>>>>>> For more options, visit https://groups.google.com/d/optout.
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> -- 
>>>>> Christian Hammond
>>>>> President/CEO of Beanbag <https://www.beanbaginc.com/>
>>>>> Makers of Review Board <https://www.reviewboard.org/>
>>>>>
>>>> -- 
>>>> Supercharge your Review Board with Power Pack: 
>>>> https://www.reviewboard.org/powerpack/
>>>> Want us to host Review Board for you? Check out RBCommons: 
>>>> https://rbcommons.com/
>>>> Happy user? Let us know! https://www.reviewboard.org/users/
>>>> --- 
>>>> You received this message because you are subscribed to the Google 
>>>> Groups "Review Board Community" group.
>>>> To unsubscribe from this group and stop receiving emails from it, send 
>>>> an email to reviewboard...@googlegroups.com.
>>>> For more options, visit https://groups.google.com/d/optout.
>>>>
>>> -- 
>> Supercharge your Review Board with Power Pack: 
>> https://www.reviewboard.org/powerpack/
>> Want us to host Review Board for you? Check out RBCommons: 
>> https://rbcommons.com/
>> Happy user? Let us know! https://www.reviewboard.org/users/
>> --- 
>> You received this message because you are subscribed to the Google Groups 
>> "Review Board Community" group.
>> To unsubscribe from this group and stop receiving emails from it, send an 
>> email to reviewboard...@googlegroups.com <javascript:>.
>> For more options, visit https://groups.google.com/d/optout.
>>
> -- 
> -- 
> Christian Hammond
> President/CEO of Beanbag
> Makers of Review Board
>

-- 
Supercharge your Review Board with Power Pack: 
https://www.reviewboard.org/powerpack/
Want us to host Review Board for you? Check out RBCommons: 
https://rbcommons.com/
Happy user? Let us know! https://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"Review Board Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to