> On June 9, 2014, 8:43 p.m., Mark Chu-Carroll wrote: > > src/main/python/apache/aurora/admin/admin_util.py, line 88 > > <https://reviews.apache.org/r/22167/diff/3/?file=603310#file603310line88> > > > > You've got "parse_hosts", "parst_host_file", "parse_hosts_optional", > > and "parse_host_list". I have no idea why there are so many different parse > > functions, or what they're all for. But it sure looks like overkill.
parse_host_list and parse_host_file are private helpers used by parse_hosts and parse_hosts_optional. Prefixed with "_" to better reflect on their meaning. > On June 9, 2014, 8:43 p.m., Mark Chu-Carroll wrote: > > src/main/python/apache/aurora/admin/admin_util.py, line 117 > > <https://reviews.apache.org/r/22167/diff/3/?file=603310#file603310line117> > > > > This needs a more descriptive name. Looking at the code, I have > > absolutely no idea of what the condition "not d.safe if unsafe_only else > > True" is supposed to mean, or what's being selected for. Fixed and documented all public methods. > On June 9, 2014, 8:43 p.m., Mark Chu-Carroll wrote: > > src/main/python/apache/aurora/admin/host_maintenance.py, line 86 > > <https://reviews.apache.org/r/22167/diff/3/?file=603311#file603311line86> > > > > This method is very unclear considering how short it is. > > > > What is host_groups? Why does probe_hosts return a list, where more > > than one element in the list is an error? > > > > Added clarifications. > On June 9, 2014, 8:43 p.m., Mark Chu-Carroll wrote: > > src/main/python/apache/aurora/client/commands/maintenance.py, line 72 > > <https://reviews.apache.org/r/22167/diff/3/?file=603316#file603316line72> > > > > This help line is unclear: what does "time interval for the percentage > > of up tasks" mean? The time period over which a certain percentage of > > tasks must have been up all the time? Time period over which a percentage > > of tasks must have been up for at least some amount of time? > > The override comments here are intentionally vague to discourage their use :) Whoever is trying to override them must already have an intimate knowledge of admin sla_* commands providing, hopefully, clear instructions. - Maxim ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/22167/#review45131 ----------------------------------------------------------- On June 4, 2014, 1:46 a.m., Maxim Khutornenko wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/22167/ > ----------------------------------------------------------- > > (Updated June 4, 2014, 1:46 a.m.) > > > Review request for Aurora, Joe Smith, Mark Chu-Carroll, and Brian Wickman. > > > Bugs: AURORA-445 > https://issues.apache.org/jira/browse/AURORA-445 > > > Repository: aurora > > > Description > ------- > > Adding SLA check into perform_maintenance_hosts command with the possibility > of override. > > > Diffs > ----- > > src/main/python/apache/aurora/admin/BUILD > 8d850bcea353a0a4afe0135d600a890511bb6751 > src/main/python/apache/aurora/admin/admin_util.py PRE-CREATION > src/main/python/apache/aurora/admin/host_maintenance.py > ca26de1e1a75aa4ae1c47ddd0f566b577c67fc7c > src/main/python/apache/aurora/client/base.py > ef0855daf95b6bddb6788284102effde2599179b > src/main/python/apache/aurora/client/cli/__init__.py > fd6f96ebe4acd358409f145178ebf8ad5ea27d05 > src/main/python/apache/aurora/client/commands/BUILD > 03cd4855464972e4ace6081f50d140ffbe5807c4 > src/main/python/apache/aurora/client/commands/admin.py > 919eea933a5a65396e64e05c739344f0c093c1b3 > src/main/python/apache/aurora/client/commands/maintenance.py > f6ebe3b0c665211f175f0b432a2fdae83fc7b62f > src/test/python/apache/aurora/client/commands/test_admin_sla.py > 84a91d55516594dadc01408eb9d0b4773060d1af > src/test/python/apache/aurora/client/commands/test_maintenance.py > dd56b8d1feddb48a741e1a855833eb577cea67ab > src/test/python/apache/aurora/client/commands/util.py > 84784171816797f3a4fa4c5238d19b626e68ff44 > > Diff: https://reviews.apache.org/r/22167/diff/ > > > Testing > ------- > > ./pants src/tests/python:all > > > Thanks, > > Maxim Khutornenko > >
