> On Sept. 29, 2014, 8:12 p.m., Bill Farner wrote:
> > src/main/java/org/apache/aurora/scheduler/quota/QuotaUtil.java, line 88
> > <https://reviews.apache.org/r/26102/diff/2/?file=708338#file708338line88>
> >
> >     Your call on whether this makes things more readable, but i could 
> > imagine some cleanup here:
> >     
> >         Function<.., ..> toResources;
> >     
> >         IResourceAggregate desired = 
> > desiredState.transform(TO_RESOURCES).or(EMPTY);

Sure, why not.


> On Sept. 29, 2014, 8:12 p.m., Bill Farner wrote:
> > src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java,
> >  line 1357
> > <https://reviews.apache.org/r/26102/diff/2/?file=708339#file708339line1357>
> >
> >     @Nullable, though i wouldn't mind seeing Optional here and orNull() 
> > below.

Done.


> On Sept. 29, 2014, 8:12 p.m., Bill Farner wrote:
> > src/test/java/org/apache/aurora/scheduler/updater/JobUpdaterIT.java, line 
> > 736
> > <https://reviews.apache.org/r/26102/diff/2/?file=708343#file708343line736>
> >
> >     Would still like to see the test case for update behavior when 
> > instanceCount is reduced, and TaskConfig is unchanged.

Thanks, added and fixed a few more issues.


- Maxim


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/26102/#review54861
-----------------------------------------------------------


On Sept. 29, 2014, 8:04 p.m., Maxim Khutornenko wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/26102/
> -----------------------------------------------------------
> 
> (Updated Sept. 29, 2014, 8:04 p.m.)
> 
> 
> Review request for Aurora and Bill Farner.
> 
> 
> Bugs: AURORA-756
>     https://issues.apache.org/jira/browse/AURORA-756
> 
> 
> Repository: aurora
> 
> 
> Description
> -------
> 
> Dropping assert on empty desired instances set.
> 
> 
> Diffs
> -----
> 
>   src/main/java/org/apache/aurora/scheduler/quota/QuotaUtil.java 
> 105426f35c5d1dd6841d844d4e223dbb40f28215 
>   
> src/main/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterface.java
>  fa54d5b7898c6460f1889f698e8f2f687b64c924 
>   src/main/java/org/apache/aurora/scheduler/updater/UpdateFactory.java 
> f4aefb21a41d41f11cb4a8caf402bbe18eb2d1d5 
>   src/test/java/org/apache/aurora/scheduler/quota/QuotaManagerImplTest.java 
> 11cc2f6fd47e316a42cb2f241344e356eaae4920 
>   
> src/test/java/org/apache/aurora/scheduler/thrift/SchedulerThriftInterfaceTest.java
>  83630a350f488d002a653dd31c170a1e918e49b7 
>   src/test/java/org/apache/aurora/scheduler/updater/JobUpdaterIT.java 
> 5b00d3cf72adc154f130bb067723c3bd6960a314 
> 
> Diff: https://reviews.apache.org/r/26102/diff/
> 
> 
> Testing
> -------
> 
> gradle -Pq build
> 
> 
> Thanks,
> 
> Maxim Khutornenko
> 
>

Reply via email to