Balazs Hevele has posted comments on this change. ( http://gerrit.cloudera.org:8080/24579 )
Change subject: IMPALA-15139: Support DELTA_LENGTH_BYTE_ARRAY Parquet encoding ...................................................................... Patch Set 2: (2 comments) http://gerrit.cloudera.org:8080/#/c/24579/2/be/src/exec/parquet/parquet-delta-length-byte-array-decoder.h File be/src/exec/parquet/parquet-delta-length-byte-array-decoder.h: http://gerrit.cloudera.org:8080/#/c/24579/2/be/src/exec/parquet/parquet-delta-length-byte-array-decoder.h@83 PS2, Line 83: data_remaining_ nit: could you clarify in the name that this is number of BYTES remaining? http://gerrit.cloudera.org:8080/#/c/24579/2/be/src/exec/parquet/parquet-delta-length-byte-array-decoder.cc File be/src/exec/parquet/parquet-delta-length-byte-array-decoder.cc: http://gerrit.cloudera.org:8080/#/c/24579/2/be/src/exec/parquet/parquet-delta-length-byte-array-decoder.cc@73 PS2, Line 73: total_data_bytes > data_len Is this comparison correct? As I understand -total_data_bytes only contains the size of the concatenated strings -data_len contains the size of the (packed) lengths and the size of the concatenated strings -- To view, visit http://gerrit.cloudera.org:8080/24579 To unsubscribe, visit http://gerrit.cloudera.org:8080/settings Gerrit-Project: Impala-ASF Gerrit-Branch: master Gerrit-MessageType: comment Gerrit-Change-Id: I9e4395fa30cd7fb2c89ef5a2b16b043d4de60b52 Gerrit-Change-Number: 24579 Gerrit-PatchSet: 2 Gerrit-Owner: Mihaly Szjatinya <[email protected]> Gerrit-Reviewer: Balazs Hevele <[email protected]> Gerrit-Reviewer: Csaba Ringhofer <[email protected]> Gerrit-Reviewer: Impala Public Jenkins <[email protected]> Gerrit-Reviewer: Mihaly Szjatinya <[email protected]> Gerrit-Reviewer: Zoltan Borok-Nagy <[email protected]> Gerrit-Comment-Date: Wed, 15 Jul 2026 12:01:37 +0000 Gerrit-HasComments: Yes
