helifu has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/15122 )

Change subject: [client] KUDU-2483 Add IN Bloom filter predicate to C++ client
......................................................................


Patch Set 6:

(3 comments)

http://gerrit.cloudera.org:8080/#/c/15122/6/src/kudu/client/scan_predicate.h
File src/kudu/client/scan_predicate.h:

http://gerrit.cloudera.org:8080/#/c/15122/6/src/kudu/client/scan_predicate.h@95
PS6, Line 95: Slice
It's a good definition here. Once I used "const KuduValue* value", then a lot 
of useless code was introduced into my implementation. From the user's 
perspective, some comments for different column type, i.e. bool/int16/int32 ... 
will be welcome.


http://gerrit.cloudera.org:8080/#/c/15122/6/src/kudu/client/scan_predicate.h@130
PS6, Line 130: int
I think "size_t" will be better than "int".


http://gerrit.cloudera.org:8080/#/c/15122/6/src/kudu/client/scan_predicate.cc
File src/kudu/client/scan_predicate.cc:

http://gerrit.cloudera.org:8080/#/c/15122/6/src/kudu/client/scan_predicate.cc@260
PS6, Line 260: Build(KuduBloomFilter** bloom_filter_out)
Maybe return Status::InvalidArgument as soon as possible if the 'num_keys' is 
less or equal than 0.



--
To view, visit http://gerrit.cloudera.org:8080/15122
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I4aa235a4c933ebce0bf3ec7fcb135098eccc4ea4
Gerrit-Change-Number: 15122
Gerrit-PatchSet: 6
Gerrit-Owner: Bankim Bhavsar <ban...@cloudera.com>
Gerrit-Reviewer: Adar Dembo <a...@cloudera.com>
Gerrit-Reviewer: Bankim Bhavsar <ban...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Yao Xu <ocla...@gmail.com>
Gerrit-Reviewer: ZhangYao <triplesheep0...@gmail.com>
Gerrit-Reviewer: helifu <hzhel...@corp.netease.com>
Gerrit-Comment-Date: Tue, 11 Feb 2020 12:58:43 +0000
Gerrit-HasComments: Yes

Reply via email to