Alexey Serbin has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/15981 )

Change subject: replace shared_ptr(new T) with make_shared<T>()
......................................................................


Patch Set 2:

(1 comment)

http://gerrit.cloudera.org:8080/#/c/15981/2/src/kudu/hms/hms_client.cc
File src/kudu/hms/hms_client.cc:

http://gerrit.cloudera.org:8080/#/c/15981/2/src/kudu/hms/hms_client.cc@394
PS2, Line 394: shared_ptr<TMemoryBuffer> 
membuffer(std::make_shared<TMemoryBuffer>(json.size()));
> Here and elsewhere, from readability/style perspective, I prefer
I used the form that was there, replacing 'new' with 'make_shared'.

As for 'auto x = ...;' vs 'auto x(...);' I prefer the latter since it has one 
less symbol :)



--
To view, visit http://gerrit.cloudera.org:8080/15981
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I9bcca0287d484472f7cc616f553060fe83faab1a
Gerrit-Change-Number: 15981
Gerrit-PatchSet: 2
Gerrit-Owner: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Andrew Wong <aw...@cloudera.com>
Gerrit-Reviewer: Bankim Bhavsar <ban...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Tidy Bot (241)
Gerrit-Comment-Date: Fri, 22 May 2020 22:39:55 +0000
Gerrit-HasComments: Yes

Reply via email to