Andrew Wong has posted comments on this change. ( http://gerrit.cloudera.org:8080/16387 )
Change subject: tablet: refactor delta iteration code ...................................................................... Patch Set 2: (10 comments) http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/delta_store.h File src/kudu/tablet/delta_store.h: http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/delta_store.h@673 PS2, Line 673: const DeltaStoreIterType* store_iter() const { > warning: all paths through this function will call itself [clang-diagnostic Done http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/delta_store.h@676 PS2, Line 676: const DeltaPreparerType* preparer() const { > warning: all paths through this function will call itself [clang-diagnostic Done http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/delta_store.h@681 PS2, Line 681: virtual std::string ToString() const = 0; > warning: 'ToString' overrides a member function but is not marked 'override Done http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/deltafile.cc File src/kudu/tablet/deltafile.cc: http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/deltafile.cc@625 PS2, Line 625: RowIteratorOptions opts) > warning: the parameter 'opts' is copied for each invocation but only used a Done http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/deltamemstore.h File src/kudu/tablet/deltamemstore.h: http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/deltamemstore.h@207 PS2, Line 207: DeltaMemStoreIterator(const std::shared_ptr<const DeltaMemStore> dms); > warning: single-argument constructors must be marked explicit to avoid unin Done http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/deltamemstore.cc File src/kudu/tablet/deltamemstore.cc: http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/deltamemstore.cc@196 PS2, Line 196: DeltaMemStoreIterator::DeltaMemStoreIterator(const shared_ptr<const DeltaMemStore> dms) > warning: the const qualified parameter 'dms' is copied for each invocation; Done http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/deltamemstore.cc@216 PS2, Line 216: Status DeltaMemStoreIterator::PrepareForBatch(size_t nrows) { > warning: parameter 'nrows' is unused [misc-unused-parameters] Done http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/deltamemstore.cc@230 PS2, Line 230: Slice key_slice, val_slice; > warning: multiple declarations in a single statement reduces readability [r Done http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/deltamemstore.cc@239 PS2, Line 239: void DeltaMemStoreIterator::Finish(size_t nrows) { > warning: parameter 'nrows' is unused [misc-unused-parameters] Done http://gerrit.cloudera.org:8080/#/c/16387/2/src/kudu/tablet/deltamemstore.cc@240 PS2, Line 240: return; > warning: redundant return statement at the end of a function with a void re Done -- To view, visit http://gerrit.cloudera.org:8080/16387 To unsubscribe, visit http://gerrit.cloudera.org:8080/settings Gerrit-Project: kudu Gerrit-Branch: master Gerrit-MessageType: comment Gerrit-Change-Id: Iafc9cffa51964f81bc01fd8fcf1b6a79770a7838 Gerrit-Change-Number: 16387 Gerrit-PatchSet: 2 Gerrit-Owner: Andrew Wong <[email protected]> Gerrit-Reviewer: Andrew Wong <[email protected]> Gerrit-Reviewer: Kudu Jenkins (120) Gerrit-Reviewer: Tidy Bot (241) Gerrit-Comment-Date: Sun, 30 Aug 2020 01:33:33 +0000 Gerrit-HasComments: Yes
