> On 十一月 23, 2015, 2:40 a.m., Guangya Liu wrote:
> > src/master/allocator/mesos/hierarchical.cpp, line 171
> > <https://reviews.apache.org/r/40332/diff/2/?file=1135516#file1135516line171>
> >
> >     What about rename it to recoverQuota()?
> 
> Joris Van Remoortere wrote:
>     We want to have just a single recover function, just like other modules 
> in the master.
>     The fact that only quota is currently recovered in the hierarchical 
> allocator is a detail, not a constraint. Does this make more sense?
> 
> Alexander Rukletsov wrote:
>     It's true that now we recover only quota, but I would prefer to keep 
> `recover()` general. Other allocators (or we in the future) may use it for 
> something different.

Fair enough. I also consider the recover case, it is useful to recover a 
specified number of slave hosts for allocator before allocating resources.


- Guangya


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/40332/#review107539
-----------------------------------------------------------


On 十一月 23, 2015, 11:35 p.m., Alexander Rukletsov wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/40332/
> -----------------------------------------------------------
> 
> (Updated 十一月 23, 2015, 11:35 p.m.)
> 
> 
> Review request for mesos, Bernd Mathiske, Joerg Schad, Joris Van Remoortere, 
> Joseph Wu, and Qian Zhang.
> 
> 
> Bugs: MESOS-3981
>     https://issues.apache.org/jira/browse/MESOS-3981
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   src/master/allocator/mesos/hierarchical.hpp 
> 2a21364fdcaa4ec5e5567b9f367c14a1579b9a49 
>   src/master/allocator/mesos/hierarchical.cpp 
> aee8ced1fbfec8cf30cb939ff67fadfc6b08f37a 
> 
> Diff: https://reviews.apache.org/r/40332/diff/
> 
> 
> Testing
> -------
> 
> make check (Mac OS X 10.10.4)
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>

Reply via email to