-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45202/#review126083
-----------------------------------------------------------


Fix it, then Ship it!




Some minor style suggestions, and then we can commit this too.


src/tests/dynamic_weights_tests.cpp (line 467)
<https://reviews.apache.org/r/45202/#comment188992>

    s/UPDATED_WEIGHTS/UPDATED_WEIGHTS1/



src/tests/dynamic_weights_tests.cpp (line 498)
<https://reviews.apache.org/r/45202/#comment188993>

    s/UPDATED_WEIGHTS/UPDATED_WEIGHTS1/



src/tests/dynamic_weights_tests.cpp (line 550)
<https://reviews.apache.org/r/45202/#comment188994>

    UPDATED_WEIGHTS1



src/tests/dynamic_weights_tests.cpp (line 590)
<https://reviews.apache.org/r/45202/#comment188995>

    UPDATED_WEIGHTS1



src/tests/dynamic_weights_tests.cpp (line 622)
<https://reviews.apache.org/r/45202/#comment188996>

    UPDATED_WEIGHTS1



src/tests/master_allocator_tests.cpp (line 1519)
<https://reviews.apache.org/r/45202/#comment188997>

    Don't you at least know that one of these parameters is the master's pid?



src/tests/master_allocator_tests.cpp (line 1524)
<https://reviews.apache.org/r/45202/#comment188998>

    You should be able to assign the string directly with `flags.resources = 
agentResources;` and the Option constructor will handle conversion



src/tests/master_allocator_tests.cpp (lines 1593 - 1595)
<https://reviews.apache.org/r/45202/#comment188999>

    Set `using` statements at the beginning of the file so we don't need to 
have the entire namespace here for each class


- Adam B


On March 25, 2016, 2:13 a.m., Yongqiao Wang wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45202/
> -----------------------------------------------------------
> 
> (Updated March 25, 2016, 2:13 a.m.)
> 
> 
> Review request for mesos and Adam B.
> 
> 
> Bugs: MESOS-4881
>     https://issues.apache.org/jira/browse/MESOS-4881
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Add test for rescinding offer trriggered by updating weights.
> 
> 
> Diffs
> -----
> 
>   src/tests/dynamic_weights_tests.cpp 
> 6357cf42ec59c1388e95d6d808978918d5cd4a78 
>   src/tests/master_allocator_tests.cpp 
> b41ba2bda4d680f6fc42f525719973d56c11fe31 
>   src/tests/mesos.hpp aaef158e5784ce077ef60996ebbeb77b356b7c57 
> 
> Diff: https://reviews.apache.org/r/45202/diff/
> 
> 
> Testing
> -------
> 
> make && make check.
> 
> $ ./src/mesos-tests 
> --gtest_filter=MasterAllocatorTest/0.RebalancedForUpdatedWeights
> [==========] Running 1 test from 1 test case.
> [----------] Global test environment set-up.
> [----------] 1 test from MasterAllocatorTest/0, where TypeParam = 
> mesos::internal::master::allocator::MesosAllocator<mesos::internal::master::allocator::HierarchicalAllocatorProcess<mesos::internal::master::allocator::DRFSorter,
>  mesos::internal::master::allocator::DRFSorter> >
> [ RUN      ] MasterAllocatorTest/0.RebalancedForUpdatedWeights
> [       OK ] MasterAllocatorTest/0.RebalancedForUpdatedWeights (1059 ms)
> [----------] 1 test from MasterAllocatorTest/0 (1059 ms total)
> 
> [----------] Global test environment tear-down
> [==========] 1 test from 1 test case ran. (1070 ms total)
> [  PASSED  ] 1 test.
> 
> 
> Thanks,
> 
> Yongqiao Wang
> 
>

Reply via email to