-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45381/#review126360
-----------------------------------------------------------




src/Makefile.am 
<https://reviews.apache.org/r/45381/#comment189357>

    Please update cmakefile.txt as well.



src/slave/slave.hpp (line 549)
<https://reviews.apache.org/r/45381/#comment189358>

    Can you move this field to Http class because this is a limiter for the 
http endpoint. Also, `limiter` sounds too general. Maybe rename it?
    
    ```
    class Http {
    private:
      Slave* slave;
      RateLimiter statisticsLimiter;
    }
    
    ```



src/slave/slave.cpp (lines 5013 - 5051)
<https://reviews.apache.org/r/45381/#comment189403>

    Instead of putting the logic here, can you move it to 
Slave::Http::statistics?
    ```
    return slave->limiter.acquire()
        .then(defer(slave->self(), &Slave::usage))
        .then([=](const ResourceUsage& usage) {
          ...
        })
        .repair([](const Future<Response>& future) {
          LOG(WARNING) << ...;
          return InternalServerError();
        });
    ```


- Jie Yu


On March 30, 2016, 5:30 p.m., Jay Guo wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45381/
> -----------------------------------------------------------
> 
> (Updated March 30, 2016, 5:30 p.m.)
> 
> 
> Review request for mesos and Jie Yu.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> These two endpoints and their underlying logics are moved from
> ResourceMonitorProcess to slave process. ResourceMonitor is removed.
> 
> 
> Diffs
> -----
> 
>   src/Makefile.am f22ae5b3bd9336a56c802e0e51d39d6cb675caf2 
>   src/slave/http.cpp 7a872c6e21b115500c5291b7cb9fb240ec9dc8ed 
>   src/slave/monitor.hpp 70a7c88fefd4577f53f85e3eccdd6b69ab6f3acd 
>   src/slave/monitor.cpp 5c1dd354595e67e5eb8888603c5d49850f84b84b 
>   src/slave/slave.hpp 3ba335fcd31a92af9609023daae328b7f4bf5e59 
>   src/slave/slave.cpp fc77f594d16a9fb2ca001e089d74e2c0ffeb5baa 
>   src/tests/monitor_tests.cpp 5dcb2481ff2f1a7caf54036bc3e60c78feb982b1 
>   src/tests/oversubscription_tests.cpp 
> ba036810758d99a6fb0034c5e2bc7829e2343a44 
>   src/tests/slave_tests.cpp 57fc50360eae85819ae6ce714b0c3c4c1867b2b8 
> 
> Diff: https://reviews.apache.org/r/45381/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> https://issues.apache.org/jira/browse/MESOS-4891
> 
> 
> Thanks,
> 
> Jay Guo
> 
>

Reply via email to