-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/60015/#review178177
-----------------------------------------------------------


Ship it!





src/common/resources.cpp
Line 1041 (original), 1041 (patched)
<https://reviews.apache.org/r/60015/#comment252046>

    Personally, I think this is a bit more readable:
    
    ```
    if (isUnreserved(resource)) {
      return false;
    }
    
    return role.isNone() || role.get() == reservationRole(resource);
    ```


- Neil Conway


On June 13, 2017, 8:34 a.m., Michael Park wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/60015/
> -----------------------------------------------------------
> 
> (Updated June 13, 2017, 8:34 a.m.)
> 
> 
> Review request for mesos and Benjamin Mahler.
> 
> 
> Bugs: MESOS-7655
>     https://issues.apache.org/jira/browse/MESOS-7655
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Introduced a utility function `Resources::reservationRole`.
> 
> 
> Diffs
> -----
> 
>   include/mesos/resources.hpp be2e377ab9a7332adf373c585e5fafd47ce79f7e 
>   include/mesos/v1/resources.hpp fe62166f20088504bdf90a178d3e3b0a94cdc1ac 
>   src/common/resources.cpp cc305e64cadc9fab913ede987625fc1839646306 
>   src/v1/resources.cpp 03d6c8098a24a2751617d14f2664de1d88318414 
> 
> 
> Diff: https://reviews.apache.org/r/60015/diff/9/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Michael Park
> 
>

Reply via email to