-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/66311/#review200734
-----------------------------------------------------------




src/resource_provider/manager.cpp
Lines 65 (patched)
<https://reviews.apache.org/r/66311/#comment281579>

    Blank line prior to this one.



src/resource_provider/manager.cpp
Lines 201 (patched)
<https://reviews.apache.org/r/66311/#comment281580>

    Unnecessary namespaces, as `Registry` is in scope here. Here and in the 
implementation below.



src/resource_provider/manager.cpp
Lines 237 (patched)
<https://reviews.apache.org/r/66311/#comment281708>

    `registry` as name is a bit misleading, how about `recovered`?



src/resource_provider/manager.cpp
Lines 240 (patched)
<https://reviews.apache.org/r/66311/#comment281710>

    s/recovery/recover



src/resource_provider/registrar.cpp
Lines 97 (patched)
<https://reviews.apache.org/r/66311/#comment281584>

    `Registry` is in scope here and used without the namespace in other parts 
of this unit. Let's be consistent and drop the namespace here and below.


- Jan Schlicht


On April 10, 2018, 2:07 p.m., Benjamin Bannier wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/66311/
> -----------------------------------------------------------
> 
> (Updated April 10, 2018, 2:07 p.m.)
> 
> 
> Review request for mesos, Jie Yu and Jan Schlicht.
> 
> 
> Bugs: MESOS-8735
>     https://issues.apache.org/jira/browse/MESOS-8735
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This patch adjusts the control flow of the resource provider manager
> so that we can in the future make use of persisted resource provider
> information.
> 
> 
> Diffs
> -----
> 
>   src/resource_provider/manager.cpp 2d3ffcdd01671f81729fe538348f2ca4e555eb4f 
>   src/resource_provider/registrar.hpp 
> 39f45b0a2a7c35bfe72a9305f5248409e4a3ef45 
>   src/resource_provider/registrar.cpp 
> 9eb49f1327a0b598c5464a29a09ee286d7018f09 
>   src/tests/resource_provider_manager_tests.cpp 
> c52541bf130ccf4795b989b53331176a64a097ea 
> 
> 
> Diff: https://reviews.apache.org/r/66311/diff/3/
> 
> 
> Testing
> -------
> 
> `make check`
> 
> 
> Thanks,
> 
> Benjamin Bannier
> 
>

Reply via email to