-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/70116/#review213541
-----------------------------------------------------------




src/master/master.hpp
Lines 941-944 (patched)
<https://reviews.apache.org/r/70116/#comment299493>

    Is this used anywhere?



src/master/metrics.hpp
Lines 83 (patched)
<https://reviews.apache.org/r/70116/#comment299494>

    s/per operation/per operation type/



src/master/metrics.cpp
Lines 158-159 (original), 160-161 (patched)
<https://reviews.apache.org/r/70116/#comment299495>

    Should we add a similar metric for operation status updates?



src/master/metrics.cpp
Lines 174-177 (original), 176-179 (patched)
<https://reviews.apache.org/r/70116/#comment299496>

    Should we add a similar metrics for operation status updates?



src/master/metrics.cpp
Lines 386-388 (patched)
<https://reviews.apache.org/r/70116/#comment299497>

    This is weirdly formatted, I think the following follows the style guide 
and is more readable:
    
    ```
        if (type == Offer::Operation::UNKNOWN ||
            type == Offer::Operation::LAUNCH ||
            type == Offer::Operation::LAUNCH_GROUP) {
    ```



src/master/metrics.cpp
Lines 637-651 (patched)
<https://reviews.apache.org/r/70116/#comment299499>

    Can these counters be decremented? If not, should we add a CHECK to ensure 
that `delta` is always positive?



src/master/metrics.cpp
Lines 684 (patched)
<https://reviews.apache.org/r/70116/#comment299500>

    Can counters for terminal states be decremented? I guess not? If I'm 
correct, then we could add a `CHECK` here.


- Gastón Kleiman


On March 7, 2019, 9:01 a.m., Benno Evers wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/70116/
> -----------------------------------------------------------
> 
> (Updated March 7, 2019, 9:01 a.m.)
> 
> 
> Review request for mesos, Gastón Kleiman, Greg Mann, and Joseph Wu.
> 
> 
> Bugs: MESOS-8241
>     https://issues.apache.org/jira/browse/MESOS-8241
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This commit adds additional metrics counting the
> number of operations in each state.
> 
> Unit tests are added in the subsequent commit.
> 
> 
> Diffs
> -----
> 
>   src/master/master.hpp aceab3455adfdf7ff6e168e033316997a4d36fb5 
>   src/master/master.cpp 665c1c7979a5ae4ecec0d5a68e59c5419049a4d5 
>   src/master/metrics.hpp 4495e65b6bb11f7236335a702c4f61e7c3f9b0aa 
>   src/master/metrics.cpp 4dd73fb18a06ce8f75c4c1435dba84ade123bee9 
> 
> 
> Diff: https://reviews.apache.org/r/70116/diff/2/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Benno Evers
> 
>

Reply via email to