Github user andrewor14 commented on a diff in the pull request:
    --- Diff: core/src/main/scala/org/apache/spark/rdd/RDD.scala ---
    @@ -1589,7 +1589,8 @@ abstract class RDD[T: ClassTag](
        * This is introduced as an alias for `isCheckpointed` to clarify the 
semantics of the
        * return value. Exposed for testing.
    -  private[spark] def isCheckpointedAndMaterialized: Boolean = 
    +  private[spark] def isCheckpointedAndMaterialized: Boolean =
    +    checkpointData.exists(_.isCheckpointed)
    --- End diff --
    One way to fix the duplicate code is to make this one final and have 
`isCheckpointed` call this one, then implementations of RDD can feel free to 
override `isCheckpointed` without affecting our internal implementation.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to