Github user yanboliang commented on a diff in the pull request:
    --- Diff: R/pkg/tests/fulltests/test_mllib_regression.R ---
    @@ -173,6 +173,14 @@ test_that("spark.glm summary", {
       expect_equal(stats$df.residual, rStats$df.residual)
       expect_equal(stats$aic, rStats$aic)
    +  # Test spark.glm works with offset
    +  training <- suppressWarnings(createDataFrame(iris))
    +  stats <- summary(spark.glm(training, Sepal_Width ~ Sepal_Length + 
    +                             family = poisson(), offsetCol = 
    +  rStats <- suppressWarnings(summary(glm(Sepal.Width ~ Sepal.Length + 
    +                        data = iris, family = poisson(), offset = 
    --- End diff --
    I vote to keep the name as it is, because it's the column name of 
```offset``` rather than the ```offset``` itself. We would like to keep SparkR 
MLlib wrappers' argument name consistent with R only when it's applicable. I'm 
ok to create a new JIRA to discuss it. Thanks. 

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to