Github user HyukjinKwon commented on a diff in the pull request:
    --- Diff: 
    @@ -659,13 +660,19 @@ case class StructsToJson(
             (arr: Any) =>
    +      case MapType(_: DataType, _: StructType, _: Boolean) =>
    +        (map: Any) =>
    +          val mapType = child.dataType.asInstanceOf[MapType]
    +          gen.write(map.asInstanceOf[MapData], mapType)
    +          getAndReset()
       override def dataType: DataType = StringType
       override def checkInputDataTypes(): TypeCheckResult = child.dataType 
match {
    -    case _: StructType | ArrayType(_: StructType, _) =>
    +    case _: StructType | ArrayType(_: StructType, _) |
    +         MapType(_: DataType, _: StructType, _: Boolean) =>
    --- End diff --
    I am quite sure we keep compatibility in the name although it might be best 
to not change if possible. I think we can also add `prettyName` to `to_json` 
for the column name concern too.
    What do you think about renaming this in another minor PR or a followup 
just for less line diff, less complexity and for an easier review, considering 
this is his very first PR? I am also fine with doing this here if the opposite 
makes more sense to you.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to