Github user cloud-fan commented on the issue:
    I think `BusQueue` is a good abstraction, but we can still simplify other 
parts. My proposal:
    // Do we need a better name like ListenesGroup? it's very similar to the 
previous LiveListenerBus.
    class BusQueue extends SparkListenerBus {
      val eventQueue = ...
    class LiveListenerBus {
      val listenersGroups: Map[String, BusQueue] = ...
      def addListener(listener, groupName = "default") {
        val group = listenerGroups.getOrUpdate(groupName, new BusQueue ...)
      def post(event) {
        listenersGroups.foreach { case (_, group) =>


If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to