GitHub user cloud-fan opened a pull request:

    [SPARK-23317][SQL] rename ContinuousReader.setOffset to setStartOffset

    ## What changes were proposed in this pull request?
    In the document of `ContinuousReader.setOffset`, we say this method is used 
to specify the start offset. We also have a `ContinuousReader.getStartOffset` 
to get the value back. I think it makes more sense to rename 
`ContinuousReader.setOffset` to `setStartOffset`.
    ## How was this patch tested?

You can merge this pull request into a Git repository by running:

    $ git pull rename

Alternatively you can review and apply these changes as the patch at:

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #20486
commit b7f71b1c65a4261ad80dfc45816e03e71e0713ef
Author: Wenchen Fan <wenchen@...>
Date:   2018-02-02T10:41:27Z

    rename ContinuousReader.setOffset to setStartOffset



To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to