Hi Meik and Aaron,

On Thursday 16 October 2014 12:14:43 meik michalke wrote:
> @aaron: did you already see this happening before september 2014? if not:
> @thomas: can this be related to one of these commits:
>  - 4802
>  - 4803
>  - 4822
>  - 4834

an obvious guess. However, I don't see, how this would be the case. If you 
look at rkward_startup.cpp, you should find it simply mimicks, what we had, 
before. In particular it tried to launch org.freedesktop.dbus-session.plit, 
but not dbus-system.plist.

> > Well, in essence, this looks to me like something is trying to load
> > /Library/LaunchDaemons/org.freedesktop.dbus-system.plist as a regular
> > user.
> > This tries starting up the daemon, fails, tries again...
> another idea: is it possible that installing the RKWard bundle several times
> (upgrades) and therefore running the postinstall script several time
> somehow messes this up? i still don't have the best understanding of how
> these mac bundle packages actually work, as apple used so many different
> formats and the documentation is... sparse.

Something causing this to be called twice is another idea, in fact. On your 
university mac, the error message is a bit more verbose: 

Oct 16 11:08:10 RKWard-iMac org.freedesktop.dbus-system[78533]: Failed to 
start message bus: Failed to bind socket 
"/opt/rkward/var/run/dbus/system_bus_socket": Address already in use
Oct 16 11:08:10 RKWard-iMac com.apple.launchd.peruser.505[78521] 
(org.freedesktop.dbus-system[78533]): Exited with code: 1
Oct 16 11:08:10 RKWard-iMac com.apple.launchd.peruser.505[78521] 
(org.freedesktop.dbus-system): Throttling respawn: Will start in 10 seconds

So dbus-daemon --system is already running, but the launcher is trying to 
start it again, fails, and tries again...

Interestingly, on the university mac, the error message starts appearing today 
at 11:08:10. That's shortly, after I started playing with it. Looking at the 
process list, you can see that the current dbus-daemon stared at 10:49. That 
process came up automatically, when I tried killing the previous dbus-daemon 
process. Well, I tried a whole bunch of other things in between, but can't 
attach a timestamp to those.

One thing to check may be what happens after a reboot. Does the message start 
appearing right away, or only after doing something KDE-related?


Attachment: signature.asc
Description: This is a digitally signed message part.

Comprehensive Server Monitoring with Site24x7.
Monitor 10 servers for $9/Month.
Get alerted through email, SMS, voice calls or mobile push notifications.
Take corrective actions from your mobile device.
RKWard-devel mailing list

Reply via email to