Hi John,

On 29/09/17 00:19, John A wrote:
Hi all,

What I am aiming at is to be able to listen to the midi tracks being played through the korg in the headphones while recording vocal audio tracks through the microphone, but I am having trouble.

I am trying to record audio from a microphone into a track in Rosegarden 15.12. I have the track set to audio, and I have the instrument parameters set to 'in 1' and out to master. The input meter in the instrument parameters shows that signal from the mic is coming in. When I try to record that input onto the track, though, it only records the output of the other tracks, and not the vocal from the mic. These are midi tracks played through a korg keyboard. The keyboard and the mic are coming through the same interface, a scarlet focusrite.

If I understand correctly you connect both your Korg keyboard and a microphone to your Scarlett? Is the interface a 2i2? In that case you would maybe connect the keyboard to input 2 and the microphone to input 1. One important thing to remember, if that's your set-up, is that on the 2i2 those are *mono* inputs.. so you're going to have to connect 'capture_1' as jack most probably calls it (your input 1 on the Scarlett).

You could test this set-up by creating to audio tracks in rosegarden, then assigning 'In 1' as the Input for the first and 'In 2' for the second, arm the tracks (second led-like icon from the left in a a track, red colour) and record. In that case one track should record your keyboard the other one your mic.

Also something useful to know is that Rosegarden has 2 audio outputs is called 'record monitor out' (Left and Right respectively) which will output what is coming into the two record ins...

See here a screenshot of qjackctl connections with my Scarlett 2i2 connected and sending each mono input to each of the Record in inputs for rosegarden:

https://i.snag.gy/mlwbgo.jpg

Hope this helps.
Lorenzo.



It seemed to me that the 'recording filters' under 'track parameters' might be the place this should be fixed, but both 'device' and 'channel' are grayed out. I'm not sure what to try. Help would be greatly appreciated!

Thanks,


JA


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Rosegarden-user mailing list
Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Rosegarden-user mailing list
Rosegarden-user@lists.sourceforge.net - use the link below to unsubscribe
https://lists.sourceforge.net/lists/listinfo/rosegarden-user

Reply via email to