Hi again,

First:
"CUDA_SDK_ROOT_DIR-NOTFOUND"
"CUDA_nvcuvenc_LIBRARY-NOTFOUND"
Doesn't matter, i.e. these are not necessary for cmake to find the
necessary files.

Second:
If rtkcuda.lib is not in [your biuld directory]/bin/[Debug or Release]/ it
would mean something went wrong - probably in your configuration.
Make sure to enable CUDA in the RTK CMake config, i.e. tick "RTK_USE_CUDA".
Also, build RTK in the same configuration (release, debug or whatever) as
the project that depends on it (otherwise visual studio might complain)

If this does not solve your problem try to build the rtkcuda project (when
the entire solution is open in Visual studio) by itself and watch the
output for anything suspicious.

Beset regards
Andreas

__________________________________

Andreas Gravgaard Andersen

Department of Oncology,

Aarhus University Hospital

Nørrebrogade 44,

8000, Aarhus C

Mail:     andre...@phys.au.dk

Cell:      +45 3165 8140



On 24 February 2018 at 00:26, Daniel lee <lkylove2...@gmail.com> wrote:

> Dear Andersen
>
> There is no rtkcuda.lib in my RTK directory.
>
> Could you give me some tips to solve it?
>
> I will reinstall CUDA and build ITK, RTK again though.
>
> Thank you for your kind attention.
>
> Sincerely,
>
> K. Y. Daniel
>
> 2018-02-24 8:01 GMT+09:00 Daniel lee <lkylove2...@gmail.com>:
>
>> Thanks for your reply
>>
>> I have already configured, generated and built ITK and RTK. (without any
>> error)
>>
>> and I tried to do cmake inside of RTK directory that I made.
>>
>> Now I doubt that RTK is built properly or even CUDA 8.0.
>>
>> I tried to do all things again composedly, I get some option is not found
>>
>> CUDA_SDK_ROOT_DIR-NOTFOUND
>> CUDA_nvcuvenc_LIBRARY-NOTFOUND
>>
>> If it is possible, It will be very helpful for me to get screen shot of
>> proper cmake options from others
>>
>>
>> -Configuration
>> RTK-1.4.0
>> ITK4.13.0
>> MSVS2015 64bit
>>
>> My basic question is still open to help.
>>
>> Best regards,
>>
>> K.Y.Daniel Lee
>>
>>
>> 2018-02-24 5:48 GMT+09:00 Andreas Gravgaard Andersen <andre...@phys.au.dk
>> >:
>>
>>> Hi Daniel
>>>
>>> I'm not exactly sure what you attempted, but it could look like you were
>>> trying to make CMake configure the path 
>>> "E:/Source/RTK-1.4.0(ITK4.13.0)/examples"
>>> *alone*.
>>> In which case: You will need to configure, generate and build ITK and
>>> RTK first.
>>> Follow the instructions on http://wiki.openrtk.org/ind
>>> ex.php/RTK_wiki_help
>>> Start at "Step 0" and see if you have missed anything on the way.
>>>
>>> Best regards
>>> Andreas
>>>
>>>
>>> __________________________________
>>>
>>> Andreas Gravgaard Andersen
>>>
>>> Department of Oncology,
>>>
>>> Aarhus University Hospital
>>>
>>> Nørrebrogade 44,
>>> <https://maps.google.com/?q=N%C3%B8rrebrogade+44,+8000,+Aarhus+C&entry=gmail&source=g>
>>>
>>> 8000, Aarhus C
>>> <https://maps.google.com/?q=N%C3%B8rrebrogade+44,+8000,+Aarhus+C&entry=gmail&source=g>
>>>
>>> Mail:     andre...@phys.au.dk
>>>
>>> Cell:      +45 3165 8140
>>>
>>>
>>>
>>> On 23 February 2018 at 16:08, Daniel lee <lkylove2...@gmail.com> wrote:
>>>
>>>> Hi, I`m almost newbie for RTK.
>>>>
>>>>
>>>> When I try to configure example (e.g. HelloWorld or
>>>> FirstReconstruction), there is an error message like following.
>>>>
>>>> [image: 본문 이미지 1]
>>>>
>>>> I don`t have the file, RTKTargets.cmake.
>>>>
>>>>
>>>> I tried with RTK 1.4.0, ITK 4.13.0, VS2015
>>>>
>>>>
>>>> I`m just looking for someone who will help me to make it.
>>>>
>>>>
>>>> Sincerely
>>>>
>>>>
>>>> K.Y. Daniel Lee
>>>>
>>>>
>>>> _______________________________________________
>>>> Rtk-users mailing list
>>>> Rtk-users@public.kitware.com
>>>> https://public.kitware.com/mailman/listinfo/rtk-users
>>>>
>>>>
>>>
>>
>
_______________________________________________
Rtk-users mailing list
Rtk-users@public.kitware.com
https://public.kitware.com/mailman/listinfo/rtk-users

Reply via email to