Hello Iwase ,

I was able to find the ryu and ryu-manager scripts in the ryu installation .
 
-Ajay
-----Original Message-----
From: Iwase Yusuke [mailto:iwase.yusu...@gmail.com] 
Sent: 21 September 2016 18:42
To: Ajay Chopra <chop...@hcl.com>
Cc: ryu-devel@lists.sourceforge.net; ntqua...@gmail.com; Jayavel Arumugam (IT 
Services), Noida <jayav...@hcl.com>
Subject: Re: [Ryu-devel] Not able to install the RYU controller

Hi,

"ryu-manager" is one of the most important script of Ryu.
Mostly, Ryu applications should be loaded via "ryu-manager".

e.g.) ryu-manager --verbose ryu.app.simple_switch_13 
http://osrg.github.io/ryu-book/en/html/switching_hub.html#executing-the-switching-hub

And, AFAIK, "ryu-manager" should be installed as the component of Ryu, you need 
not install it separately.

Though I don't know if Ryu has been installed correctly in SDN Hub VM, I 
recommend to use Ryu (Ryu-Book) Docker images to try Ryu.
I guess it is the easiest way to try.
  https://hub.docker.com/r/osrg/ryu/
  https://hub.docker.com/r/osrg/ryu-book/

Thanks,
Iwase

On 2016年09月21日 19:57, Ajay Chopra wrote:
> Hello Iwase ,
> I am having few question regarding the RYU controller .
> What is the function  of Ryu-manager ?
> I wanted to know we need to install the Ryu-manager separately ? 
> Can you tell us where is Ryu-manager is installed ?
> How to start the Ryu controller ?
> Do you have any good tutorials on Ryu ?Commands .
>  
> -Ajay
> -----Original Message-----
> From: Ajay Chopra
> Sent: 16 September 2016 11:52
> To: ryu-devel@lists.sourceforge.net; Iwase Yusuke 
> <iwase.yusu...@gmail.com>
> Cc: ntqua...@gmail.com; Jayavel Arumugam (IT Services), Noida 
> <jayav...@hcl.com>
> Subject: RE: [Ryu-devel] Not able to install the RYU controller
> 
> HI ,
> 
> Thank you Iwase .I have contacted the SDN Hub team for my issue I am in 
> initial phase  of learning and understanding .
> They have suggested few steps will try and see if it works .
>  
> -Aj
> 
> -----Original Message-----
> From: Iwase Yusuke [mailto:iwase.yusu...@gmail.com]
> Sent: 16 September 2016 07:05
> To: Ajay Chopra <chop...@hcl.com>
> Cc: ryu-devel@lists.sourceforge.net; ntqua...@gmail.com; Jayavel 
> Arumugam (IT Services), Noida <jayav...@hcl.com>
> Subject: Re: [Ryu-devel] Not able to install the RYU controller
> 
> Hi,
> 
> Sorry, I don't know about "all-in-one package from SDN Hub".
> I can't guess what is the problem in this case.
> 
> It does not seem to be an official package of Ryu-devel and does not be 
> maintained by Ryu-devel.
> 
> How about trying to contact to SDN Hub team?
> 
> Thanks,
> Iwase
> 
> 
> On 2016年09月15日 20:54, Ajay Chopra wrote:
>> Hello Iwase ,
>>
>> I have got a all-in-one package from SDN Hub .
>> I am trying to run the command  .
>>
>> cd /home/ubuntu/ryu && ./bin/ryu-manager --verbose 
>> ryu/app/simple_switch_13.py
>>
>> Now in between running of this command it gets hanged ,can you let us know 
>> what the issue with it .
>>
>> -Ajay
>> -----Original Message-----
>> From: Iwase Yusuke [mailto:iwase.yusu...@gmail.com]
>> Sent: 30 August 2016 13:14
>> To: Ajay Chopra <chop...@hcl.com>
>> Cc: ryu-devel@lists.sourceforge.net; Jayavel Arumugam (IT Services), 
>> Noida <jayav...@hcl.com>; ntqua...@gmail.com
>> Subject: Re: [Ryu-devel] Not able to install the RYU controller
>>
>> Hi,
>>
>> I don't know much about the packages on RHEL and CentOS, though...
>>
>> You can install pip manually as follow.
>> $ wget https://bootstrap.pypa.io/get-pip.py
>> $ sudo python3.5 get-pip.py
>>
>> Thanks,
>> Iwase
>>
>>
>> On 2016年08月30日 16:30, Ajay Chopra wrote:
>>> Hi,
>>>
>>> Iwase -ys ,usr/local/bin/python3.5: No module named pip .
>>> But when I do -"sudo yum install git python-dev python-setuptools 
>>> python-pip" , it shows
>>>      -Package python-setuptools-0.6.10-3.el6.noarch already installed and 
>>> latest version
>>>      -No package python-pip available.
>>>      -Nothing to do
>>>
>>> So , I need to install which version of setup-tools and where I need 
>>> to copy it so that it can be picked by the python script.
>>>
>>> -Ajay
>>> -----Original Message-----
>>> From: Iwase Yusuke [mailto:iwase.yusu...@gmail.com]
>>> Sent: 30 August 2016 12:42
>>> To: Ajay Chopra <chop...@hcl.com>
>>> Cc: ryu-devel@lists.sourceforge.net; Jayavel Arumugam (IT Services), 
>>> Noida <jayav...@hcl.com>; ntqua...@gmail.com
>>> Subject: Re: [Ryu-devel] Not able to install the RYU controller
>>>
>>> Hi,
>>>
>>> If you have install Python3.5 and want to install Ryu to Python3.5, how 
>>> about the following?
>>>    $ python3.5 -m pip setuptools
>>>
>>> If the output is:
>>>    /usr/bin/python3.5: No module named pip you need to install setuptools 
>>> and pip into Python3.5 environment, first.
>>>
>>> Thanks,
>>> Iwase
>>>
>>>
>>> On 2016年08月30日 16:05, Ajay Chopra wrote:
>>>> The python2.7 -m pip setuptools  command  shows  .
>>>>
>>>> /usr/local/bin/python2.7: No module named pip
>>>>
>>>> -Ajay
>>>> -----Original Message-----
>>>> From: Ajay Chopra
>>>> Sent: 30 August 2016 12:33
>>>> To: ryu-devel@lists.sourceforge.net
>>>> Cc: ntqua...@gmail.com; Jayavel Arumugam (IT Services), Noida 
>>>> <jayav...@hcl.com>
>>>> Subject: RE: [Ryu-devel] Not able to install the RYU controller
>>>>
>>>> I have installed the Python Version 3.5 When I do the python --version it 
>>>> gives Python 3.5.0 .
>>>>
>>>> -Ajay
>>>>
>>>> -----Original Message-----
>>>> From: Iwase Yusuke [mailto:iwase.yusu...@gmail.com]
>>>> Sent: 30 August 2016 12:30
>>>> To: Ajay Chopra <chop...@hcl.com>
>>>> Cc: ryu-devel@lists.sourceforge.net; ntqua...@gmail.com; Jayavel 
>>>> Arumugam (IT Services), Noida <jayav...@hcl.com>
>>>> Subject: Re: [Ryu-devel] Not able to install the RYU controller
>>>>
>>>> Hi,
>>>>
>>>>> Location: /usr/lib/python2.6/site-packages
>>>>
>>>> This shows pip command still on python2.6.
>>>> Ryu cannot be installed correctly on python2.6.
>>>>
>>>> Could you install python2.7 or python3.4+?
>>>> How about the output of the following command?
>>>>    e.g.) with python2.7
>>>>      $ python2.7 -m pip setuptools
>>>>
>>>> If not, I recommend to upgrade python version or use virtualenv to create 
>>>> python2.7 or python3.4 environment.
>>>>
>>>> Thanks,
>>>> Iwase
>>>>
>>>>
>>>> On 2016年08月30日 15:43, Ajay Chopra wrote:
>>>>> Hello Iwase ,
>>>>>
>>>>> Getting the below message with command .
>>>>>
>>>>> I think its installed .
>>>>>
>>>>> Metadata-Version: 1.0
>>>>> Name: setuptools
>>>>> Version: 0.6rc11
>>>>> Summary: xxxx
>>>>> Home-page: xxx
>>>>> Author: xxx
>>>>> Author-email: xxx
>>>>> License: xxx
>>>>> Location: /usr/lib/python2.6/site-packages
>>>>> Requires:
>>>>> Classifiers:
>>>>>
>>>>> -Ajay
>>>>> -----Original Message-----
>>>>> From: Iwase Yusuke [mailto:iwase.yusu...@gmail.com]
>>>>> Sent: 30 August 2016 12:10
>>>>> To: Ajay Chopra <chop...@hcl.com>
>>>>> Cc: ntqua...@gmail.com; ryu-devel@lists.sourceforge.net; Jayavel 
>>>>> Arumugam (IT Services), Noida <jayav...@hcl.com>
>>>>> Subject: Re: [Ryu-devel] Not able to install the RYU controller
>>>>>
>>>>> Hi,
>>>>>
>>>>> Can you get the info for setuptools with "pip show setuptools" command?
>>>>> If can not, setuptools is not installed correctly.
>>>>>
>>>>> $ pip show setuptools
>>>>> ---
>>>>> Metadata-Version: 2.0
>>>>> Name: setuptools
>>>>> Version: 24.0.3
>>>>> Summary: Easily download, build, install, upgrade, and uninstall 
>>>>> Python packages
>>>>> Home-page: https://github.com/pypa/setuptools
>>>>> Author: Python Packaging Authority
>>>>> Author-email: distutils-...@python.org
>>>>>   ...(snip)
>>>>>
>>>>> Thanks,
>>>>> Iwase
>>>>>
>>>>>
>>>>> On 2016年08月30日 15:19, Ajay Chopra wrote:
>>>>>> Hello Quan,
>>>>>>
>>>>>> I have installed the setup tools ,still getting this error message .
>>>>>> can you tell us from where the setup tool is being picked ?
>>>>>>
>>>>>> -Ajay
>>>>>>
>>>>>> From: Quân Nguyễn Thanh [mailto:ntqua...@gmail.com]
>>>>>> Sent: 30 August 2016 07:53
>>>>>> To: Ajay Chopra <chop...@hcl.com>
>>>>>> Cc: ryu-devel@lists.sourceforge.net; Iwase Yusuke 
>>>>>> <iwase.yusu...@gmail.com>; Jayavel Arumugam (IT Services), Noida 
>>>>>> <jayav...@hcl.com>
>>>>>> Subject: Re: [Ryu-devel] Not able to install the RYU controller
>>>>>>
>>>>>> Hi Ajay,
>>>>>> I think you should install setuptools module. If you are using 
>>>>>> Ubuntu, you can install by command
>>>>>>
>>>>>> # apt-get install python-setuptools Thanks
>>>>>>
>>>>>> On Mon, Aug 29, 2016 at 3:19 PM, Ajay Chopra 
>>>>>> <chop...@hcl.com<mailto:chop...@hcl.com>> wrote:
>>>>>> Hello Iwase ,
>>>>>>
>>>>>> I have installed the latest version . I am still getting the Error 
>>>>>> message .
>>>>>> Exact error message is mentioned below .
>>>>>>
>>>>>> Traceback (most recent call last):
>>>>>>   File "setup.py", line 26, in <module>
>>>>>>     import setuptools
>>>>>> ImportError: No module named 'setuptools'
>>>>>>
>>>>>> -Ajay
>>>>>> -----Original Message-----
>>>>>> From: Iwase Yusuke
>>>>>> [mailto:iwase.yusu...@gmail.com<mailto:iwase.yusu...@gmail.com>]
>>>>>> Sent: 25 August 2016 13:01
>>>>>> To: Ajay Chopra <chop...@hcl.com<mailto:chop...@hcl.com>>
>>>>>> Cc:
>>>>>> ryu-devel@lists.sourceforge.net<mailto:ryu-devel@lists.sourceforge.
>>>>>> n
>>>>>> e
>>>>>> t
>>>>>>>
>>>>>> Subject: Re: [Ryu-devel] Not able to install the RYU controller
>>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> Ryu drops Python 2.6 support at this patch.
>>>>>>
>>>>>> https://github.com/osrg/ryu/commit/af5e6b5fb7bfcce070fb94c4615754
>>>>>> 6
>>>>>> a
>>>>>> 7
>>>>>> 0
>>>>>> 4
>>>>>> 53c34
>>>>>>
>>>>>> So, the latest Ryu might not work well on your environment.
>>>>>> Please install Python version 2.7, 3.4 or 3.5, first.
>>>>>>
>>>>>> To activate Python virtualenv, please refer to the following example.
>>>>>> e.g.)
>>>>>>    $ sudo pip install virtualenv
>>>>>>    $ virtualenv -p python2.7 venv
>>>>>>    $ source venv/bin/activate
>>>>>>    (venv) $ pip install .  # "sudo" is not required
>>>>>>    (venv) $ ryu-manager
>>>>>>
>>>>>> Thanks,
>>>>>> Iwase
>>>>>>
>>>>>>
>>>>>> On 2016年08月25日 15:16, Ajay Chopra wrote:
>>>>>>> This is not the exact message .I can tell you the exact message by 
>>>>>>> tomorrow as I am not in office today .
>>>>>>>
>>>>>>> I am using Linux machine ,python version 2.6 .
>>>>>>>
>>>>>>> How to set the virtual environment ?
>>>>>>>
>>>>>>> -Ajay
>>>>>>>
>>>>>>> -----Original Message-----
>>>>>>> From: Iwase Yusuke
>>>>>>> [mailto:iwase.yusu...@gmail.com<mailto:iwase.yusu...@gmail.com>]
>>>>>>> Sent: 25 August 2016 10:17
>>>>>>> To: Ajay Chopra <chop...@hcl.com<mailto:chop...@hcl.com>>
>>>>>>> Cc:
>>>>>>> ryu-devel@lists.sourceforge.net<mailto:ryu-devel@lists.sourceforge.
>>>>>>> n
>>>>>>> e
>>>>>>> t>
>>>>>>> Subject: Re: [Ryu-devel] Not able to install the RYU controller
>>>>>>>
>>>>>>> Hi,
>>>>>>>
>>>>>>> But, the message "setuptools not available" shows setup.py cannot use 
>>>>>>> setuptools.
>>>>>>>
>>>>>>> IIRC, I didn't see this message, "setuptools not available", before, is 
>>>>>>> this the exact message you got?
>>>>>>> Nothing hits with "setuptools not available" on Google.
>>>>>>>
>>>>>>> Which environment (e.g. OS, Python version, virtualenv or not) are you 
>>>>>>> using?
>>>>>>>
>>>>>>> Thanks,
>>>>>>> Iwase
>>>>>>>
>>>>>>> On 2016年08月25日 13:31, Ajay Chopra wrote:
>>>>>>>> Yes its being installed .
>>>>>>>>
>>>>>>>> -----Original Message-----
>>>>>>>> From: Iwase Yusuke
>>>>>>>> [mailto:iwase.yusu...@gmail.com<mailto:iwase.yusu...@gmail.com>
>>>>>>>> ]
>>>>>>>> Sent: 25 August 2016 09:36
>>>>>>>> To: Ajay Chopra <chop...@hcl.com<mailto:chop...@hcl.com>>
>>>>>>>> Cc:
>>>>>>>> ryu-devel@lists.sourceforge.net<mailto:ryu-devel@lists.sourceforge.
>>>>>>>> n
>>>>>>>> et>
>>>>>>>> Subject: Re: [Ryu-devel] Not able to install the RYU controller
>>>>>>>>
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> setuptools is one of required Python package.
>>>>>>>> Please confirm "python-setuptools" package is installed.
>>>>>>>>
>>>>>>>> Thanks,
>>>>>>>> Iwase
>>>>>>>>
>>>>>>>> On 2016年08月25日 12:11, Ajay Chopra wrote:
>>>>>>>>> Also I wanted to know from where the setuptools file being picked up 
>>>>>>>>> ?As this file is not present in the working directory .
>>>>>>>>>
>>>>>>>>> -Ajay
>>>>>>>>> -----Original Message-----
>>>>>>>>> From: Ajay Chopra
>>>>>>>>> Sent: 25 August 2016 08:34
>>>>>>>>> To:
>>>>>>>>> ryu-devel@lists.sourceforge.net<mailto:ryu-devel@lists.sourceforge.
>>>>>>>>> net>
>>>>>>>>> Cc: 'Iwase Yusuke'
>>>>>>>>> <iwase.yusu...@gmail.com<mailto:iwase.yusu...@gmail.com>>
>>>>>>>>> Subject: RE: [Ryu-devel] Not able to install the RYU 
>>>>>>>>> controller
>>>>>>>>>
>>>>>>>>> Hello Iwase ,
>>>>>>>>>
>>>>>>>>> Getting below message
>>>>>>>>>
>>>>>>>>> I am using the below commands “sudo python setup.py install “ its 
>>>>>>>>> error out with below message .
>>>>>>>>> " That ryu.hooks not available "
>>>>>>>>>  and when I run the command “python setup.py install” it gives the 
>>>>>>>>> error that "setuptools not available ".
>>>>>>>>>
>>>>>>>>> -Ajay
>>>>>>>>>
>>>>>>>>> -----Original Message-----
>>>>>>>>> From: Iwase Yusuke
>>>>>>>>> [mailto:iwase.yusu...@gmail.com<mailto:iwase.yusu...@gmail.com
>>>>>>>>> >
>>>>>>>>> ]
>>>>>>>>> Sent: 25 August 2016 07:15
>>>>>>>>> To: Ajay Chopra <chop...@hcl.com<mailto:chop...@hcl.com>>
>>>>>>>>> Cc:
>>>>>>>>> ryu-devel@lists.sourceforge.net<mailto:ryu-devel@lists.sourceforge.
>>>>>>>>> net>
>>>>>>>>> Subject: Re: [Ryu-devel] Not able to install the RYU 
>>>>>>>>> controller
>>>>>>>>>
>>>>>>>>> Hi,
>>>>>>>>>
>>>>>>>>> Please keep mailing list.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On 2016年08月24日 19:01, Ajay Chopra wrote:
>>>>>>>>>> Hello Iwase ,
>>>>>>>>>>
>>>>>>>>>> I have copied the RYU and can you help .
>>>>>>>>>> Getting the same error message after that as-well .
>>>>>>>>>
>>>>>>>>> What error message did you get?
>>>>>>>>> On the previous message, No error message seems to be attached.
>>>>>>>>>    https://sourceforge.net/p/ryu/mailman/message/35296178/
>>>>>>>>>
>>>>>>>>> Thanks,
>>>>>>>>> Iwase
>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> -Ajay
>>>>>>>>>> -----Original Message-----
>>>>>>>>>> From: Iwase Yusuke
>>>>>>>>>> [mailto:iwase.yusu...@gmail.com<mailto:iwase.yusu...@gmail.co
>>>>>>>>>> m
>>>>>>>>>>>
>>>>>>>>>> ]
>>>>>>>>>> Sent: 24 August 2016 06:36
>>>>>>>>>> To: Ajay Chopra <chop...@hcl.com<mailto:chop...@hcl.com>>
>>>>>>>>>> Cc:
>>>>>>>>>> ryu-devel@lists.sourceforge.net<mailto:ryu-devel@lists.source
>>>>>>>>>> f
>>>>>>>>>> o
>>>>>>>>>> r
>>>>>>>>>> g
>>>>>>>>>> e
>>>>>>>>>> .net>
>>>>>>>>>> Subject: Re: [Ryu-devel] Not able to install the RYU 
>>>>>>>>>> controller
>>>>>>>>>>
>>>>>>>>>> Hi,
>>>>>>>>>>
>>>>>>>>>> Could you check the following?
>>>>>>>>>> http://osrg.github.io/ryu-book/en/html/switching_hub.html#execution-of-ryu-application
>>>>>>>>>>   Installation procedure
>>>>>>>>>>     $ sudo apt-get install git python-dev python-setuptools 
>>>>>>>>>> python-pip
>>>>>>>>>>     $ git clone https://github.com/osrg/ryu.git
>>>>>>>>>>     $ cd ryu
>>>>>>>>>>     $ sudo pip install .
>>>>>>>>>>   (snip)
>>>>>>>>>>
>>>>>>>>>> Thanks,
>>>>>>>>>> Iwase
>>>>>>>>>>
>>>>>>>>>> On 2016年08月23日 19:01, Ajay Chopra wrote:
>>>>>>>>>>> Hello ,
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> I have tried to install the RYU controller .
>>>>>>>>>>>
>>>>>>>>>>> I am using the below commands “sudo python setup.py install 
>>>>>>>>>>> “ its error out with below message
>>>>>>>>>>>
>>>>>>>>>>> That ryu.hooks not available and when I run the command “python 
>>>>>>>>>>> setup.py install” it gives the error that setuptools not available .
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> Please give the response as soon as possible we are in the middle 
>>>>>>>>>>> of installing the controller .
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> -Ajay
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> ::DISCLAIMER::
>>>>>>>>>>> ------------------------------------------------------------
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> ------------------------------------------------------------
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> --------
>>>>>>>>>>>
>>>>>>>>>>> The contents of this e-mail and any attachment(s) are confidential 
>>>>>>>>>>> and intended for the named recipient(s) only.
>>>>>>>>>>> E-mail transmission is not guaranteed to be secure or 
>>>>>>>>>>> error-free as information could be intercepted, corrupted, 
>>>>>>>>>>> lost, destroyed, arrive late or incomplete, or may contain viruses 
>>>>>>>>>>> in transmission. The e mail and its contents (with or without 
>>>>>>>>>>> referred errors) shall therefore not attach any liability on the 
>>>>>>>>>>> originator or HCL or its affiliates.
>>>>>>>>>>> Views or opinions, if any, presented in this email are 
>>>>>>>>>>> solely those of the author and may not necessarily reflect 
>>>>>>>>>>> the views or opinions of HCL or its affiliates. Any form of 
>>>>>>>>>>> reproduction, dissemination, copying, disclosure, modification, 
>>>>>>>>>>> distribution and / or publication of this message without the prior 
>>>>>>>>>>> written consent of authorized representative of HCL is strictly 
>>>>>>>>>>> prohibited. If you have received this email in error please delete 
>>>>>>>>>>> it and notify the sender immediately.
>>>>>>>>>>> Before opening any email and/or attachments, please check them for 
>>>>>>>>>>> viruses and other defects.
>>>>>>>>>>>
>>>>>>>>>>> ------------------------------------------------------------
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> ------------------------------------------------------------
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> --------
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> ------------------------------------------------------------
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> -
>>>>>>>>>>> --------
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> _______________________________________________
>>>>>>>>>>> Ryu-devel mailing list
>>>>>>>>>>> Ryu-devel@lists.sourceforge.net<mailto:Ryu-devel@lists.sourc
>>>>>>>>>>> e
>>>>>>>>>>> f
>>>>>>>>>>> o
>>>>>>>>>>> r g e.net>
>>>>>>>>>>> https://lists.sourceforge.net/lists/listinfo/ryu-devel
>>>>>>>>>>>
>>>>>>>> ---------------------------------------------------------------
>>>>>>>> -
>>>>>>>> -
>>>>>>>> -
>>>>>>>> -
>>>>>>>> -
>>>>>>>> -
>>>>>>>> -
>>>>>>>> -------- _______________________________________________
>>>>>>>> Ryu-devel mailing list
>>>>>>>> Ryu-devel@lists.sourceforge.net<mailto:Ryu-devel@lists.sourceforge.
>>>>>>>> n
>>>>>>>> et> https://lists.sourceforge.net/lists/listinfo/ryu-devel
>>>>>>>>
>>>>>>> ----------------------------------------------------------------
>>>>>>> -
>>>>>>> -
>>>>>>> -
>>>>>>> -
>>>>>>> -
>>>>>>> -
>>>>>>> -------- _______________________________________________
>>>>>>> Ryu-devel mailing list
>>>>>>> Ryu-devel@lists.sourceforge.net<mailto:Ryu-devel@lists.sourceforge.
>>>>>>> n
>>>>>>> e
>>>>>>> t> https://lists.sourceforge.net/lists/listinfo/ryu-devel
>>>>>>>
>>>>>> -----------------------------------------------------------------
>>>>>> -
>>>>>> -
>>>>>> -
>>>>>> -
>>>>>> -
>>>>>> -------- _______________________________________________
>>>>>> Ryu-devel mailing list
>>>>>> Ryu-devel@lists.sourceforge.net<mailto:Ryu-devel@lists.sourceforge.
>>>>>> n
>>>>>> e
>>>>>> t
>>>>>>> https://lists.sourceforge.net/lists/listinfo/ryu-devel
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> Best regards,
>>>>>> Quan Nguyen
>>>>>>
>>>> -------------------------------------------------------------------
>>>> -
>>>> -
>>>> -
>>>> -------- _______________________________________________
>>>> Ryu-devel mailing list
>>>> Ryu-devel@lists.sourceforge.net
>>>> https://lists.sourceforge.net/lists/listinfo/ryu-devel
>>>>
>> ---------------------------------------------------------------------
>> -
>> -------- _______________________________________________
>> Ryu-devel mailing list
>> Ryu-devel@lists.sourceforge.net
>> https://lists.sourceforge.net/lists/listinfo/ryu-devel
>>
------------------------------------------------------------------------------
_______________________________________________
Ryu-devel mailing list
Ryu-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/ryu-devel

Reply via email to