I forgot to say this is in sage.groups.libgap_wrapper On Friday, February 9, 2018 at 9:45:50 AM UTC+1, Simon Brandhorst wrote: > > Currently: > > def is_subgroup(self): > """ > Return whether the group was defined as a subgroup of a bigger > group. > > You can access the containing group with :meth:`ambient`. > > OUTPUT: > > Boolean. > > EXAMPLES:: > > sage: G = FreeGroup(3) > sage: G.is_subgroup() > False > """ > return self._ambient is not None > > > But in any sensible derived class i would expect > > def is_subgroup(self, other): > """ > Returns "True" if "self" is a subgroup of "other". > """ > > The suggestion is to change the name of he first method to > "is_defined_as_subgroup" >
-- You received this message because you are subscribed to the Google Groups "sage-devel" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]. To post to this group, send email to [email protected]. Visit this group at https://groups.google.com/group/sage-devel. For more options, visit https://groups.google.com/d/optout.
