I simply ran 'make'.

Updating Xcode fixed the issue.

On Wednesday, March 7, 2018 at 12:04:47 AM UTC-5, Dima Pasechnik wrote:
> On Tuesday, March 6, 2018 at 11:56:59 PM UTC, Matthew Lancellotti wrote:
>> sage: latest version (8.1) (from https://github.com/sagemath/sage, last 
>> updated Dec 17, 2017).  tried both master branch and develop branch.
>> OS: Mac OSX 10.13.3
>> Xcode version 9.0.1
>> I cloned the latest version of sage from the git repository.  When 
>> attempting to `make` sage, I run into the error `The following package(s) 
>> may have failed to build...gfortran-7.2.0`.  I will attach the log file 
>> shortly.  Near the bottom of the file it says:
>>     The directory that should contain system headers does not exist:
>>       /usr/include
>>     make[5]: *** [stmp-fixinc] Error 1
>>     make[5]: *** Waiting for unfinished jobs....
>>     rm gcc.pod gfortran.pod
>>     make[4]: *** [all-gcc] Error 2
>>     make[3]: *** [all] Error 2
>> I tried using brew to manually install gfortran.  Brew said that it ships 
>> with gcc.  I used brew to update my system to the latest version of gcc.  
>> It didn't help.  Currently, I am updating my Xcode to 9.2 to see if that 
>> helps.  Also, should my "system headers" exist?  If so, where are they?
> System headers should be in /usr/include
> You also need XCode's command line tools to be installed.
> It could be that presence of Homebrew in your PATH breaks things.
> As well, please tell us the sequence of commands you executed.
> Did you run ./bootstrap and
> ./configure (with what parameters?)
> before running make?

You received this message because you are subscribed to the Google Groups 
"sage-support" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sage-support+unsubscr...@googlegroups.com.
To post to this group, send email to sage-support@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-support.
For more options, visit https://groups.google.com/d/optout.

Reply via email to