#17581: resolvable BIBD
-------------------------------------+-------------------------------------
       Reporter:  ncohen             |        Owner:
           Type:  enhancement        |       Status:  positive_review
       Priority:  major              |    Milestone:  sage-6.5
      Component:  combinatorial      |   Resolution:
  designs                            |    Merged in:
       Keywords:                     |    Reviewers:
        Authors:  Nathann Cohen      |  Work issues:
Report Upstream:  N/A                |       Commit:
         Branch:                     |  6ec96bfe78beb32322dd37792b8712432f2efd64
  u/vdelecroix/17581                 |     Stopgaps:
   Dependencies:                     |
-------------------------------------+-------------------------------------
Changes (by ncohen):

 * status:  needs_review => positive_review


Comment:

 Yo !

 > See my commit at `u/vdelecroix/17581`.

 Looks good. About the example of KTS at the beginning of the doc: I tried
 to write it in such a way that it is both informative and readable by
 users. Yours is prettier indeed, but.. Clearly harder to read. Anyway
 let's talk about this before it is changed, next time.

 > 1) Why not return an object with type `BalancedIncompleteBlockDesign`.
 That way you can add to the examples `.is_resolvable()`. (moreover,
 contrarily to the others `v_4_1_rbibd` does!?)

 I do not understand your sentence. Where isn't a
 `BalancedIncompleteBlockDesign` object returned?

 > 2) The lines
 > {{{
 > bla.extend([a**(i+j0),a**(i+j1),a**(i+j2)] for i in a_big_list])
 > }}}

 AHahah. Well compared to the complexity of other parts of the algorithm I
 am sure that it makes no difference. By the way isn't it a `nlog(n)`
 complexity ? Exponents are cheap.

 > 3) I used `discrete_log` where you did a `while` loop... should be
 faster.

 Oh thanks, I did not know that we had that. There must be some other spot
 where it is needed in the code then, for I am sure that I missed it once
 at least.

 Assuming that you see nothing else to change, I set this ticket to
 `positive_review`. Thanks for your help again, there would be no design
 code in Sage if not for that `^^;`

 Nathann

--
Ticket URL: <http://trac.sagemath.org/ticket/17581#comment:10>
Sage <http://www.sagemath.org>
Sage: Creating a Viable Open Source Alternative to Magma, Maple, Mathematica, 
and MATLAB

-- 
You received this message because you are subscribed to the Google Groups 
"sage-trac" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
Visit this group at http://groups.google.com/group/sage-trac.
For more options, visit https://groups.google.com/d/optout.

Reply via email to