> 
> placing library functions is very error prone. A new developer should not
> need to read all the code to contribute to the project and he should be
> able to assume that standard functions behave normally.
> We can call it scidBindMouseWheel or consistentBindMouseWheel or
> nofocusBindMouseWheel, etc..
>

You have a point about the standard functions. "bindMouseWheel" should be
enough as a name.


I believe the best thing to proceed is:
> 1) start from scratch, that is with a patch that remove the focus stealing
> and all the mousewheel bind
> 2) test and list all the unwanted behaviors
> 3) adapt and change the name of ttk_bindMouseWheel so that we can call
> ttk_bindMouseWheel .main somecallback to allow the use of mousewheel to
> change the position of a game
> - ttk_bindMouseWheel to scroll the gamelist
> - ttk_bindMouseWheel to change the position of a gbrowser window
> - ttk_bindMouseWheel to scroll all the autoscrollframe
> 4) adapt the ttk_bindMouseWheel to work as we want on Windows (deliver the
> event to the window under the mouse and not to the windows with the focus)
>

I think bindMouseWheel adaptation should be the base for the rest of work
because MouseWheel events are sent to the wrong windows in the first place.

On the other hand, gamescroll will need a callback if you want to use
bindMouseWheel also for it, and this can be done as a new patch. However, I
don't think that adding the "break" in bindMouseWheel is the right approach
for every window. That's why I would suggest to add these modifications as
new patches to make sure they preserve or give the desired behaviour.

See if fix_mouse_wheel2 branch is better suited as base for new work.

Cristian
------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Scid-users mailing list
Scid-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/scid-users

Reply via email to