On Mar 22, 2014, at 06:11 , Denice wrote:

> On Fri, 21 Mar 2014, Denice wrote:
> 
>> On Fri, 21 Mar 2014, Konstantin Olchanski wrote:
>> 
>>> I see an odd problem with installing SL 6.5. (I use my USB installer, see 
>>> my other message about it).
>>> The installation works okey, boots into linux okey, login to root okey, but 
>>> "emacs" does
>>> not work because "libotf" is not installed. This is very strange because 
>>> libotf is listed
>>> as a dependancy for the "emacs" package. "yum install libotf" fixes emacs.
>>> Does anybody else see this?
>> 
>> Looks like an old problem - I saw it with SL 6.2 or 6.3 I believe. It should 
>> be gone with 6.5
>> 
>> 2 different packages at one time provided libotf.so.*:
>> libotf
>> openmpi-psm
>> 
>> openmpi-psm is gone in later SL versions, so the problem doesn't
>> occur - at least I haven't seen it for some time.
> 
> nope - I just made a query, and the issue is still there but with a
> different RPM name:
> 
> $ cd  /triumfcs/mirror/scientificlinux.org/6.5/x86_64/os/Packages
> $ rpm -qp *.rpm --qf='[%{NAME} %{PROVIDES}\n]' |grep libotf.so.
> compat-openmpi libotf.so.0
> compat-openmpi libotf.so.0()(64bit)
> compat-openmpi-psm libotf.so.0()(64bit)
> libotf libotf.so.0
> libotf libotf.so.0()(64bit)
> 
> So I guess whether you trip on this depends on what you are trying
> to pull in with an installation.

And the problem is new in 6.5. Earlier compat-openmpi packages don't have that 
problem.

NB the old BZ for openmpi was #768457 .

-- 
Stephan Wiesand
DESY -DV-
Platanenenallee 6
15738 Zeuthen, Germany

Reply via email to