[lng-odp] [Bug 1337] New: No means of knowing the size of the CPU mask (odp_cpumask_t)

2015-03-11 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1337 Bug ID: 1337 Summary: No means of knowing the size of the CPU mask (odp_cpumask_t) Product: OpenDataPlane Version: 1.0 Hardware: Other OS: Linux Statu

[lng-odp] [PATCH] validation: pktio check return code for pool_destroy

2015-03-11 Thread Maxim Uvarov
Fix CID 88056 to check return code of pool_destroy. Signed-off-by: Maxim Uvarov --- test/validation/odp_pktio.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/test/validation/odp_pktio.c b/test/validation/odp_pktio.c index 6359452..e022c33 100644 --- a/test/validation/odp_pk

[lng-odp] proto flags set functions

2015-03-11 Thread Radu-Andrei Bulie
Hi, Regarding the functions that set the proto flags (e.g odp_packet_has_xx_set) isn't more suitable not to pass an int value as second parameter, in fact not to have any parameter at all because howsoever inside the function we have some bit fields, and setting protos would mean just shifti

[lng-odp] [Bug 1168] odp_schedule test can create more threads than ODP_CONFIG_MAX_THREADS

2015-03-11 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1168 --- Comment #1 from Ciprian Barbu --- The bug was eventually fixed by Petri: https://git.linaro.org/lng/odp.git/commit/70bd7de7182eaae5c920979e4d25cb512e6fffb8 -- You are receiving this mail because: You are on the CC list for the bug.___

Re: [lng-odp] [PATCH] validation: pktio check return code for pool_destroy

2015-03-11 Thread Stuart Haslam
On Wed, Mar 11, 2015 at 11:36:25AM +0300, Maxim Uvarov wrote: > Fix CID 88056 to check return code of pool_destroy. > > Signed-off-by: Maxim Uvarov Reviewed-by: Stuart Haslam > --- > test/validation/odp_pktio.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/test/val

Re: [lng-odp] proto flags set functions

2015-03-11 Thread Taras Kondratiuk
On 03/11/2015 10:37 AM, Radu-Andrei Bulie wrote: Hi, Regarding the functions that set the proto flags (e.g *odp_packet_has_xx_set*) isn’t more suitable not to pass an int value as second parameter, in fact not to have any parameter at all because howsoever inside the function we have some bit

[lng-odp] [Bug 1340] New: CID 88056: Error handling issues: odp_pktio.c

2015-03-11 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1340 Bug ID: 1340 Summary: CID 88056: Error handling issues: odp_pktio.c Product: OpenDataPlane Version: 1.0 Hardware: Other OS: Linux Status: UNCONFIRMED Severity:

[lng-odp] ODP_v1.0 @ Regarding adding some file say demo.c and demo.h in platform/linux-genic and platform/linux-genic/include

2015-03-11 Thread Ayushman Kashyap
Hi I want to add some file in *platform/linux-generic* and *platform/linux-genic/include*. But Not able to compile simple case. Please see the scenario . I have a file say: * demo.c: * #include #include int get_sys_page_size() { int page_size; page_size = getpagesize();

Re: [lng-odp] odp_cpu_count() vs odp_cpumask size

2015-03-11 Thread Savolainen, Petri (Nokia - FI/Espoo)
CPU IDs are system dependent. So e.g. odp_cpu_count() == 2 would not necessarily result a cpumask with cpus 0 and 1 set, but e.g. cpus 7 and 17 set. Typically, the mask comes from user/system level (user has decided to run the ODP app on cpus 7 and 17). We may need two new functions: /** * @re

Re: [lng-odp] odp_cpu_count() vs odp_cpumask size

2015-03-11 Thread Savolainen, Petri (Nokia - FI/Espoo)
Actually, this is equal to odp_cpu_max(): odp_cpumask_t mask; odp_cpu_mask(&mask) odp_cpumask_last(&mask) So maybe odp_cpu_mask() is only new thing we need. -Petri From: lng-odp-boun...@lists.linaro.org [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of ext Savolainen, Petri (Nokia - FI/E

Re: [lng-odp] [PATCH] example: odp_ipsec: fix missing definition for ifreq

2015-03-11 Thread Ola Liljedahl
On 11 March 2015 at 10:58, Ciprian Barbu wrote: > On Tue, Mar 10, 2015 at 7:19 PM, Ola Liljedahl > wrote: > > On 10 March 2015 at 17:11, Ciprian Barbu > wrote: > >> On Tue, Mar 10, 2015 at 6:06 PM, Ciprian Barbu < > ciprian.ba...@linaro.org> wrote: > >>> On Tue, Mar 10, 2015 at 4:31 PM, Maxim U

[lng-odp] [PATCH 2/3] linux-geneirc: timer: remove ifdefs inside function from timer_cancel

2015-03-11 Thread Maxim Uvarov
Using ifdefs inside function make it hard to read. No functional changes. Signed-off-by: Maxim Uvarov --- platform/linux-generic/odp_timer.c | 19 --- 1 file changed, 16 insertions(+), 3 deletions(-) diff --git a/platform/linux-generic/odp_timer.c b/platform/linux-generic/odp_t

[lng-odp] [PATCH 1/3] linux-generic: timer simplify timer_expire

2015-03-11 Thread Maxim Uvarov
Current timer_expire() function implementation for linux-generic is too long and complex. This patch makes it simple to read. No functional changes. Signed-off-by: Maxim Uvarov --- platform/linux-generic/odp_timer.c | 102 ++--- 1 file changed, 61 insertions(+), 4

[lng-odp] [PATCH 0/3] simplify linux-generic timer code

2015-03-11 Thread Maxim Uvarov
This patchset is propose to simplify current linux-genric timer code. There are no functional changes, just removing ifdef from function body. After that changes function looks much more simple, at least now I can understand what do they do. Maxim. Maxim Uvarov (3): linux-generic: timer simplif

[lng-odp] [PATCH 3/3] linux-generic: timer: remove atomic ifdef from timer_reset() function body

2015-03-11 Thread Maxim Uvarov
No functional changes, just make code more readable. Signed-off-by: Maxim Uvarov --- platform/linux-generic/odp_timer.c | 76 +++--- 1 file changed, 54 insertions(+), 22 deletions(-) diff --git a/platform/linux-generic/odp_timer.c b/platform/linux-generic/odp_ti

Re: [lng-odp] [PATCH] linux-generic: odp_timer: set user_ptr for cancelled timeout

2015-03-11 Thread Maxim Uvarov
On 03/10/15 18:46, Ola Liljedahl wrote: On 10 March 2015 at 16:11, Maxim Uvarov wrote: On 03/10/15 18:08, Ola Liljedahl wrote: On 10 March 2015 at 15:59, Maxim Uvarov wrote: On 03/10/15 17:43, Ola Liljedahl wrote: Ensure that the timeout user_ptr and timer fields are set when the correspond

Re: [lng-odp] [PATCH] example: odp_ipsec: fix missing definition for ifreq

2015-03-11 Thread Ciprian Barbu
On Wed, Mar 11, 2015 at 2:12 PM, Ola Liljedahl wrote: > On 11 March 2015 at 10:58, Ciprian Barbu wrote: >> >> On Tue, Mar 10, 2015 at 7:19 PM, Ola Liljedahl >> wrote: >> > On 10 March 2015 at 17:11, Ciprian Barbu >> > wrote: >> >> On Tue, Mar 10, 2015 at 6:06 PM, Ciprian Barbu >> >> wrote: >>

Re: [lng-odp] [KEYSTONE2 PATCH 06/15] linux-ks2: init: fix a minimal library build

2015-03-11 Thread Maxim Uvarov
On 03/10/15 18:31, Taras Kondratiuk wrote: int odp_init_global(odp_init_t *params ODP_UNUSED, odp_platform_init_t *platform_params ODP_UNUSED) { + odp_proc.log_fn = odp_override_log; + odp_proc.abort_fn = odp_override_abort; + + if (params != NULL) { +

[lng-odp] [PATCH] validation: schedule: code clean up

2015-03-11 Thread Petri Savolainen
Cleaned up usage of buf count, thread args and globals. Signed-off-by: Petri Savolainen --- test/validation/odp_schedule.c | 102 - 1 file changed, 49 insertions(+), 53 deletions(-) diff --git a/test/validation/odp_schedule.c b/test/validation/odp_schedul

[lng-odp] [PATCH] example: odp_ipsec: remove USE_MAC_ADDR_HACK

2015-03-11 Thread Ciprian Barbu
Remove the old hack and switch to using the provided API This also fixes https://bugs.linaro.org/show_bug.cgi?id=1330 Signed-off-by: Ciprian Barbu --- example/ipsec/odp_ipsec.c | 58 ++- 1 file changed, 2 insertions(+), 56 deletions(-) diff --git a/ex

Re: [lng-odp] [PATCH] example: odp_ipsec: fix missing definition for ifreq

2015-03-11 Thread Bala Manoharan
On 11 March 2015 at 18:31, Ciprian Barbu wrote: > So after a little chat we had, Maxim suggested I remove the ioctl code > that needs struct ifreq. There is a USE_MAC_ADDR_HACK define in > odp_ipsec that is now set to 1, removing all that code should fix the > problem. > > The problem was describe

Re: [lng-odp] [PATCH] linux-generic: odp_timer: set user_ptr for cancelled timeout

2015-03-11 Thread Ola Liljedahl
On 11 March 2015 at 13:16, Maxim Uvarov wrote: > On 03/10/15 18:46, Ola Liljedahl wrote: > >> On 10 March 2015 at 16:11, Maxim Uvarov wrote: >> >>> On 03/10/15 18:08, Ola Liljedahl wrote: >>> On 10 March 2015 at 15:59, Maxim Uvarov wrote: > On 03/10/15 17:43, Ola Liljedahl wr

Re: [lng-odp] [PATCH] linux-generic: odp_timer: set user_ptr for cancelled timeout

2015-03-11 Thread Mike Holmes
Can we take this off line, it is straying from a technical discussion. On 11 March 2015 at 09:29, Ola Liljedahl wrote: > On 11 March 2015 at 13:16, Maxim Uvarov wrote: > >> On 03/10/15 18:46, Ola Liljedahl wrote: >> >>> On 10 March 2015 at 16:11, Maxim Uvarov wrote: >>> On 03/10/15 18:08,

Re: [lng-odp] [PATCH] linux-generic: odp_timer: set user_ptr for cancelled timeout

2015-03-11 Thread Savolainen, Petri (Nokia - FI/Espoo)
> -Original Message- > From: lng-odp-boun...@lists.linaro.org [mailto:lng-odp- > boun...@lists.linaro.org] On Behalf Of ext Ola Liljedahl > Sent: Tuesday, March 10, 2015 4:44 PM > To: lng-odp@lists.linaro.org > Subject: [lng-odp] [PATCH] linux-generic: odp_timer: set user_ptr for > cancel

[lng-odp] [PATCH 1/3] example: odp_l2fwd: replace strtok_r with strtok and fix leaks

2015-03-11 Thread Ciprian Barbu
The odp_l2fwd example leaks some strings allocated during parse_args. https://bugs.linaro.org/show_bug.cgi?id=1117 CID 56899: Resource leak (RESOURCE_LEAK) Signed-off-by: Ciprian Barbu --- example/l2fwd/odp_l2fwd.c | 29 +++-- 1 file changed, 15 insertions(+), 14 deleti

[lng-odp] [PATCH 2/3] example: odp_ipsec: replace strtok_r with strtok and fix leaks

2015-03-11 Thread Ciprian Barbu
The odp_ipsec example leaks some strings allocated during parse_args. https://bugs.linaro.org/show_bug.cgi?id=1117 CID 56899: Resource leak (RESOURCE_LEAK) Signed-off-by: Ciprian Barbu --- example/ipsec/odp_ipsec.c | 30 ++ 1 file changed, 14 insertions(+), 16 delet

[lng-odp] [PATCH 0/3] Fix the leaks in examples (bug 1117)

2015-03-11 Thread Ciprian Barbu
This series continues the patch I sent some while ago to replace strtok with strtok_r in odp_pktio: https://git.linaro.org/lng/odp.git/commit/273955e6db6bb220f2736d3709e4237c50d04772 The bug that this series fixes only refers to resource leaks, but the initial strtok_r fix should have been done fo

[lng-odp] [Bug 1117] CID 56899: Resource leak in examples

2015-03-11 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1117 --- Comment #2 from Ciprian Barbu --- Patches v1 sent: https://patches.linaro.org/45656/ https://patches.linaro.org/45657/ https://patches.linaro.org/45658/ -- You are receiving this mail because: You are on the CC list for the bug.__

[lng-odp] [Bug 1337] No means of knowing the size of the CPU mask (odp_cpumask_t)

2015-03-11 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1337 Mike Holmes changed: What|Removed |Added CC||mike.hol...@linaro.org --- Comment #1 from Mike

Re: [lng-odp] [PATCH] validation: pktio: prevent race when using veth pair

2015-03-11 Thread Stuart Haslam
On Thu, Mar 05, 2015 at 12:12:31PM +, Stuart Haslam wrote: > There's a potential race condition whereby the test case could start > running before the virtual ethernet interfaces are fully brought up. > So replace the the arbitrary delay with a check for the interface's > operational state befo

Re: [lng-odp] [PATCHv3] linux-generic: only print errors to stderr

2015-03-11 Thread Stuart Haslam
On Fri, Mar 06, 2015 at 01:24:52PM +, Stuart Haslam wrote: > The default logger prints all log levels to stderr. To make things > easier when debugging failures change it to print only errors to stderr > and everything else to stdout. ping - this is ready to be merged. > > Signed-off-by: Stu

Re: [lng-odp] [PATCH] linux-generic: odp_timer: set user_ptr for cancelled timeout

2015-03-11 Thread Ola Liljedahl
On 11 March 2015 at 14:49, Savolainen, Petri (Nokia - FI/Espoo) < petri.savolai...@nokia.com> wrote: > > > > -Original Message- > > From: lng-odp-boun...@lists.linaro.org [mailto:lng-odp- > > boun...@lists.linaro.org] On Behalf Of ext Ola Liljedahl > > Sent: Tuesday, March 10, 2015 4:44 PM

Re: [lng-odp] [PATCH] linux-generic: odp_timer: set user_ptr for cancelled timeout

2015-03-11 Thread Ola Liljedahl
On 11 March 2015 at 15:26, Ola Liljedahl wrote: > On 11 March 2015 at 14:49, Savolainen, Petri (Nokia - FI/Espoo) < > petri.savolai...@nokia.com> wrote: > >> >> >> > -Original Message- >> > From: lng-odp-boun...@lists.linaro.org [mailto:lng-odp- >> > boun...@lists.linaro.org] On Behalf Of

Re: [lng-odp] odp_cpu_count() vs odp_cpumask size

2015-03-11 Thread Savolainen, Petri (Nokia - FI/Espoo)
Continuation of cpumask discussion on the call… For creating arbitrary masks (e.g. fill in a mask with CPU ids of another ODP program in the system, or testing all possible mask bits), we may need two more calls: /** * @return Maximum number of CPUs a mask can hold */ int odp_cpumask_max_cpus(

Re: [lng-odp] odp_cpu_count() vs odp_cpumask size

2015-03-11 Thread Taras Kondratiuk
On 03/11/2015 04:46 PM, Savolainen, Petri (Nokia - FI/Espoo) wrote: Continuation of cpumask discussion on the call… For creating arbitrary masks (e.g. fill in a mask with CPU ids of another ODP program in the system, or testing all possible mask bits), we may need two more calls: /** * @return

[lng-odp] [PATCHv2] linux-generic: odp_timer: set user_ptr for cancelled timeout

2015-03-11 Thread Ola Liljedahl
Ensure that the timeout user_ptr and timer fields are set when the corresponding timer is immediately cancelled. https://bugs.linaro.org/show_bug.cgi?id=1313 Signed-off-by: Ola Liljedahl --- (This document/code contribution attached is provided under the terms of agreement LES-LTM-21309) Passes

[lng-odp] [Bug 1330] commit 71fcc8a _DEFAULT_SOURCE breaks odp_ipsec example

2015-03-11 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1330 --- Comment #2 from Ciprian Barbu --- Patch sent: https://patches.linaro.org/45655/ -- You are receiving this mail because: You are the assignee for the bug.___ lng-odp mailing list lng-odp@lists.linaro.org

Re: [lng-odp] ODP_v1.0 @ Regarding adding some file say demo.c and demo.h in platform/linux-genic and platform/linux-genic/include

2015-03-11 Thread Bill Fischofer
I'm not sure what you're trying to do. You don't need to add files into the ODP directory structure in order to compile them. Are you just trying to compile an ODP application? On Wed, Mar 11, 2015 at 6:39 AM, Ayushman Kashyap wrote: > Hi > > I want to add some file in *platform/linux-generic*

Re: [lng-odp] [PATCH 0/3] Fix the leaks in examples (bug 1117)

2015-03-11 Thread Mike Holmes
On 11 March 2015 at 10:32, Ola Liljedahl wrote: > These examples won't leak memory continuously so why is this a problem? > Are we catering to e.g. bare metal environments which may not clean up > after applications have terminated? > I think the tests should be clean so they can be reused in ba

Re: [lng-odp] [PATCHv2] linux-generic: odp_timer: set user_ptr for cancelled timeout

2015-03-11 Thread Bill Fischofer
I originally was going to point out the 'typo' but my first reaction was that if should be of rather than in. However, on reflection it seemed that if was what was intended. However, I agree that this revised wording is clearer. On Wed, Mar 11, 2015 at 10:36 AM, Ola Liljedahl wrote: > Ensure

Re: [lng-odp] [PATCH] validation: schedule: code clean up

2015-03-11 Thread Bill Fischofer
On Wed, Mar 11, 2015 at 7:59 AM, Petri Savolainen < petri.savolai...@nokia.com> wrote: > Cleaned up usage of buf count, thread args and globals. > > Signed-off-by: Petri Savolainen > Reviewed-and-tested-by: Bill Fischofer > --- > test/validation/odp_schedule.c | 102 > ---

[lng-odp] [PATCH ARCH] remove api_guide_lines

2015-03-11 Thread Mike Holmes
This docuemtnation has been moved to the API document Signed-off-by: Mike Holmes --- api_guide_lines.dox | 178 1 file changed, 178 deletions(-) delete mode 100644 api_guide_lines.dox diff --git a/api_guide_lines.dox b/api_guide_lines.dox de

Re: [lng-odp] [PATCH] doc: move api guidelines to API doc

2015-03-11 Thread Bill Fischofer
On Wed, Mar 11, 2015 at 1:24 PM, Mike Holmes wrote: > This documentation was moved from the architecture doc to this API doc. > > Signed-off-by: Mike Holmes > Reviewed-by: Bill Fischofer > --- > doc/api_guide_lines.dox | 178 > > 1 file chang

Re: [lng-odp] [PATCH ARCH] remove api_guide_lines

2015-03-11 Thread Bill Fischofer
On Wed, Mar 11, 2015 at 1:30 PM, Mike Holmes wrote: > This docuemtnation has been moved to the API document > > Signed-off-by: Mike Holmes > Reviewed-by: Bill Fischofer > --- > api_guide_lines.dox | 178 > > 1 file changed, 178 deletions(

[lng-odp] [Bug 1284] test/validation/odp_schedule fails to terminate cleanly

2015-03-11 Thread bugzilla-daemon
https://bugs.linaro.org/show_bug.cgi?id=1284 Mike Holmes changed: What|Removed |Added Assignee|petri.savolai...@linaro.org |ciprian.ba...@linaro.org -- You are receiving t

Re: [lng-odp] [PATCH] validation: pktio: prevent race when using veth pair

2015-03-11 Thread Mike Holmes
I simultaneously ran two independent instances of odp with "make check" and neither had an issue, one had this patch the other did not. At the same time I used the ./build.sh script from the cleanup branch of https://git.linaro.org/people/anders.roxell/check-odp.git and it was pointed at a patche

Re: [lng-odp] [PATCH] validation: pktio: prevent race when using veth pair

2015-03-11 Thread Mike Holmes
I never run it as root usually, but I did just now to check. Again build.sh had errors and running the for loop directly did not On 11 March 2015 at 17:43, Maxim Uvarov wrote: > On 03/11/15 23:47, Mike Holmes wrote: > >> for i in {1..10}; do make clean check -e; done >> > Mike do you run that u

[lng-odp] [PATCH] doc: move api guidelines to API doc

2015-03-11 Thread Mike Holmes
This documentation was moved from the architecture doc to this API doc. Signed-off-by: Mike Holmes --- doc/api_guide_lines.dox | 178 1 file changed, 178 insertions(+) create mode 100644 doc/api_guide_lines.dox diff --git a/doc/api_guide_lines.d

Re: [lng-odp] [PATCH] doc: move api guidelines to API doc

2015-03-11 Thread Mike Holmes
Please ignore this On 11 March 2015 at 19:25, Mike Holmes wrote: > This documentation was moved from the architecture doc to this API doc. > > Signed-off-by: Mike Holmes > --- > doc/api_guide_lines.dox | 178 > > 1 file changed, 178 insertions(+

[lng-odp] [PATCH] CONTRIBUTING: add clarification on code style

2015-03-11 Thread Mike Holmes
Clarify the locations that variables may be declared Signed-off-by: Mike Holmes --- CONTRIBUTING | 15 +++ 1 file changed, 15 insertions(+) diff --git a/CONTRIBUTING b/CONTRIBUTING index 75fb711..ca1ce3f 100644 --- a/CONTRIBUTING +++ b/CONTRIBUTING @@ -16,6 +16,21 @@ ODP code shall

Re: [lng-odp] [PATCH v2 0/3] test cleanup

2015-03-11 Thread Mike Holmes
Ping On 5 March 2015 at 17:22, Mike Holmes wrote: > v2 > Inadvertently send v1 which was != local commits > > Mike Holmes (3): > test: debug: Add unused attribute MACRO > validation: timer: use unused attribute > test: debug: replace example with test > > test/test_debug.h | 11