[jira] [Commented] (HADOOP-15676) Cleanup TestSSLHttpServer

2018-09-08 Thread Xiao Chen (JIRA)


[ 
https://issues.apache.org/jira/browse/HADOOP-15676?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16608286#comment-16608286
 ] 

Xiao Chen commented on HADOOP-15676:


Thanks [~snemeth] for the improvement here.

Looks like {{testOneEnabledCiphers}} and {{testExclusiveEnabledCiphers}} has 
some duplicate codes.
And usually it's not recommended to:
{code}
try {
...
} catch (Exception e) {
  fail()
}
{code}
One can expect that the exception can trigger the test failure, and that would 
be enough for investigation. 

+1 once that's fixed and precommit checkstyle is addressed.

> Cleanup TestSSLHttpServer
> -
>
> Key: HADOOP-15676
> URL: https://issues.apache.org/jira/browse/HADOOP-15676
> Project: Hadoop Common
>  Issue Type: Improvement
>  Components: common
>Affects Versions: 2.6.0
>Reporter: Szilard Nemeth
>Assignee: Szilard Nemeth
>Priority: Minor
> Attachments: HADOOP-15676.001.patch, HADOOP-15676.002.patch
>
>
> This issue will fix: 
> * Several typos in this class
> * Code is not very well readable in some of the places.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org



[jira] [Commented] (HADOOP-15694) ABFS: Allow OAuth credentials to not be tied to accounts

2018-09-08 Thread Thomas Marquardt (JIRA)


[ 
https://issues.apache.org/jira/browse/HADOOP-15694?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16608273#comment-16608273
 ] 

Thomas Marquardt commented on HADOOP-15694:
---

# *AbfsConfiguration.java@L212*:  getBoolean returns the account-agnostic value 
if both the account-agnostic and account-specific properties are set. We want 
it to return account-specific in this case.  Same is true for getLong.
 # Can we add test cases for these new methods on AbfsConfiguration to validate 
1 above? 
 # I know it's late for this comment, but I realized while reviewing this that 
it is a feature which would be nice in hadoop-common.  This change effectively 
introduces a collection for configuration property keys, where an optional 
default is overridden by a named subkey.  It could be added to the 
Configuration system without breaking existing config.  I mean, you could have 
XML like below, and look up values for the sub key by passing the string 
"\{KEY}.\{SUBKEY}" to Configuration.get().  You can disallow '.' in the 
\{SUBKEY} and fallback to the \{DEFAULT_VALUE} if \{SUBKEY} does not exist in 
the collection.  See XML below:

 
{code:java}

  {KEY}
  {DEFAULT_VALUE}
  




  

{code}

 

> ABFS: Allow OAuth credentials to not be tied to accounts
> 
>
> Key: HADOOP-15694
> URL: https://issues.apache.org/jira/browse/HADOOP-15694
> Project: Hadoop Common
>  Issue Type: Sub-task
>Reporter: Sean Mackrory
>Assignee: Sean Mackrory
>Priority: Major
> Attachments: HADOOP-15694-HADOOP-15407-005.patch, 
> HADOOP-15694-HADOOP-15407.003.patch, HADOOP-15694-HADOOP-15407.004.patch, 
> HADOOP-15694-HADOOP-15407.006.patch, HADOOP-15694.001.patch, 
> HADOOP-15694.002.patch, HADOOP-15694.003.patch
>
>
> Now that there's OAuth support, it's possible to have a notion of identity 
> that's distinct from the account itself. If a cluster is configured via OAuth 
> with it's own identity, it's likely operators will want to use that identity 
> regardless of which storage account a job uses.
> So OAuth configs right now (and probably others) are looked up with 
> .. I propose that we add a function for looking up these 
> configs that returns an account-specific value if it exists, but in the event 
> it does not will also try to return , if that exists.
> I can work on a patch for this if nobody has any objections.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org



[jira] [Updated] (HADOOP-15733) Invalid emptier Interval value printing in Logs when we configured invalid

2018-09-08 Thread Ayush Saxena (JIRA)


 [ 
https://issues.apache.org/jira/browse/HADOOP-15733?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Ayush Saxena updated HADOOP-15733:
--
Component/s: trash

> Invalid emptier Interval value printing in Logs when we configured invalid
> --
>
> Key: HADOOP-15733
> URL: https://issues.apache.org/jira/browse/HADOOP-15733
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: trash
>Affects Versions: 3.1.1
>Reporter: Harshakiran Reddy
>Assignee: Ayush Saxena
>Priority: Major
>
> {{Scenario:-}}
>  Configure Deletion interval as 10 and  Emptier interval as -1
>  Restart the namenode 
>  Run the rm command  hdfs dfs -rm /file
> {{ Actualoutput:- }}
> In log it's printing the -1 value for emptierinverval but as per the code 
> it's should be deletion interval value
> {noformat}
> 2018-09-07 14:59:41,721 INFO org.apache.hadoop.fs.TrashPolicyDefault: 
> Namenode trash configuration: Deletion interval = 10 minutes, Emptier 
> interval = -1 minutes.
> {noformat}
> {{Exceptedoutput:-}}
> Emptier interval value should be 10



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org



[jira] [Updated] (HADOOP-15733) Invalid emptier Interval value printing in Logs when we configured invalid

2018-09-08 Thread Harshakiran Reddy (JIRA)


 [ 
https://issues.apache.org/jira/browse/HADOOP-15733?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Harshakiran Reddy updated HADOOP-15733:
---
Issue Type: Bug  (was: Improvement)

> Invalid emptier Interval value printing in Logs when we configured invalid
> --
>
> Key: HADOOP-15733
> URL: https://issues.apache.org/jira/browse/HADOOP-15733
> Project: Hadoop Common
>  Issue Type: Bug
>Affects Versions: 3.1.1
>Reporter: Harshakiran Reddy
>Assignee: Ayush Saxena
>Priority: Major
>
> {{Scenario:-}}
>  Configure Deletion interval as 10 and  Emptier interval as -1
>  Restart the namenode 
>  Run the rm command  hdfs dfs -rm /file
> {{ Actualoutput:- }}
> In log it's printing the -1 value for emptierinverval but as per the code 
> it's should be deletion interval value
> {noformat}
> 2018-09-07 14:59:41,721 INFO org.apache.hadoop.fs.TrashPolicyDefault: 
> Namenode trash configuration: Deletion interval = 10 minutes, Emptier 
> interval = -1 minutes.
> {noformat}
> {{Exceptedoutput:-}}
> Emptier interval value should be 10



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org



[jira] [Updated] (HADOOP-15733) Invalid emptier Interval value printing in Logs when we configured invalid

2018-09-08 Thread Ayush Saxena (JIRA)


 [ 
https://issues.apache.org/jira/browse/HADOOP-15733?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Ayush Saxena updated HADOOP-15733:
--
Summary: Invalid emptier Interval value printing in Logs when we configured 
invalid  (was: Invalid emptierInterval value printing in Logs when we 
configured invalid)

> Invalid emptier Interval value printing in Logs when we configured invalid
> --
>
> Key: HADOOP-15733
> URL: https://issues.apache.org/jira/browse/HADOOP-15733
> Project: Hadoop Common
>  Issue Type: Improvement
>Affects Versions: 3.1.1
>Reporter: Harshakiran Reddy
>Assignee: Ayush Saxena
>Priority: Major
>
> {{Scenario:-}}
>  Configure Deletion interval as 10 and  Emptier interval as -1
>  Restart the namenode 
>  Run the rm command  hdfs dfs -rm /file
> {{ Actualoutput:- }}
> In log it's printing the -1 value for emptierinverval but as per the code 
> it's should be deletion interval value
> {noformat}
> 2018-09-07 14:59:41,721 INFO org.apache.hadoop.fs.TrashPolicyDefault: 
> Namenode trash configuration: Deletion interval = 10 minutes, Emptier 
> interval = -1 minutes.
> {noformat}
> {{Exceptedoutput:-}}
> Emptier interval value should be 10



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org



[jira] [Assigned] (HADOOP-15733) Invalid emptierInterval value printing in Logs when we configured invalid

2018-09-08 Thread Ayush Saxena (JIRA)


 [ 
https://issues.apache.org/jira/browse/HADOOP-15733?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Ayush Saxena reassigned HADOOP-15733:
-

Assignee: Ayush Saxena

> Invalid emptierInterval value printing in Logs when we configured invalid
> -
>
> Key: HADOOP-15733
> URL: https://issues.apache.org/jira/browse/HADOOP-15733
> Project: Hadoop Common
>  Issue Type: Improvement
>Affects Versions: 3.1.1
>Reporter: Harshakiran Reddy
>Assignee: Ayush Saxena
>Priority: Major
>
> {{Scenario:-}}
>  Configure Deletion interval as 10 and  Emptier interval as -1
>  Restart the namenode 
>  Run the rm command  hdfs dfs -rm /file
> {{ Actualoutput:- }}
> In log it's printing the -1 value for emptierinverval but as per the code 
> it's should be deletion interval value
> {noformat}
> 2018-09-07 14:59:41,721 INFO org.apache.hadoop.fs.TrashPolicyDefault: 
> Namenode trash configuration: Deletion interval = 10 minutes, Emptier 
> interval = -1 minutes.
> {noformat}
> {{Exceptedoutput:-}}
> Emptier interval value should be 10



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org



[jira] [Created] (HADOOP-15733) Invalid emptierInterval value printing in Logs when we configured invalid

2018-09-08 Thread Harshakiran Reddy (JIRA)
Harshakiran Reddy created HADOOP-15733:
--

 Summary: Invalid emptierInterval value printing in Logs when we 
configured invalid
 Key: HADOOP-15733
 URL: https://issues.apache.org/jira/browse/HADOOP-15733
 Project: Hadoop Common
  Issue Type: Improvement
Affects Versions: 3.1.1
Reporter: Harshakiran Reddy


{{Scenario:-}}

 Configure Deletion interval as 10 and  Emptier interval as -1
 Restart the namenode 
 Run the rm command  hdfs dfs -rm /file

{{ Actualoutput:- }}

In log it's printing the -1 value for emptierinverval but as per the code it's 
should be deletion interval value

{noformat}
2018-09-07 14:59:41,721 INFO org.apache.hadoop.fs.TrashPolicyDefault: Namenode 
trash configuration: Deletion interval = 10 minutes, Emptier interval = -1 
minutes.
{noformat}

{{Exceptedoutput:-}}

Emptier interval value should be 10



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org



[jira] [Created] (HADOOP-15732) DOAP http://hadoop.apache.org/doap.rdf disappeared

2018-09-08 Thread Sebb (JIRA)
Sebb created HADOOP-15732:
-

 Summary: DOAP http://hadoop.apache.org/doap.rdf disappeared
 Key: HADOOP-15732
 URL: https://issues.apache.org/jira/browse/HADOOP-15732
 Project: Hadoop Common
  Issue Type: Bug
Reporter: Sebb


Subject: Cannot find doap file: http://hadoop.apache.org/doap.rdf
From: Projects 
To: Site Development 
Reply-To: site-...@apache.org
Date: Sat,
  8 Sep 2018 02:00:26 + (UTC)

URL: http://hadoop.apache.org/doap.rdf
HTTP Error 404: Not Found
Source: 
https://svn.apache.org/repos/asf/comdev/projects.apache.org/trunk/data/projects.xml

Please restore the DOAP or update projects.xml to the new location.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org