LACP inbound traffic aggregation problem

2016-05-19 Thread Evgeniy Sudyr
Hi all,

I need to get tcp traffic aggregation between 4 hosts connected to
same Cisco switch  over 1Gbe ports (2 ports per server).

My problem is I can't get "inbound" traffic balanced over both eth0 and eth1

On all servers I'm using bond-ed interface with 2x 1Gbe slave
interfaces, want to get 2Gbe aggregated link for both inbound and
outbound traffic.

I do have VLAN interface which is using bond0 - "vlan-raw-device bond0".

On switch (Cisco 2960) I have portchannel with active mode configured.

Cisco configuration looks like this:

vlan 20

interface GigabitEthernet0/19
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active
interface GigabitEthernet0/20
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode active

interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk

On Linux hosts I'm using bond-mode 802.3ad, bond-lacp-rate 1 and
bond-xmit-hash-policy encap3+4 (also tried with bond-xmit-hash-policy
layer3+4).

I'm running iperf on this server in server mode (iperf -s -p 5001,
iperf -s -p 5002) where on 3 other clients.


I'm running iperf in client mode, with multiple theads -P and using
both tcp ports for connection 5001 and 5002 to make sure that
layer/encap3+4 load balancing (3+4) work.

My problem is that with ifstat I see that:
a) on iperf "server" only one eth interface is uses (and saturated as result);
b) on iperf "clients" I see traffic is leaving over both interfaces (balanced).

I'm wondered what's missing there, why inbound traffic is not coming
over both interfaces, but one.

There are my configuration and and tests results between 2 of hosts
(ceph0 and nebula0).

root@ceph0:~# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: encap3+4 (4)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 200
Down Delay (ms): 200
802.3ad info
LACP rate: fast
Min links: 0
Aggregator selection policy (ad_select): bandwidth
Active Aggregator Info:
Aggregator ID: 15
Number of ports: 2
Actor Key: 17
Partner Key: 4
Partner Mac Address: 5c:fc:66:d4:6d:80
Slave Interface: eth0
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: 78:e3:b5:13:28:ac
Aggregator ID: 15
Slave queue ID: 0
Slave Interface: eth1
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: 78:e3:b5:13:28:ae
Aggregator ID: 15
Slave queue ID: 0
root@ceph0:~# cat /etc/network/interfaces
auto lo bond0 vlan20 eth0 eth1
iface lo inet loopback
iface bond0 inet static
address 10.10.10.70
netmask 255.255.255.0
slaves eth0 eth1
bond-mode 802.3ad
bond-min-links 1
bond-miimon 100
bond-lacp-rate 1
bond-xmit-hash-policy encap3+4
iface vlan20 inet static
address 10.0.10.70
netmask 255.255.255.0
vlan-raw-device bond0

root@ceph0:~# ifstat -i bond0 -i eth0 -i eth1

root@nebula0:~# ifstat -i bond0 -i eth0 -i eth1
  bond0eth0eth1
 KB/s in  KB/s out   KB/s in  KB/s out   KB/s in  KB/s out
120293.0860.53  120291.5333.78  1.58526.75
120292.5883.70  120292.3352.81  0.13530.89
120292.1856.83  120292.0326.76  0.15530.07
120295.4862.24  120294.0354.49  1.37507.75
120291.4859.61  120291.4317.20  0.07542.41
120293.2856.05  120293.0309.97  0.21546.07
120293.8854.75  120293.3330.57  0.50524.18
120293.4855.36  120293.3308.17  0.14547.19
120784.1857.80  120783.9313.48  0.19544.32



root@nebula0:~# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: encap3+4 (4)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0
802.3ad info
LACP rate: fast
Min links: 0
Aggregator selection policy (ad_select): bandwidth
System priority: 65535
System MAC address: 2c:59:e5:42:5e:24
Active Aggregator Info:
Aggregator ID: 8
Number of ports: 2
Actor Key: 9
Partner Key: 2
Partner Mac Address: 5c:fc:66:d4:6d:80
Slave Interface: eth0
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: 2c:59:e5:42:5e:24
Slave queue ID: 0
Aggregator ID: 8
Actor Churn State: none
Partner Churn State: none
Actor Churned Count: 0
Partner Churned Count: 0
details actor lacp pdu:
system priority: 65535
system mac address: 2c:59:e5:42:5e:24
port key: 9
port priority: 255
port number: 1
port state: 63
details partner lacp pdu:
system priority: 32768
system mac address: 5c:fc:66:d4:6d:80
oper key: 2
port priority: 32768
port number: 262
port state: 60
Slave Interface: eth1
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: 2c:59:e5:42:5e:26
Slave queue ID: 0
Aggregator ID: 8
Actor Churn State: none
Partner Churn State: none
Actor Churned Count: 0
Partner Churned Count: 0
d

Local package archive problem

2006-04-23 Thread Evgeniy Sudyr
Hi all,

  I lost my dvds with sarge :(
  But I have debian-31r1a-i386-netinst.iso and content of both DVDs on
  my hard disk (in with tree of DVDs) - how use packages from hard drive?

  I tired make Local package archive (as discribed in Debian package
  management) - http://pastebin.com/677328

  when i use apt-setup it told me that I can use more then 15000
  packages, nbut when I try use aptitude I get messages that files
  aren`t found

  What to do??? Help please ...

---
best regards Evgeniy


-- 
To UNSUBSCRIBE, email to [EMAIL PROTECTED] 
with a subject of "unsubscribe". Trouble? Contact [EMAIL PROTECTED]



Packages.gz

2006-04-22 Thread Evgeniy Sudyr
-BEGIN PGP SIGNED MESSAGE-
Hash: MD5

- -BEGIN PGP SIGNED MESSAGE-
Hash: MD5

Hi all,

how make own deb reprositary on CD with own packages (for using in
sources.list) - how right make Packages.gz file ?

- - ---
best regards Evgeniy

- -BEGIN PGP SIGNATURE-
Version: 2.6

iQEVAwUAREqy/rxMYSoGX/vjAQHZ6gf9E/lRo1LttUweJV2ZxEZZEmQK+aRgzXns
YRtUBHgTnwKbdBtTGxJ3F70XuqEVLDvnUmba3qvFKtbFIGOAu7Pw6Pz5qy+xR9Fr
rNlR2KupsLdTS11PIlUItBdMuhZ01R0/6OXEC7QIRM3OILksjsIx6YhHIMef1sdV
ArKqJVNSm3BfEFJ/s5qJGpSOtGAF9LdArYKSOI2BRG1RGfBtPk6O9pext9CgovFs
j14DVtx24bSD74mbXxDTC5tC9IrOKkH9Dw4Bk31DRJ/Cqy71Ge+nPqVtFOE/csL+
aBMHenZ7xnIRcZBQFc2LGjU59kaUHKR5/ic5GhcB0jyZxOMxgDr1Xg==
=FyM7
- -END PGP SIGNATURE-

-BEGIN PGP SIGNATURE-
Version: 2.6

iQEVAwUAREq3nLxMYSoGX/vjAQHLbAf/WkCg/m1/SnK1RFltdkgBXnJP1fltR/Me
3PiY8iNhX9q+R7Ef54U1NbR0+D3xUzyge5kPNrLv+TLTGgTZD6F28u7SMmDpd0wZ
knLU6uxKS50daNOOZL964l0Ry0fiRIayb1qSJAWgEae8O21+lSE0XKiSLRlIeSgL
VxUceTc8psXbz3CyoFglPCbqPtK1FQUQrR3sd/DwCmrJda5qSmBAQ5lPuQIaw193
PODKJmjbbSAdTuDvxWR3jA+u7UQpqtRl3hR/9R++KCR2sIAsEM6lExs5IqinUiZ+
Wh4VFQYYjSxCMvsbdQfKXS0Td1VICazvWWrAF2+5fo3L/pqzEao1lA==
=n+Ob
-END PGP SIGNATURE-



-- 
To UNSUBSCRIBE, email to [EMAIL PROTECTED] 
with a subject of "unsubscribe". Trouble? Contact [EMAIL PROTECTED]



Howto move pool to own CD

2006-04-22 Thread Evgeniy Sudyr
Hi all,
I have Sarge 3.1 on 2 DVD - i want copy only needed packets (near 300
mB) from pool to CD and burn it.

Please help me howto make it.

With respect Evgeniy


-- 
To UNSUBSCRIBE, email to [EMAIL PROTECTED] 
with a subject of "unsubscribe". Trouble? Contact [EMAIL PROTECTED]