[jira] [Commented] (GEODE-2966) Refactor LauncherLifecycleCommands

2017-06-01 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/GEODE-2966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16033277#comment-16033277
 ] 

ASF subversion and git services commented on GEODE-2966:


Commit cfdd57378fb78cbc98d41446752460f534b28db7 in geode's branch 
refs/heads/release/1.2.0 from [~jstewart]
[ https://git-wip-us.apache.org/repos/asf?p=geode.git;h=cfdd573 ]

GEODE-2966: RefactorLauncherLifecycleCommands

 - Extract several commands into their own classes.
 - Extract utility methods into their own classes.
 - Rename AbstractCommandsSupport to GfshCommand, and convert it from an 
abstract class to an interface

(cherry picked from commit 9046c8d)


> Refactor LauncherLifecycleCommands
> --
>
> Key: GEODE-2966
> URL: https://issues.apache.org/jira/browse/GEODE-2966
> Project: Geode
>  Issue Type: Sub-task
>  Components: gfsh, management
>Reporter: Jared Stewart
>Assignee: Jared Stewart
> Fix For: 1.3.0
>
>
> LauncherLifecycleCommands is over 2000 lines of code, and could be made a lot 
> more readable by introducing proper OO abstraction.  There are also many 
> private static final strings like {{CliStrings.START_LOCATOR__MEMBER_NAME}} 
> that could be made shorter and more contextual, e.g. 
> {{StartLocatorCommand.MEMBER_NAME}}.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (GEODE-2966) Refactor LauncherLifecycleCommands

2017-06-01 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/GEODE-2966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16033278#comment-16033278
 ] 

ASF subversion and git services commented on GEODE-2966:


Commit fd55f05c75bdcaecdae593bcab7b7b7d180402b6 in geode's branch 
refs/heads/release/1.2.0 from [~jstewart]
[ https://git-wip-us.apache.org/repos/asf?p=geode.git;h=fd55f05 ]

GEODE-2966: Restore command changes lost in merge conflict

(cherry picked from commit ad48ab6)


> Refactor LauncherLifecycleCommands
> --
>
> Key: GEODE-2966
> URL: https://issues.apache.org/jira/browse/GEODE-2966
> Project: Geode
>  Issue Type: Sub-task
>  Components: gfsh, management
>Reporter: Jared Stewart
>Assignee: Jared Stewart
> Fix For: 1.3.0
>
>
> LauncherLifecycleCommands is over 2000 lines of code, and could be made a lot 
> more readable by introducing proper OO abstraction.  There are also many 
> private static final strings like {{CliStrings.START_LOCATOR__MEMBER_NAME}} 
> that could be made shorter and more contextual, e.g. 
> {{StartLocatorCommand.MEMBER_NAME}}.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (GEODE-2966) Refactor LauncherLifecycleCommands

2017-06-01 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/GEODE-2966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16033267#comment-16033267
 ] 

ASF subversion and git services commented on GEODE-2966:


Commit ad48ab684c007b5996a942d12d63c5f405ba03f7 in geode's branch 
refs/heads/develop from [~jstewart]
[ https://git-wip-us.apache.org/repos/asf?p=geode.git;h=ad48ab6 ]

GEODE-2966: Restore command changes lost in merge conflict


> Refactor LauncherLifecycleCommands
> --
>
> Key: GEODE-2966
> URL: https://issues.apache.org/jira/browse/GEODE-2966
> Project: Geode
>  Issue Type: Sub-task
>  Components: gfsh, management
>Reporter: Jared Stewart
>Assignee: Jared Stewart
> Fix For: 1.3.0
>
>
> LauncherLifecycleCommands is over 2000 lines of code, and could be made a lot 
> more readable by introducing proper OO abstraction.  There are also many 
> private static final strings like {{CliStrings.START_LOCATOR__MEMBER_NAME}} 
> that could be made shorter and more contextual, e.g. 
> {{StartLocatorCommand.MEMBER_NAME}}.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)


[jira] [Commented] (GEODE-2966) Refactor LauncherLifecycleCommands

2017-06-01 Thread ASF subversion and git services (JIRA)

[ 
https://issues.apache.org/jira/browse/GEODE-2966?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16033214#comment-16033214
 ] 

ASF subversion and git services commented on GEODE-2966:


Commit 9046c8dcd3bf530997fbb374085f1c1213db15e3 in geode's branch 
refs/heads/develop from [~jstewart]
[ https://git-wip-us.apache.org/repos/asf?p=geode.git;h=9046c8d ]

GEODE-2966: RefactorLauncherLifecycleCommands

 - Extract several commands into their own classes.
 - Extract utility methods into their own classes.
 - Rename AbstractCommandsSupport to GfshCommand, and convert it from an 
abstract class to an interface


> Refactor LauncherLifecycleCommands
> --
>
> Key: GEODE-2966
> URL: https://issues.apache.org/jira/browse/GEODE-2966
> Project: Geode
>  Issue Type: Sub-task
>  Components: gfsh, management
>Reporter: Jared Stewart
>Assignee: Jared Stewart
>
> LauncherLifecycleCommands is over 2000 lines of code, and could be made a lot 
> more readable by introducing proper OO abstraction.  There are also many 
> private static final strings like {{CliStrings.START_LOCATOR__MEMBER_NAME}} 
> that could be made shorter and more contextual, e.g. 
> {{StartLocatorCommand.MEMBER_NAME}}.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)