Re: vr0 interface and VLAN tagging

2006-07-28 Thread Chuck Swiger

William wrote:
[ ... ]

Switch config has stayed the same, what I want to do now is do a
one-liner on the vr0 interface so I can bring it up and set the speed
duplex to 100/full. When I do:

ifconfig_vr0="up media 100baseTX mediaopt full-duplex"

It doesnt seem to work, any ideas what I'm doing wrong?


If you force the switch port to use 100FD, does the vr0 auto-neg work properly 
or not?


--
-Chuck
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"


Re: vr0 interface and VLAN tagging

2006-07-28 Thread William

Hi list,

I've made some progress.. my rc.conf looks like this:

cloned_interfaces="vlan100 vlan200 vlan254"
ifconfig_vr0="up"
ifconfig_vlan100="inet 192.168.100.1 netmask 255.255.255.0 vlan 100 vlandev vr0"
ifconfig_vlan200="inet 192.168.200.1 netmask 255.255.255.0 vlan 200 vlandev vr0"
ifconfig_vlan254="inet 10.254.254.252 netmask 255.255.255.0 vlan 254
vlandev vr0"
defaultrouter="10.254.254.254"

Switch config has stayed the same, what I want to do now is do a
one-liner on the vr0 interface so I can bring it up and set the speed
duplex to 100/full. When I do:

ifconfig_vr0="up media 100baseTX mediaopt full-duplex"

It doesnt seem to work, any ideas what I'm doing wrong?

Cheers,

Will




On 27/07/06, James Snow <[EMAIL PROTECTED]> wrote:

Will,

In your ifconfig_vr0, line, you have a typo. The 'f' is missing from
full-duplex.  Possibly just a copy & paste gaffe, and I doubt it's the
cause of your problem anyway.

The vr driver isn't listed in if_vlan(4).  It may be one of the ones
that doesn't work, or doesn't work very well.

Also, if connected to a trunking port, I'm not sure what happens to
frames that leave without an 802.1Q header.  Frames leaving via vr0
would be untagged and I think dropped by the switch.  You may need to
drop 10.25.254.252 from vr0 and put it on a fourth VLAN interface.  But
don't quote me on this.

Hope this helps.


-Snow

On Thu, Jul 27, 2006 at 02:07:14PM +0100, William wrote:
> Hi list,
>
> I'm trying to get a FreeBSD 5.3-RELEASE (running GENERIC kernel) to do
> vlan tagging.
>
> I want to have several 'vlan interfaces' that can talk to their local
> subnet and also use a default route.
>
> On the switch side of things I'm using a Cisco 3550 runing layer3
> code, I've had this working before with a em driver (on another box)
> but my setup was a little different then so I'm pretty sure the switch
> isnt at fault?
>
> My rc.conf looks like:
>
> cloned_interfaces="vlan100 vlan200 vlan233"
> ifconfig_vr0="up"
> ifconfig_vlan100="inet 192.168.100.1 netmask 255.255.255.0 vlan 100 vlandev
> vr0"
> ifconfig_vlan200="inet 192.168.200.1 netmask 255.255.255.0 vlan 200 vlandev
> vr0"
> ifconfig_vlan233="inet 10.233.233.1 netmask 255.255.255.0 vlan 233 vlandev
> vr0"
> ifconfig_vr0="inet 10.254.254.252 netmask 255.255.255.0 media
> 100baseTX mediaopt ull-duplex"
> defaultrouter="10.254.254.254"
>
> and my switch config looks like this:
>
> interface FastEthernet0/12
>  switchport access vlan 254
>  switchport trunk encapsulation dot1q
>  switchport trunk allowed vlan 100,200,233
>  switchport mode trunk
> logging event trunk-status
> duplex full
> speed 100
> end
>
> I'm getting to the point that the vlan interfaces (100,200,233) can
> talk to machines on their subnet but I cannot seem to ping anything on
> the 10.254.254.0/24 subnet (ip address applied to vr0 interface) or
> anythnig via the default route.
>
> If anyone can assist me I'd appreciate it, please contact me off list
> as I am not subscribed to -questions.
>
> Cheers,
>
> Will
> ___
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "[EMAIL PROTECTED]"


___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"


vr0 interface and VLAN tagging

2006-07-27 Thread William

Hi list,

I'm trying to get a FreeBSD 5.3-RELEASE (running GENERIC kernel) to do
vlan tagging.

I want to have several 'vlan interfaces' that can talk to their local
subnet and also use a default route.

On the switch side of things I'm using a Cisco 3550 runing layer3
code, I've had this working before with a em driver (on another box)
but my setup was a little different then so I'm pretty sure the switch
isnt at fault?

My rc.conf looks like:

cloned_interfaces="vlan100 vlan200 vlan233"
ifconfig_vr0="up"
ifconfig_vlan100="inet 192.168.100.1 netmask 255.255.255.0 vlan 100 vlandev vr0"
ifconfig_vlan200="inet 192.168.200.1 netmask 255.255.255.0 vlan 200 vlandev vr0"
ifconfig_vlan233="inet 10.233.233.1 netmask 255.255.255.0 vlan 233 vlandev vr0"
ifconfig_vr0="inet 10.254.254.252 netmask 255.255.255.0 media
100baseTX mediaopt ull-duplex"
defaultrouter="10.254.254.254"

and my switch config looks like this:

interface FastEthernet0/12
 switchport access vlan 254
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 100,200,233
 switchport mode trunk
logging event trunk-status
duplex full
speed 100
end

I'm getting to the point that the vlan interfaces (100,200,233) can
talk to machines on their subnet but I cannot seem to ping anything on
the 10.254.254.0/24 subnet (ip address applied to vr0 interface) or
anythnig via the default route.

If anyone can assist me I'd appreciate it, please contact me off list
as I am not subscribed to -questions.

Cheers,

Will
___
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"