Re: [PATCH v4 2/2] Rename suffixcmp() to ends_with() and invert its result

2013-11-20 Thread Christian Couder
From: Junio C Hamano gits...@pobox.com

 Antoine Pelisse apeli...@gmail.com writes:
 
 I'm not exactly sure I understand the point of not squashing all those
 patches together ?
 It's not like one is going without the others, or that the commit
 message provides some new information (except for the name of the
 file, but that is not very relevant either). The downside is that it's
 _many_ messages to bypass when reading mails from small-screen devices
 :-)
 
 The only plausible reason I could think of is to avoid clashing with
 topics in-flight, but then the approach to produce per-file patch is
 not perfect for that purpose, either, when more than one topic in
 flight touch the same file at different places.
 
 I'd say probably the best organization would be something like:
 
  * A set of clean-up patches to normalize oddball usages of existing
functions (e.g. normalize 'prefixcmp(a,b) != 0' in some file(s)
to 'prefixcmp(a,b)');
 
  * A single patch to introduce the new function(s), to be applied on
top of 1.8.5;
 
  * A large patch to convert all uses of prefixcmp to starts_with and
suffixcmp to ends_with in the 1.8.5 codebase;
 
  * A patch for each topic in flight to convert newly introduced
prefixcmp/suffixcmp to starts_with/ends_with, to be applied after
the topic graduates to 'master' after 1.8.5; and then finally
 
  * A separate patch to remove prefixcmp and suffixcmp, to be applied
after _all_ in-flight topic has graduated to 'master'.

Ok, I will wait for 1.8.5 and then send a patch series like what you
suggest.

Thanks,
Christian.

--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v4 2/2] Rename suffixcmp() to ends_with() and invert its result

2013-11-19 Thread Jonathan Nieder
Christian Couder wrote:

 Now ends_with() returns 1 when the suffix is present and 0 otherwise.

Sounds good.

[...]
 And in vcs-svn/fast_export.c there was already an ends_with()
 function that did the same thing. Let's used the renamed one
 while at it.

Yes, despite the change in signature this shouldn't slow anything
down.  Thanks.

For what it's worth,
Reviewed-by: Jonathan Nieder jrnie...@gmail.com
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v4 2/2] Rename suffixcmp() to ends_with() and invert its result

2013-11-19 Thread Christian Couder
From: Jonathan Nieder jrnie...@gmail.com
 Christian Couder wrote:
 
 And in vcs-svn/fast_export.c there was already an ends_with()
 function that did the same thing. Let's used the renamed one
 while at it.
 
 Yes, despite the change in signature this shouldn't slow anything
 down.  Thanks.
 
 For what it's worth,
 Reviewed-by: Jonathan Nieder jrnie...@gmail.com

Thanks.

To avoid spamming the list again, I am going to send the following
patches from the 86 patch long series to replace prefixcmp() with
starts_with():

[PATCH v2 00/86] replace prefixcmp() with starts_with()
[PATCH v2 01/86] strbuf: add starts_with() to be used instead of prefixcmp()
[PATCH v2 02/86] diff: replace prefixcmp() with starts_with()
[PATCH v2 08/86] transport*: replace prefixcmp() with starts_with()
[PATCH v2 40/86] environment: replace prefixcmp() with starts_with()
[PATCH v2 86/86] strbuf: remove prefixcmp() as it has been replaced with 
starts_with()

If there are no problems with them, then I will suppose that most of
the patches are ok and probably send them all unless I am asked not
to.

Cheers,
Christian.
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH v4 2/2] Rename suffixcmp() to ends_with() and invert its result

2013-11-19 Thread Antoine Pelisse
On Tue, Nov 19, 2013 at 10:04 PM, Christian Couder
chrisc...@tuxfamily.org wrote:
 To avoid spamming the list again, I am going to send the following
 patches from the 86 patch long series to replace prefixcmp() with
 starts_with():

 [PATCH v2 00/86] replace prefixcmp() with starts_with()
 [PATCH v2 01/86] strbuf: add starts_with() to be used instead of prefixcmp()
 [PATCH v2 02/86] diff: replace prefixcmp() with starts_with()
 [PATCH v2 08/86] transport*: replace prefixcmp() with starts_with()
 [PATCH v2 40/86] environment: replace prefixcmp() with starts_with()
 [PATCH v2 86/86] strbuf: remove prefixcmp() as it has been replaced with 
 starts_with()

 If there are no problems with them, then I will suppose that most of
 the patches are ok and probably send them all unless I am asked not
 to.

I'm not exactly sure I understand the point of not squashing all those
patches together ?
It's not like one is going without the others, or that the commit
message provides some new information (except for the name of the
file, but that is not very relevant either). The downside is that it's
_many_ messages to bypass when reading mails from small-screen devices
:-)
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html