Re: Review Request 128353: Unit tests of directory permissions in zip files

2016-07-04 Thread Sune Vuorela

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/128353/
---

(Updated July 4, 2016, 6:27 p.m.)


Status
--

This change has been marked as submitted.


Review request for KDE Frameworks and David Faure.


Changes
---

Submitted with commit dda62267aab8893db0ff695391d0fd8b37ace1f6 by Sune Vuorela 
to branch master.


Repository: karchive


Description
---

Add unit test to prevent later changes to abandon directory permissions in zip 
files

Test file created with
mkdir ziptest
cd ziptest
mkdir 700 750 755
chmod 700 700
chmod 750 750
chmod 755 755
zip -r my.zip 7*


Diffs
-

  autotests/karchivetest.h 5a6375c 
  autotests/karchivetest.cpp dd03dac 

Diff: https://git.reviewboard.kde.org/r/128353/diff/


Testing
---


Thanks,

Sune Vuorela

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 128353: Unit tests of directory permissions in zip files

2016-07-04 Thread Sune Vuorela


> On July 3, 2016, 8:25 p.m., David Faure wrote:
> > autotests/karchivetest.cpp, line 1118
> > 
> >
> > Why QLatin1String("") and not just QString() ?

Previous unit test does the same


- Sune


---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/128353/#review97066
---


On July 4, 2016, 6:27 p.m., Sune Vuorela wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/128353/
> ---
> 
> (Updated July 4, 2016, 6:27 p.m.)
> 
> 
> Review request for KDE Frameworks and David Faure.
> 
> 
> Repository: karchive
> 
> 
> Description
> ---
> 
> Add unit test to prevent later changes to abandon directory permissions in 
> zip files
> 
> Test file created with
> mkdir ziptest
> cd ziptest
> mkdir 700 750 755
> chmod 700 700
> chmod 750 750
> chmod 755 755
> zip -r my.zip 7*
> 
> 
> Diffs
> -
> 
>   autotests/karchivetest.h 5a6375c 
>   autotests/karchivetest.cpp dd03dac 
> 
> Diff: https://git.reviewboard.kde.org/r/128353/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Sune Vuorela
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 128353: Unit tests of directory permissions in zip files

2016-07-03 Thread David Faure

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/128353/#review97066
---


Fix it, then Ship it!





autotests/karchivetest.cpp (line 1113)


QVERIFY(!data.isEmpty());

(I'd rename data to file, it's a filename, not file contents)



autotests/karchivetest.cpp (line 1118)


Why QLatin1String("") and not just QString() ?



autotests/karchivetest.cpp (line 1119)


There's a join(QChar), so better write join(' ').


- David Faure


On July 3, 2016, 1:09 p.m., Sune Vuorela wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/128353/
> ---
> 
> (Updated July 3, 2016, 1:09 p.m.)
> 
> 
> Review request for KDE Frameworks and David Faure.
> 
> 
> Repository: karchive
> 
> 
> Description
> ---
> 
> Add unit test to prevent later changes to abandon directory permissions in 
> zip files
> 
> Test file created with
> mkdir ziptest
> cd ziptest
> mkdir 700 750 755
> chmod 700 700
> chmod 750 750
> chmod 755 755
> zip -r my.zip 7*
> 
> 
> Diffs
> -
> 
>   autotests/karchivetest.h 5a6375c 
>   autotests/karchivetest.cpp dd03dac 
> 
> Diff: https://git.reviewboard.kde.org/r/128353/diff/
> 
> 
> Testing
> ---
> 
> 
> Thanks,
> 
> Sune Vuorela
> 
>

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Re: Review Request 128353: Unit tests of directory permissions in zip files

2016-07-03 Thread Sune Vuorela

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/128353/
---

(Updated July 3, 2016, 1:09 p.m.)


Review request for KDE Frameworks and David Faure.


Repository: karchive


Description (updated)
---

Add unit test to prevent later changes to abandon directory permissions in zip 
files

Test file created with
mkdir ziptest
cd ziptest
mkdir 700 750 755
chmod 700 700
chmod 750 750
chmod 755 755
zip -r my.zip 7*


Diffs
-

  autotests/karchivetest.h 5a6375c 
  autotests/karchivetest.cpp dd03dac 

Diff: https://git.reviewboard.kde.org/r/128353/diff/


Testing
---


Thanks,

Sune Vuorela

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel


Review Request 128353: Unit tests of directory permissions in zip files

2016-07-03 Thread Sune Vuorela

---
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/128353/
---

Review request for KDE Frameworks and David Faure.


Repository: karchive


Description
---

Add unit test to prevent later changes to abandon directory permissions in zip 
files


Diffs
-

  autotests/karchivetest.h 5a6375c 
  autotests/karchivetest.cpp dd03dac 

Diff: https://git.reviewboard.kde.org/r/128353/diff/


Testing
---


Thanks,

Sune Vuorela

___
Kde-frameworks-devel mailing list
Kde-frameworks-devel@kde.org
https://mail.kde.org/mailman/listinfo/kde-frameworks-devel