Need suggestions for a module name

2011-06-17 Thread Robert Rothenberg
While debugging a project that generated a lot of temporary files, I came
upon a nifty idea: rather than name the temporary files the usual random
strings, why not have the files named by the method/function that created
them, e.g. instead of something like /tmp/Hf6254d85.txt, why not call it
/tmp/Some_Package_Name/text_analysing_function-Hf6254d85.txt.

Anyhow, I think this might be something worth uploading to CPAN.

So what should it be called?

I was thinking of something like File::Temp::Smart, for lack of a better
name. But I am open to better ideas.

Suggestions?

Rob


RE: Need suggestions for a module name

2011-06-17 Thread Pearce, Martyn
'Smart' is subjective, and not very informative.  How about 
File::Temp::ByFnName ?

-Original Message-
From: Robert Rothenberg [mailto:r...@fastmail.net] 
Sent: Thursday, June 16, 2011 9:24 PM
To: Perl Module Authors List
Subject: Need suggestions for a module name

While debugging a project that generated a lot of temporary files, I came
upon a nifty idea: rather than name the temporary files the usual random
strings, why not have the files named by the method/function that created
them, e.g. instead of something like /tmp/Hf6254d85.txt, why not call it
/tmp/Some_Package_Name/text_analysing_function-Hf6254d85.txt.

Anyhow, I think this might be something worth uploading to CPAN.

So what should it be called?

I was thinking of something like File::Temp::Smart, for lack of a better
name. But I am open to better ideas.

Suggestions?

Rob


Re: Need suggestions for a module name

2011-06-17 Thread Nadim Khemir
HI,

Using ::Smart may not be so smart

I have no idea for the module name but one or two about the
functionality it coold offer. IMO, a module just for that functionality,
although, welcome, is over the edge. maybe adding some functionality
could make it worth istalling. i also wonder if there isn't another
loggin module where your functionality could added.

Other things that could be added:

template to add information to the file name
  my $fh = temp_file(%M %S %s %d, 'some_text', $index) or die ...

automatic addition of content within the file
information about the call stack
information about time or the number of iteration


File::Temp::FromContext
...

my less than 2 cents

Nadim


+++ Robert Rothenberg [Thu, Jun 16, 2011 at 09:23:50PM +0100]:
 While debugging a project that generated a lot of temporary files, I came
 upon a nifty idea: rather than name the temporary files the usual random
 strings, why not have the files named by the method/function that created
 them, e.g. instead of something like /tmp/Hf6254d85.txt, why not call it
 /tmp/Some_Package_Name/text_analysing_function-Hf6254d85.txt.
 
 Anyhow, I think this might be something worth uploading to CPAN.
 
 So what should it be called?
 
 I was thinking of something like File::Temp::Smart, for lack of a better
 name. But I am open to better ideas.
 
 Suggestions?
 
 Rob