Re: [Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-06-14 Thread Phill
Review: Approve


-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/368843
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


Re: [Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-06-14 Thread Phill
Review: Approve


-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/368841
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


Re: [Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-06-14 Thread Phill
Review: Needs Fixing

Just one inconsistency with text labels (see inline) and the failed linting, 
but other than that looks ok!

Diff comments:

> 
> === modified file 'openlp/core/ui/media/mediatab.py'
> --- openlp/core/ui/media/mediatab.py  2019-05-04 19:47:06 +
> +++ openlp/core/ui/media/mediatab.py  2019-06-14 18:00:17 +
> @@ -68,11 +68,15 @@
>  self.left_layout.addWidget(self.live_media_group_box)
>  self.stream_media_group_box = QtWidgets.QGroupBox(self.left_column)
>  self.stream_media_group_box.setObjectName('stream_media_group_box')
> -self.stream_media_layout = 
> QtWidgets.QHBoxLayout(self.stream_media_group_box)
> +self.stream_media_layout = 
> QtWidgets.QFormLayout(self.stream_media_group_box)
>  self.stream_media_layout.setObjectName('stream_media_layout')
>  self.stream_media_layout.setContentsMargins(0, 0, 0, 0)
> -self.stream_edit = QtWidgets.QLabel(self)
> -self.stream_media_layout.addWidget(self.stream_edit)
> +self.video_edit = QtWidgets.QLineEdit(self)
> +self.stream_media_layout.addRow(translate('MediaPlugin.MediaTab', 
> 'Video:'), self.video_edit)

colon here

> +self.audio_edit = QtWidgets.QLineEdit(self)
> +self.stream_media_layout.addRow(translate('MediaPlugin.MediaTab', 
> 'Audio'), self.audio_edit)

but not here

> +self.stream_cmd = QtWidgets.QLabel(self)
> +self.stream_media_layout.addWidget(self.stream_cmd)
>  self.left_layout.addWidget(self.stream_media_group_box)
>  self.vlc_arguments_group_box = QtWidgets.QGroupBox(self.left_column)
>  self.vlc_arguments_group_box.setObjectName('vlc_arguments_group_box')


-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/368841
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


Re: [Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-05-06 Thread Raoul Snyman
Review: Approve


-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366957
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


Re: [Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-05-02 Thread Tomas Groth
Review: Needs Fixing

I tried running the branch on a windows system which I then realized didn't 
have VLC. But it resulted in this traceback: https://bin.snyman.info/mmmvuquw
-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366608
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


Re: [Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-04-27 Thread Raoul Snyman
Review: Needs Fixing

Looks good.

One thing I would prefer to change though, is "VLC additions" aka "VLC 
additional commands". They are not commands, they are command line arguments, 
so I would call them "VLC arguments". In my opinion, "additions" is ambiguous 
and unclear.
-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366608
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


Re: [Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-04-21 Thread Tim Bentley
Prints are there as the code just explodes on my machine and shuts OpenLP down.
No worth doing anything cute while it is this state!  They never get called.

Happy to move flag.
-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366336
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp


Re: [Openlp-core] [Merge] lp:~trb143/openlp/more_media into lp:openlp

2019-04-21 Thread Tomas Groth
Review: Needs Fixing

A few comments below. Will try to test on a few systems later.

Diff comments:

> 
> === modified file 'openlp/core/ui/generaltab.py'
> --- openlp/core/ui/generaltab.py  2019-03-16 10:20:46 +
> +++ openlp/core/ui/generaltab.py  2019-04-21 12:51:38 +
> @@ -113,6 +113,9 @@
>  self.check_for_updates_check_box = 
> QtWidgets.QCheckBox(self.startup_group_box)
>  
> self.check_for_updates_check_box.setObjectName('check_for_updates_check_box')
>  self.startup_layout.addWidget(self.check_for_updates_check_box)
> +self.experimental_check_box = 
> QtWidgets.QCheckBox(self.startup_group_box)
> +self.experimental_check_box.setObjectName('experimental_check_box')
> +self.startup_layout.addWidget(self.experimental_check_box)
>  self.right_layout.addWidget(self.startup_group_box)

Wouldn't it make more sense to have the experimental thing on the advanced tab?

>  # Logo
>  self.logo_group_box = QtWidgets.QGroupBox(self.right_column)
> 
> === modified file 'openlp/core/ui/media/mediatab.py'
> --- openlp/core/ui/media/mediatab.py  2019-04-09 17:32:10 +
> +++ openlp/core/ui/media/mediatab.py  2019-04-21 12:51:38 +
> @@ -100,6 +108,20 @@
>  self.stream_edit.setPlainText(LINUX_STREAM)
>  elif is_win:
>  self.stream_edit.setPlainText(WIN_STREAM)
> +else:
> +self.stream_edit.setPlainText(OSX_STREAM)
> +
> self.vlc_additions_edit.setPlainText(Settings().value(self.settings_section + 
> '/vlc additions'))
> +if Settings().value('core/experimental'):
> +print('Video input:')
> +for cam in QCameraInfo.availableCameras():
> +print('===')
> +print(cam.deviceName())
> +print(cam.description())
> +print()
> +print('Audio input:')
> +for au in QAudioDeviceInfo.availableDevices(QAudio.AudioInput):
> +print('===')
> +print(au.deviceName())

Remove prints, or put in debug log

>  
>  def save(self):
>  """


-- 
https://code.launchpad.net/~trb143/openlp/more_media/+merge/366336
Your team OpenLP Core is subscribed to branch lp:openlp.

___
Mailing list: https://launchpad.net/~openlp-core
Post to : openlp-core@lists.launchpad.net
Unsubscribe : https://launchpad.net/~openlp-core
More help   : https://help.launchpad.net/ListHelp