[OpenWrt-Devel] ubiquiti unifi pro vlan config issue

2014-07-08 Thread ulf kypke
hi, i have problems getting a vlan setting working on a unifi pro runnnig
on a managed switch with tagged vlan ports


based on the hardware table in the wiki the unifi pro has a AR8327 switch.

i tried setting up a config like
http://wiki.openwrt.org/toh/ubiquiti/routerstation.pro

and i also tried a setup like the readme in
http://wiki.openwrt.org/doc/uci/network/switch

both without success, the device is not reachable anymore.

does anyone know how to run the unifi pro in vlan
so that each wifi mapped to one tagged vlan like for example:

the 2.4 ghz wifi is mapped to vlan2
and the 5ghz wifi is mapped to vlan5

and config for the device is mapped to vlan3

here is my config network:

config interface 'vlan3'
option ifname 'eth0.3'
option proto 'static'
option ipaddr '192.168.1.91'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'

config interface 'vlan2'

option ifname 'eth0.2'
option type 'bridge'
option proto 'none'

config interface 'vlan5'

option ifname 'eth0.5'
option type 'bridge'
option proto 'none'


and wireless is like this
...
...

config wifi-iface
option device 'radio0'
option mode 'ap'
option encryption 'none'
option ssid 'guest'
option network 'vlan2'

config wifi-iface
option device 'radio1'
option mode 'ap'
option encryption 'wpa-mixed'
option key 'foofoofoo'
option ssid 'private'
option network 'vlan5'



and help or tips would be awesome

thanks ulf


-- 
--
Ulf Kypke-Burchardi
Köpenicker Strasse 159
10997 Berlin, Germany
+49 - (0) 177 - 3405152
--
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] edgerouter lite vs openwrt

2014-07-08 Thread Luca Postregna
Is there anybody with experience in setup openwrt on ubiquiti edgerouter
lite?
I found only incomplete online information about.
Is there howto?

Thanks
LP

-- 
luca.postregna.name
twitter.com/lucapost
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] edgerouter lite vs openwrt

2014-07-08 Thread Edison Figueira Junior
the trunk version works correctly

Enviada do meu iPhone

 Em 08/07/2014, às 10:04, Luca Postregna luca.postre...@gmail.com escreveu:
 
 Is there anybody with experience in setup openwrt on ubiquiti edgerouter lite?
 I found only incomplete online information about.
 Is there howto?
 
 Thanks
 LP
 
 -- 
 luca.postregna.name
 twitter.com/lucapost
 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] why only hostapd?

2014-07-08 Thread smilebef
Only hostap work with dfs in AP-Mode?
This is the last development step here?
Than is this not rewarding for me.

Bacause:
Wy this limitation?
Is this necessary?

I think no.

1. I think the Hardware has only to disable the channel if Radar is
   detectet. Right? It works.
2. The Software in Userspace has to choice a (ald and new) channel.
Right? It works only with hostapd!
3. We are not bound to honour a standard, that not explicit writen for
ours application!
4. We are only engaged to fulfil the laws of the countries.

But why only hostapd?

If the Hardware disables the channel because radardetect, i do not need
any instance, that tell me wich aplication rules my channels, because i
can not overide disabled channels by hardware with the software tools.

I think the choice of the channel can also be done by a shell-script
using iw or iwconfig located in chrontab.

The current situation is in my opinion not nessesary and not
consistent to ours situation.

lg




Am Thu, 03 Jul 2014 18:14:10 +0200
schrieb Martin Garbe monomar...@opennet-initiative.de:

 On 7/3/14, 7:28 AM, Jacek Kikiewicz wrote:
  Hi,
  
  I sure selected this option, as I said command 'iw phy phy1 info'
  does in fact show DFS channels, but I just cannot set them for
  usage...
  
 
 The command iw phy ... only shows hardware capabilities. For DFS
 hardware AND software support is needed. In OpenWRT you need hostapd
 to support DFS too. The config parameter CONFIG_PACKAGE_ATH_DFS
 explicitely activates DFS in hostapd. This parameter is not set by
 default. For more information see also the patch with comment in git:
 http://git.openwrt.org/?p=openwrt.git;a=commitdiff;h=5fd90c893f86e88150ea81be7afd337ac1b802aa
 
 Regards,
 Martin
 
 
  Jacek
  
  On 07/02/14 22:50, Martin Garbe wrote:
  On 7/1/14, 10:04 AM, Jacek Kikiewicz wrote:
  Hello,
 
  I have few APs that are using ath9k driver, I've read that now
  DFS is supported on that driver,
  so I compiled latest revision (yesterday: 41415), and started
  playing, basically when as per
  manual / howto I run 'iw phy phy1 info' I can see DFS channels,
  exactly like in howto on a wiki, problem is however
  that I cannot make it work on those channels (I've tried
  52,56,100, 104), after changing config and restarting wifi
  I saw in dmesg 'interface wlan1 entered disabled mode) - I tried
  with HT20 for the beginning.
  So, question here is, should this work in current state or is
  there still some support missing?
  I can pull any logs  / settings that are of interest.
  Have you elected
CONFIG_PACKAGE_ATH_DFS=y
  when compiling the driver? This way you agree to the fact that your
  hardware supports DFS. After that DFS channels can be selected.
 
 
  Martin
 
  Thanks!
  Jacek
  ___
  openwrt-devel mailing list
  openwrt-devel@lists.openwrt.org
  https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
 
  ___
  openwrt-devel mailing list
  openwrt-devel@lists.openwrt.org
  https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
  ___
  openwrt-devel mailing list
  openwrt-devel@lists.openwrt.org
  https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] edgerouter lite vs openwrt

2014-07-08 Thread Luca Postregna
Hi edison,
   can you summarize for me the right way to install openwrt on usb flash
of ERLite?


On Tue, Jul 8, 2014 at 3:21 PM, Edison Figueira Junior efjg...@gmail.com
wrote:

 the trunk version works correctly

 Enviada do meu iPhone

 Em 08/07/2014, às 10:04, Luca Postregna luca.postre...@gmail.com
 escreveu:

 Is there anybody with experience in setup openwrt on ubiquiti edgerouter
 lite?
 I found only incomplete online information about.
 Is there howto?

 Thanks
 LP

 --
 luca.postregna.name
 twitter.com/lucapost

 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel




-- 
luca.postregna.name
twitter.com/lucapost
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] edgerouter lite vs openwrt

2014-07-08 Thread Edison Figueira Junior
Hi luca,

Put the kernel on /dev/sda1 partition of usb flash with vmlinux.64 name and 
extract rootfs on /dev/sda2 of usb flash

make the backup of kernel ubnt :-) 



Enviada do meu iPhone

 Em 08/07/2014, às 10:39, Luca Postregna luca.postre...@gmail.com escreveu:
 
 Hi edison,
can you summarize for me the right way to install openwrt on usb flash of 
 ERLite?
 
 
 On Tue, Jul 8, 2014 at 3:21 PM, Edison Figueira Junior efjg...@gmail.com 
 wrote:
 the trunk version works correctly
 
 Enviada do meu iPhone
 
 Em 08/07/2014, às 10:04, Luca Postregna luca.postre...@gmail.com escreveu:
 
 Is there anybody with experience in setup openwrt on ubiquiti edgerouter 
 lite?
 I found only incomplete online information about.
 Is there howto?
 
 Thanks
 LP
 
 -- 
 luca.postregna.name
 twitter.com/lucapost
 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
 
 
 
 -- 
 luca.postregna.name
 twitter.com/lucapost
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [PATCH] [package] libubox: fix segment fault for out-of-memory

2014-07-08 Thread ewolfok
HI, all

this is a patch try to fix libubox's segment fault for out-of-memory

Best regards

Signed-off-by:Chen Bin ewol...@126.com
---
diff --git a/blob.c b/blob.c
index 10c1f49..ec8617b 100644
--- a/blob.c
+++ b/blob.c
@@ -21,12 +21,15 @@
 static bool
 blob_buffer_grow(struct blob_buf *buf, int minlen)
 {
+   struct blob_buf *new;
int delta = ((minlen / 256) + 1) * 256;
-   buf-buflen += delta;
-   buf-buf = realloc(buf-buf, buf-buflen);
-   if (buf-buf)
-   memset(buf-buf + buf-buflen - delta, 0, delta);
-   return !!buf-buf;
+   new = realloc(buf-buf, buf-buflen + delta);
+   if (new) {
+   buf-buf = new;
+   memset(buf-buf + buf-buflen, 0, delta);
+   buf-buflen += delta;
+   }
+   return !!new;
 }
 
 static void
@@ -50,15 +53,16 @@ attr_to_offset(struct blob_buf *buf, struct blob_attr *attr)
return (char *)attr - (char *) buf-buf + BLOB_COOKIE;
 }
 
-void
+bool
 blob_buf_grow(struct blob_buf *buf, int required)
 {
int offset_head = attr_to_offset(buf, buf-head);
 
if (!buf-grow || !buf-grow(buf, required))
-   return;
+   return false;
 
buf-head = offset_to_attr(buf, offset_head);
+   return true;
 }
 
 static struct blob_attr *
@@ -69,7 +73,8 @@ blob_add(struct blob_buf *buf, struct blob_attr *pos, int id, 
int payload)
struct blob_attr *attr;
 
if (required  0) {
-   blob_buf_grow(buf, required);
+   if (!blob_buf_grow(buf, required))
+   return NULL;
attr = offset_to_attr(buf, offset);
} else {
attr = pos;
@@ -142,6 +147,8 @@ blob_put_raw(struct blob_buf *buf, const void *ptr, 
unsigned int len)
return NULL;
 
attr = blob_add(buf, blob_next(buf-head), 0, len - sizeof(struct 
blob_attr));
+   if (!attr)
+   return NULL;
blob_set_raw_len(buf-head, blob_pad_len(buf-head) + len);
memcpy(attr, ptr, len);
return attr;
@@ -166,6 +173,8 @@ blob_nest_start(struct blob_buf *buf, int id)
 {
unsigned long offset = attr_to_offset(buf, buf-head);
buf-head = blob_new(buf, id, 0);
+   if (!buf-head)
+   return NULL;
return (void *) offset;
 }
 
diff --git a/blobmsg.c b/blobmsg.c
index f317152..ce9e4dd 100644
--- a/blobmsg.c
+++ b/blobmsg.c
@@ -212,6 +212,8 @@ blobmsg_open_nested(struct blob_buf *buf, const char *name, 
bool array)
name = ;
 
head = blobmsg_new(buf, type, name, 0, data);
+   if (!head)
+   return NULL;
blob_set_raw_len(buf-head, blob_pad_len(buf-head) - 
blobmsg_hdrlen(strlen(name)));
buf-head = head;
return (void *)offset;
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] why only hostapd?

2014-07-08 Thread Felix Fietkau
On 2014-07-08 15:22, smile...@gmail.com wrote:
 Only hostap work with dfs in AP-Mode?
 This is the last development step here?
 Than is this not rewarding for me.
LOLWUT?

 Bacause:
 Wy this limitation?
hostapd is already required for AP mode. It controls the AP state,
channel configuration, etc.

 Is this necessary?
At the moment, yes.

 I think no.
 
 1. I think the Hardware has only to disable the channel if Radar is
detectet. Right? It works.
 2. The Software in Userspace has to choice a (ald and new) channel.
 Right? It works only with hostapd!
 3. We are not bound to honour a standard, that not explicit writen for
 ours application!
 4. We are only engaged to fulfil the laws of the countries.
What you're writing looks a bit confused to me...

 But why only hostapd?
 
 If the Hardware disables the channel because radardetect, i do not need
 any instance, that tell me wich aplication rules my channels, because i
 can not overide disabled channels by hardware with the software tools.
 
 I think the choice of the channel can also be done by a shell-script
 using iw or iwconfig located in chrontab.
Even without DFS that doesn't work.

 The current situation is in my opinion not nessesary and not
 consistent to ours situation.
Your opinion seems to be lacking quite a bit of background regarding the
design of MAC layer management within mac80211, cfg80211 and hostapd.

- Felix
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH 2/4] [rb532] change default package set

2014-07-08 Thread Roman Yeryomin
On 8 July 2014 04:17, Florian Fainelli flor...@openwrt.org wrote:
 2014-07-07 13:57 GMT-07:00 Roman Yeryomin leroi.li...@gmail.com:
 On 7 July 2014 11:52, Felix Fietkau n...@openwrt.org wrote:
 On 2014-07-05 00:36, Roman Yeryomin wrote:
 There could be no wireless interfaces but ethernets are on board.

 Signed-off-by: Roman Yeryomin ro...@advem.lv
 Not taking this one. Adding kmod-via-rhine is unnecessary, since the
 driver is already built into the kernel.

 Ok, true... though I don't see the point in keeping wpad and madwifi there.

 Could you resubmit with a more recent package set such as wpad-mini
 and kmod-ath5k for instance?

How about just removing wpad and madwifi? I understand that, most
likely, there will be some wifi card installed but it can be any
minipci card and some (like me) may not use any wifi cards at all.

Regards,
Roman
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] edgerouter lite vs openwrt

2014-07-08 Thread Luca Postregna
do you have .config for me?


On Tue, Jul 8, 2014 at 3:43 PM, Edison Figueira Junior efjg...@gmail.com
wrote:

 Hi luca,

 Put the kernel on /dev/sda1 partition of usb flash with vmlinux.64 name
 and extract rootfs on /dev/sda2 of usb flash

 make the backup of kernel ubnt :-)



 Enviada do meu iPhone

 Em 08/07/2014, às 10:39, Luca Postregna luca.postre...@gmail.com
 escreveu:

 Hi edison,
can you summarize for me the right way to install openwrt on usb flash
 of ERLite?


 On Tue, Jul 8, 2014 at 3:21 PM, Edison Figueira Junior efjg...@gmail.com
 wrote:

 the trunk version works correctly

 Enviada do meu iPhone

 Em 08/07/2014, às 10:04, Luca Postregna luca.postre...@gmail.com
 escreveu:

 Is there anybody with experience in setup openwrt on ubiquiti edgerouter
 lite?
 I found only incomplete online information about.
 Is there howto?

 Thanks
 LP

 --
 luca.postregna.name
 twitter.com/lucapost

 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel




 --
 luca.postregna.name
 twitter.com/lucapost




-- 
luca.postregna.name
twitter.com/lucapost
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] uClibc menuconfig

2014-07-08 Thread Carlos Ferreira
Hello all!

Can anyone tell me how can I enable the pthread debug mode in uClibc?
I followed the instructions as explained here
https://forum.openwrt.org/viewtopic.php?id=25741 with no luck in
obtaining the libthread_db.so.

In here
http://cursos.leon.uia.mx/temporal/software/openwrt/openwrt/docs/buildroot-documentation.html#custom_uclibc,
the explanation for accessing the menuconfig for uClibc does not work in
trunk.
Does anyone knows if the uclibc menuconfig still exists in current trunk?

-- 

Carlos Miguel Ferreira
Researcher at Telecommunications Institute
Aveiro - Portugal
Work E-mail - c...@av.it.pt
Skype  GTalk - carlosmf...@gmail.com
LinkedIn - http://www.linkedin.com/in/carlosmferreira
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] [Patch] [ar71xx] added support for TL-WA830RE V2

2014-07-08 Thread Fredrik Jonson
Sorry for the incorrect topic.

Signed-off-by: Fredrik Jonson fred...@famjonson.se
---
 target/linux/ar71xx/base-files/etc/diag.sh |   1 +
 .../ar71xx/base-files/etc/uci-defaults/01_leds |   5 +
 .../ar71xx/base-files/etc/uci-defaults/02_network  |   1 +
 target/linux/ar71xx/base-files/lib/ar71xx.sh   |   3 +
 .../ar71xx/base-files/lib/upgrade/platform.sh  |   1 +
 target/linux/ar71xx/config-3.10|   1 +
 .../files/arch/mips/ath79/mach-tl-wa830re-v2.c | 132 +
 target/linux/ar71xx/image/Makefile |   3 +-
 target/linux/ar71xx/mikrotik/config-default|   1 +
 .../714-MIPS-auth79-add-TL-WA830REv2-support.patch |  42 +++
 10 files changed, 189 insertions(+), 1 deletion(-)
 create mode 100644 
target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa830re-v2.c
 create mode 100644 
target/linux/ar71xx/patches-3.10/714-MIPS-auth79-add-TL-WA830REv2-support.patch

diff --git a/target/linux/ar71xx/base-files/etc/diag.sh 
b/target/linux/ar71xx/base-files/etc/diag.sh
index ef172b4..d2e4937 100755
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -184,6 +184,7 @@ get_status_led() {
tl-wr841n-v1 | \
tl-wr841n-v7 | \
tl-wr841n-v8 | \
+   tl-wa830re-v2 | \
tl-wr842n-v2 | \
tl-wr941nd)
status_led=tp-link:green:system
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds 
b/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
index fe5ff93..ebc8942 100755
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
@@ -286,6 +286,11 @@ tl-wr841n-v8)
ucidef_set_led_wlan wlan WLAN tp-link:green:wlan phy0tpt
;;
 
+tl-wa830re-v2)
+   ucidef_set_led_netdev lan LAN tp-link:green:lan eth0
+   ucidef_set_led_wlan wlan WLAN tp-link:green:wlan phy0tpt
+   ;;
+
 tl-wr841n-v9)
ucidef_set_led_netdev wan WAN tp-link:green:wan eth1
ucidef_set_led_switch lan1 LAN1 tp-link:green:lan1 switch0 
0x10
diff --git a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network 
b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
index 646425c..6a43d03 100755
--- a/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ar71xx/base-files/etc/uci-defaults/02_network
@@ -269,6 +269,7 @@ tl-mr3040 |\
 tl-mr3040-v2 |\
 tl-wa750re |\
 tl-wa850re |\
+tl-wa830re-v2 |\
 tl-wa801nd-v2 |\
 tl-wa901nd |\
 tl-wa901nd-v2 |\
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh 
b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index bd277ab..88a1c86 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -541,6 +541,9 @@ ar71xx_board_detect() {
*TL-WA850RE)
name=tl-wa850re
;;
+   *TL-WA830RE v2)
+   name=tl-wa830re-v2
+   ;;
*TL-WA801ND v2)
name=tl-wa801nd-v2
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh 
b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 8af9580..8f3b563 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -253,6 +253,7 @@ platform_check_image() {
tl-wr741nd | \
tl-wr741nd-v4 | \
tl-wr841n-v1 | \
+   tl-wa830re-v2 | \
tl-wr841n-v7 | \
tl-wr841n-v8 | \
tl-wr841n-v9 | \
diff --git a/target/linux/ar71xx/config-3.10 b/target/linux/ar71xx/config-3.10
index 4e30a44..fbd22b9 100644
--- a/target/linux/ar71xx/config-3.10
+++ b/target/linux/ar71xx/config-3.10
@@ -82,6 +82,7 @@ CONFIG_ATH79_MACH_TL_MR11U=y
 CONFIG_ATH79_MACH_TL_MR13U=y
 CONFIG_ATH79_MACH_TL_MR3020=y
 CONFIG_ATH79_MACH_TL_MR3X20=y
+CONFIG_ATH79_MACH_TL_WA830RE_V2=y
 CONFIG_ATH79_MACH_TL_WA901ND=y
 CONFIG_ATH79_MACH_TL_WA901ND_V2=y
 CONFIG_ATH79_MACH_TL_WAX50RE=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa830re-v2.c 
b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa830re-v2.c
new file mode 100644
index 000..1c74fed
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa830re-v2.c
@@ -0,0 +1,132 @@
+/*
+ *  TP-LINK TL-WA830RE v2 board support
+ *
+ *  Copyright (C) 2014 Fredrik Jonson fred...@famjonson.se
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include linux/gpio.h
+#include linux/platform_device.h
+
+#include asm/mach-ath79/ath79.h
+#include asm/mach-ath79/ar71xx_regs.h
+
+#include common.h
+#include dev-eth.h
+#include dev-gpio-buttons.h
+#include dev-leds-gpio.h
+#include dev-m25p80.h
+#include dev-usb.h
+#include dev-wmac.h
+#include machtypes.h
+
+#define TL_WA830REV2_GPIO_LED_WLAN 13
+#define 

Re: [OpenWrt-Devel] [PATCH 2/4] [rb532] change default package set

2014-07-08 Thread Florian Fainelli
2014-07-08 8:01 GMT-07:00 Roman Yeryomin leroi.li...@gmail.com:
 On 8 July 2014 04:17, Florian Fainelli flor...@openwrt.org wrote:
 2014-07-07 13:57 GMT-07:00 Roman Yeryomin leroi.li...@gmail.com:
 On 7 July 2014 11:52, Felix Fietkau n...@openwrt.org wrote:
 On 2014-07-05 00:36, Roman Yeryomin wrote:
 There could be no wireless interfaces but ethernets are on board.

 Signed-off-by: Roman Yeryomin ro...@advem.lv
 Not taking this one. Adding kmod-via-rhine is unnecessary, since the
 driver is already built into the kernel.

 Ok, true... though I don't see the point in keeping wpad and madwifi there.

 Could you resubmit with a more recent package set such as wpad-mini
 and kmod-ath5k for instance?

 How about just removing wpad and madwifi? I understand that, most
 likely, there will be some wifi card installed but it can be any
 minipci card and some (like me) may not use any wifi cards at all.

How about keeping it? By the time the RB532 was sold, ath5k driven
mini-PCI cards were also sold, so they are likely to be still
installed. Either way, I am fine with nothing, you have already
dictated the use of 'eth0' as a WAN interface, so I guess that's a
fair change.
-- 
Florian
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Kernel module development workflow

2014-07-08 Thread Tomas Daujotas
Hello,
I was looking for a good reference for OpenWRT kernel module development
workflow. I know that it is possible to download the linux kernel, set up
the cross-compile and do all the job messing around the files, however I am
interested if there is a *correct* way of doing driver development.
I've been using Eclipse for most of my embedded designs and search on
Google ended up in this lovely manual:
http://downloads.openwrt.org/docs/eclipse.pdf
Since it already sets up the cross-compile stuff, the main issue for me
should be setting up the correct include paths for kernel headers. This
becomes an interesting task. E.g. we have an include from the example here:
http://www.thegeekstuff.com/2013/07/write-linux-kernel-module/ -

#include linux/module.h

However, the current path for the kernel sources is:
./openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2/linux-ar71xx_generic
including the path ./openwrt/build_dir/target-mips_34kc_uClibc-0.9.33.2
would not work, so this requires either renaming the directory, creating a
symlink or using another kernel sources location, which I probably don't
know. I couldn't find a decent and good manual of setting up the
environment.

Could you please put me on the correct way of how to start the development
properly, so the driver could be easily implemented into the system?

Thank you.

BR
Tomas Daujotas
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH 2/4] [rb532] change default package set

2014-07-08 Thread Roman Yeryomin
On 8 July 2014 21:37, Florian Fainelli flor...@openwrt.org wrote:
 2014-07-08 8:01 GMT-07:00 Roman Yeryomin leroi.li...@gmail.com:
 On 8 July 2014 04:17, Florian Fainelli flor...@openwrt.org wrote:
 2014-07-07 13:57 GMT-07:00 Roman Yeryomin leroi.li...@gmail.com:
 On 7 July 2014 11:52, Felix Fietkau n...@openwrt.org wrote:
 On 2014-07-05 00:36, Roman Yeryomin wrote:
 There could be no wireless interfaces but ethernets are on board.

 Signed-off-by: Roman Yeryomin ro...@advem.lv
 Not taking this one. Adding kmod-via-rhine is unnecessary, since the
 driver is already built into the kernel.

 Ok, true... though I don't see the point in keeping wpad and madwifi there.

 Could you resubmit with a more recent package set such as wpad-mini
 and kmod-ath5k for instance?

 How about just removing wpad and madwifi? I understand that, most
 likely, there will be some wifi card installed but it can be any
 minipci card and some (like me) may not use any wifi cards at all.

 How about keeping it? By the time the RB532 was sold, ath5k driven
 mini-PCI cards were also sold, so they are likely to be still
 installed. Either way, I am fine with nothing, you have already
 dictated the use of 'eth0' as a WAN interface, so I guess that's a
 fair change.

Didn't know that I'm a dictator :)
If you are fine with nothing that would mean you don't care, but seems you do.
It's just that I prefer defining defaults only if they are really
defaults. Like if there would be onboard wireless or if rb532 couldn't
be bought without wifi cards. But by default they were sold without
any wireless cards.
Either way, seems that nobody but me (at least from the list) really
uses these boards, so, I assumed, that my micro-dictatorship would be
acceptable. :)

Regards,
Roman
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Board-specific config for WNR1000v2

2014-07-08 Thread Cody Jackson

Hello all;

A OpenWRT ramdisk image runs nicely on my Netgear WNR1000v2 VC (Atheros 
7240 CPU, ar71xx target) except for the minor fact that when booted as a 
generic board, there are no network devices. (But who needs those 
anyway on a router, right?)


I'm hacking on the WNR2000 board init code (in 
linux/ar71xx/files/arch/mips/ath79/mach-wnr2000.c) and I believe I 
understand the gist of what it's doing. However, when I try booting with 
my hacked code, it crashes on ath79_register_wmac().


I think the key is this line:

u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff1000);

But I'm not sure what it does. My best guest is that it's a pointer to 
the flash memory (or possibly a specific portion of it, such as the ART 
partition with the device MAC addresses), with the magic number being 
its address in the address space of the device. I don't think 0x1fff1000 
is correct for the WNR1000v2. How can I go about figuring out the 
correct address (if it is incorrect)?


I've browsed through the Netgear GPL'd source code but there is an 
overwhelming number of addresses specified in a header file (ar7240.h). 
However, 0x1f is defined as AR7240_SPI_BASE, which does seem to 
be flash memory...


I'd appreciate any pointers in the right direction.

-Cody Jackson
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] why only hostapd?

2014-07-08 Thread Bernd Naumann
Hi Felix,

As I do not have the lightest clue about the magic behind DFS I want to
ask a question.

If I understand it correctly, routers in a mesh network have to change
there channel if they detect a radar, and all routers in a mesh network
have to use the same channel, but have to switch to the proper channel
/at once/?

Additionally, the only way to set the channel on OpenWRT is to use
hostapd? And the problem is, that some script have to make the decision
and have to tell hostapd the set the 'new' channel? Or am I completely
miss the point?

Thanks for making things clear to me,
Bernd
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] [PATCH] kernel: ledtrig-netdev: use netdev_notifier_info

2014-07-08 Thread Luka Perkov
Hi Claudio,

On Mon, Jul 07, 2014 at 08:24:32PM -0400, Claudio Leite wrote:
 Since kernel 3.11, the third parameter passed to notifier_call()
 is of type struct netdev_notifier_info. This patch fixes an oops
 when setting a netdev LED trigger.
 
 Signed-off-by: Claudio Leite lei...@staticky.com
 ---
  .../patches-3.12/833-ledtrig_netdev-use-notifier-info.patch | 13 
 +
  .../patches-3.13/833-ledtrig_netdev-use-notifier-info.patch | 13 
 +
  .../patches-3.14/833-ledtrig_netdev-use-notifier-info.patch | 13 
 +
  3 files changed, 39 insertions(+)
  create mode 100644 
 target/linux/generic/patches-3.12/833-ledtrig_netdev-use-notifier-info.patch
  create mode 100644 
 target/linux/generic/patches-3.13/833-ledtrig_netdev-use-notifier-info.patch
  create mode 100644 
 target/linux/generic/patches-3.14/833-ledtrig_netdev-use-notifier-info.patch

Applied in r41552. I have merged the patch with already existing
831-ledtrig_netdev.patch. Thanks for fixing this!

Luka
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel