[PATCH] images: Revert "fix boot failures on NAND with small sub pages"

2020-12-04 Thread Sven Eckelmann
This reverts commit ee76bd11bbe7 ("images: fix boot failures on NAND with
small sub pages") which broke (besides telling otherwise in the commit
message) the boot after sysupgrade on some NOR based devices.

The NOR flash rootfs images stored in a sysupgrade.tar must end with the
JFFS2 marker. Otherwise, devices like OpenMesh A42/A62 are not able to
calculate the md5sum of the fixed squashfs part and store it inside the
u-boot-env.

But the commit ee76bd11bbe7 ("images: fix boot failures on NAND with small
sub pages") adds up to 1020 0x00 bytes after the 0xdead0de EOF marker. The
calculated md5sum will be wrong due do this change and u-boot will fail to
boot the newly flashed device with a message like:

  Validating MD5Sum of 'vmlinux'...
  Passed!
  Validating MD5Sum of 'rootfs'...
  Failed!
  583a1b7b54b8601efa64ade42742459b != 8850ee812dfd7638e94083329d5d2781

  Data validation failed!

Cc: Russell Senior 
Cc: Jonas Gorski 
Signed-off-by: Sven Eckelmann 
---
I've originally submitted another hack on top of the original hack to avoid
this additional padding when the JFFS2 post-padding mark was detected.

https://github.com/openwrt/openwrt/pull/3616

But I was not yet able to get feedback from the original author.
---
 scripts/functions.sh  | 26 --
 scripts/sysupgrade-tar.sh | 13 +
 scripts/ubinize-image.sh  | 37 +++--
 3 files changed, 16 insertions(+), 60 deletions(-)
 delete mode 100644 scripts/functions.sh

diff --git a/scripts/functions.sh b/scripts/functions.sh
deleted file mode 100644
index 9a7fcde627..00
--- a/scripts/functions.sh
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-
-
-get_magic_word() {
-   dd if=$1 bs=4 count=1 2>/dev/null | od -A n -N 4 -t x1 | tr -d ' '
-}
-
-get_fs_type() {
-   local magic_word="$(get_magic_word "$1")"
-
-   case "$magic_word" in
-   "3118"*)
-   echo "ubifs"
-   ;;
-   "68737173")
-   echo "squashfs"
-   ;;
-   *)
-   echo "unknown"
-   ;;
-   esac
-}
-
-round_up() {
-   echo "$$1 + ($2 - 1))/ $2) * $2))"
-}
diff --git a/scripts/sysupgrade-tar.sh b/scripts/sysupgrade-tar.sh
index b93b2584bb..d1d627a96e 100755
--- a/scripts/sysupgrade-tar.sh
+++ b/scripts/sysupgrade-tar.sh
@@ -1,7 +1,5 @@
 #!/bin/sh
 
-. $TOPDIR/scripts/functions.sh
-
 board=""
 kernel=""
 rootfs=""
@@ -55,16 +53,7 @@ fi
 
 mkdir -p "${tmpdir}/sysupgrade-${board}"
 echo "BOARD=${board}" > "${tmpdir}/sysupgrade-${board}/CONTROL"
-if [ -n "${rootfs}" ]; then
-   case "$( get_fs_type ${rootfs} )" in
-   "squashfs")
-   dd if="${rootfs}" of="${tmpdir}/sysupgrade-${board}/root" 
bs=1024 conv=sync
-   ;;
-   *)
-   cp "${rootfs}" "${tmpdir}/sysupgrade-${board}/root"
-   ;;
-   esac
-fi
+[ -z "${rootfs}" ] || cp "${rootfs}" "${tmpdir}/sysupgrade-${board}/root"
 [ -z "${kernel}" ] || cp "${kernel}" "${tmpdir}/sysupgrade-${board}/kernel"
 
 mtime=""
diff --git a/scripts/ubinize-image.sh b/scripts/ubinize-image.sh
index c6f8bcefe5..32bd5ca326 100755
--- a/scripts/ubinize-image.sh
+++ b/scripts/ubinize-image.sh
@@ -1,7 +1,5 @@
 #!/bin/sh
 
-. $TOPDIR/scripts/functions.sh
-
 part=""
 ubootenv=""
 ubinize_param=""
@@ -11,6 +9,16 @@ outfile=""
 err=""
 ubinize_seq=""
 
+get_magic_word() {
+   dd if=$1 bs=2 count=1 2>/dev/null | od -A n -N 2 -t x1 | tr -d ' '
+}
+
+is_ubifs() {
+   if [ "$( get_magic_word $1 )" = "3118" ]; then
+   echo "1"
+   fi
+}
+
 ubivol() {
volid=$1
name=$2
@@ -24,7 +32,7 @@ ubivol() {
echo "vol_name=$name"
if [ "$image" ]; then
echo "image=$image"
-   [ -n "$size" ] && echo "vol_size=${size}"
+   [ -n "$size" ] && echo "vol_size=${size}MiB"
else
echo "vol_size=1MiB"
fi
@@ -35,10 +43,7 @@ ubivol() {
 
 ubilayout() {
local vol_id=0
-   local rootsize=
-   local autoresize=
-   local rootfs_type="$( get_fs_type "$2" )"
-
+   local root_is_ubifs="$( is_ubifs "$2" )"
if [ "$1" = "ubootenv" ]; then
ubivol $vol_id ubootenv
vol_id=$(( $vol_id + 1 ))
@@ -58,28 +63,16 @@ ubilayout() {
 
size="$part"
 
-   ubivol $vol_id "$name" "$image" "" "${size}MiB"
+   ubivol $vol_id "$name" "$image" "" "$size"
vol_id=$(( $vol_id + 1 ))
done
if [ "$3" ]; then
ubivol $vol_id kernel "$3"
vol_id=$(( $vol_id + 1 ))
fi
-
-   case "$rootfs_type" in
-   "ubifs")
-   autoresize=1
-   ;;
-   "squashfs")
-   # squashfs uses 1k block size, ensure we do not
-   # violate that
-   rootsize="$( round_up "$( stat -c%s "$2" )" 1024 )"
-   ;;
-   esac
-   ubivol $vol_id rootfs "$2" "$autore

[PATCH] lzo: remove

2020-12-04 Thread Rosen Penev
This is not used by any package in base. It will be moved to packages.

Signed-off-by: Rosen Penev 
---
 package/libs/lzo/Makefile | 61 ---
 1 file changed, 61 deletions(-)
 delete mode 100644 package/libs/lzo/Makefile

diff --git a/package/libs/lzo/Makefile b/package/libs/lzo/Makefile
deleted file mode 100644
index 09885e8d9b..00
--- a/package/libs/lzo/Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-#
-# Copyright (C) 2006-2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=lzo
-PKG_VERSION:=2.10
-PKG_RELEASE:=4
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.oberhumer.com/opensource/lzo/download/
-PKG_HASH:=c0f892943208266f9b6543b3ae308fab6284c5c90e627931446fb49b4221a072
-
-PKG_LICENSE:=GPL-2.0-or-later
-PKG_LICENSE_FILES:=COPYING
-
-PKG_BUILD_PARALLEL:=1
-CMAKE_BINARY_SUBDIR:=openwrt-build
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-define Package/liblzo
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=A real-time data compression library
-  URL:=http://www.oberhumer.com/opensource/lzo/
-  ABI_VERSION:=2
-endef
-
-define Package/liblzo/description
- LZO is a data compression library which is suitable for data de-/compression
- in real-time. This means it favours speed over compression ratio.
-endef
-
-CMAKE_OPTIONS += \
-   -DENABLE_SHARED=ON \
-   -DENABLE_STATIC=ON \
-   \
-   -DBUILD_TESTING=OFF \
-   -DCMAKE_SKIP_INSTALL_RPATH=ON
-
-define Build/InstallDev
-   $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
-   $(CP) $(PKG_INSTALL_DIR)/usr/include/lzo $(1)/usr/include/
-   $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.{a,so*} $(1)/usr/lib/
-   $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lzo2.pc 
$(1)/usr/lib/pkgconfig
-   $(SED) 's,/usr/include,{prefix}/include,g' 
$(1)/usr/lib/pkgconfig/lzo2.pc
-   $(SED) 's,/usr/lib,{exec_prefix}/lib,g' 
$(1)/usr/lib/pkgconfig/lzo2.pc
-endef
-
-define Package/liblzo/install
-   $(INSTALL_DIR) $(1)/usr/lib
-   $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,liblzo))
-- 
2.28.0


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: Lightweight policy-based routing

2020-12-04 Thread Philip Prindeville
But I’m trying:

config rule
option src '192.168.3.6'
option lookup 200

Per the cheatsheet and it’s resulting in:

root@OpenWrt2:~# ip rule ls
0:  from all lookup local
1:  from all lookup 200
32766:  from all lookup main
32767:  from all lookup default

i.e. the ’src’ is being ignored.  Also trying:

config route
option target '151.101.0.0/16'
option interface ‘xfrm0'
option gateway '192.168.1.252'
option table 200
option proto ‘static'

But that works great.


> On Dec 4, 2020, at 1:00 PM, Jo-Philipp Wich  wrote:
> 
> Hi Philip,
> 
> ip rules are possible in uci, but not sure if all the bits you require are
> covered:
> 
> https://openwrt.org/docs/guide-user/network/ucicheatsheet#ip_rules_for_both_rule_and_rule6
> 
> `config route` sections allow specifying `option table` as well to stage the
> routes in the non-main rttable.
> 
> Since the device options for uci rules and routes require logical networks and
> not Linux network device names, you might need to declare a dummy interface
> for xfrm0, like this:
> 
> config interface vpn
>  option proto static
>  option ifname xfrm0
> 
> It might be that netifd will clear out any IP addresses on the xfrm0
> interface, so you would need to encode those in uci as well:
> 
> config interface vpn
>  option proto static
>  option ifname xfrm0
>  option ipaddr 192.168.1.0/24
>  option table 200   # will instruct netifd to put any related routes into
> table 200
> 
> 
> Netifd understands aliases set up in /etc/iproute2/rt_tables but there is no
> uci way to declare new symbolic aliases. So either you need to manage that
> file externally or you stick to numeric table IDs.
> 
> ~ Jo
> 
> ___
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: Lightweight policy-based routing

2020-12-04 Thread Jo-Philipp Wich
Hi Philip,

ip rules are possible in uci, but not sure if all the bits you require are
covered:

https://openwrt.org/docs/guide-user/network/ucicheatsheet#ip_rules_for_both_rule_and_rule6

`config route` sections allow specifying `option table` as well to stage the
routes in the non-main rttable.

Since the device options for uci rules and routes require logical networks and
not Linux network device names, you might need to declare a dummy interface
for xfrm0, like this:

config interface vpn
  option proto static
  option ifname xfrm0

It might be that netifd will clear out any IP addresses on the xfrm0
interface, so you would need to encode those in uci as well:

config interface vpn
  option proto static
  option ifname xfrm0
  option ipaddr 192.168.1.0/24
  option table 200   # will instruct netifd to put any related routes into
table 200


Netifd understands aliases set up in /etc/iproute2/rt_tables but there is no
uci way to declare new symbolic aliases. So either you need to manage that
file externally or you stick to numeric table IDs.

~ Jo



signature.asc
Description: OpenPGP digital signature
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Lightweight policy-based routing

2020-12-04 Thread Philip Prindeville
Hi.

I’m currently manually doing the following in a script but was wondering if 
there was an easy way to do this in UCI, such as in /etc/config/network:

#!/bin/sh

INTF=xfrm0
STB=192.168.3.6/24
TABLE=stb
GW2=192.168.1.252
NETS="151.101.0.0/16"

eval `ipcalc -n -p $STB`

if ! grep -q "^200 $TABLE" /etc/iproute2/rt_tables; then
echo "200 $TABLE" >> /etc/iproute2/rt_tables
fi

for NET in $NETS; do
ip route add $NET via $GW2 dev $INTF table $TABLE
done
ip route add $NETWORK/$PREFIX dev br-lan table $TABLE

ip route flush cache

ip rule add from ${STB%%/*} table $TABLE


Basically, I have an STB that I travel with that mostly works on the road, but 
one of the services is anchored to my home IP so I have to backhaul that with 
VPN to get it to work, and that service is hosted on fastly.

Is there any easy way to integrate this into my OpenWRT config?  (Yes, I also 
have a RPi4 that I use as a portable pocket firewall/hotspot…)

Thanks,

-Philip




___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[PATCH] rules.mk: use -fPIC instead of -fpic on arm64

2020-12-04 Thread Stijn Tintel
Some packages fail to build on arm64 when PKG_ASLR_PIE_ALL=y, due to
machine-specific size restrictions on the global offset table.
While the manual instructs to recompile with -fPIC if it fails with
-fpic, by doing this per package, there is still a risk of random
breakage due to version bumps or other changes, so let's use -fPIC on
arm64 by default.

While comparing the sizes of 141 packages built with -fpic vs -fPIC,
most packages are either equal or smaller in size. Only 9 of the
compared packages turned out slightly larger.

Signed-off-by: Stijn Tintel 
---
 rules.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/rules.mk b/rules.mk
index 34222a3a71..f79340b124 100644
--- a/rules.mk
+++ b/rules.mk
@@ -77,7 +77,7 @@ IS_PACKAGE_BUILD := $(if $(filter 
package/%,$(BUILD_SUBDIR)),1)
 
 OPTIMIZE_FOR_CPU=$(subst i386,i486,$(ARCH))
 
-ifeq ($(ARCH),powerpc)
+ifneq (,$(findstring $(ARCH) , aarch64 aarch64_be powerpc ))
   FPIC:=-fPIC
 else
   FPIC:=-fpic
-- 
2.26.2


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


RE: What happened to 18.06.9? (Re: Upcoming 19.07.4 and 18.07.9 stable releases

2020-12-04 Thread Adrian Schmutzler
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
> On Behalf Of Hannu Nyman
> Sent: Freitag, 4. Dezember 2020 15:27
> To: openwrt-devel@lists.openwrt.org; Hauke Mehrtens  m.de>
> Subject: What happened to 18.06.9? (Re: Upcoming 19.07.4 and 18.07.9
> stable releases
> 
> *Hauke Mehrtens* wrote on /Tue Nov 10 18:58:52 EST 2020:
> /
> 
> /> /Currently 18.06 looks good for me and I would really like to do the final
> release and call it then officially end of life. I would wait for the build 
> bot
> results and then do it at the weekend.
> 
> 
> What happened to 18.06.9?
> It was tagged and built over two weeks ago, but was never officially
> released?
> (no trace of it in either forum, mailing list or
> https://downloads.openwrt.org/*  )*

It's in downloads, it's just not linked:

https://downloads.openwrt.org/releases/18.06.9/

(Just an observation, I've not taken part in the process of making that 
release.)

> 
> 
> Ps. Is 18.06 now EoL ?
> 
> 
> 
> ___
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel


openpgp-digital-signature.asc
Description: PGP signature
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


What happened to 18.06.9? (Re: Upcoming 19.07.4 and 18.07.9 stable releases

2020-12-04 Thread Hannu Nyman

*Hauke Mehrtens* wrote on /Tue Nov 10 18:58:52 EST 2020:
/

/> /Currently 18.06 looks good for me and I would really like to do the final 
release and call it then officially end of life. I would wait for the build 
bot results and then do it at the weekend.



What happened to 18.06.9?
It was tagged and built over two weeks ago, but was never officially released?
(no trace of it in either forum, mailing list or 
https://downloads.openwrt.org/*  )*



Ps. Is 18.06 now EoL ?



___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[PATCH v3 3/3] ltq-dsl-base: bump PKG_RELEASE

2020-12-04 Thread Andre Heider
Signed-off-by: Andre Heider 
---
 package/network/utils/ltq-dsl-base/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/package/network/utils/ltq-dsl-base/Makefile 
b/package/network/utils/ltq-dsl-base/Makefile
index e2cfc4004c..aae07bc299 100644
--- a/package/network/utils/ltq-dsl-base/Makefile
+++ b/package/network/utils/ltq-dsl-base/Makefile
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ltq-dsl-base
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
-- 
2.29.2


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[PATCH v3 2/3] ltq-dsl-base: remove preformatted integer values from lucistat

2020-12-04 Thread Andre Heider
luci has been converted to use the raw values, see [0].
Remove the now unused values.

[0] https://github.com/openwrt/luci/pull/4635

Signed-off-by: Andre Heider 
---
 .../files/lib/functions/lantiq_dsl.sh | 54 ---
 1 file changed, 22 insertions(+), 32 deletions(-)

diff --git 
a/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh 
b/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
index 1a28633c79..169e602d4a 100755
--- a/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
+++ b/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
@@ -149,15 +149,13 @@ data_rates() {
[ -z "$drd" ] && drd=0
[ -z "$dru" ] && dru=0
 
-   sdrd=$(scale $drd)
-   sdru=$(scale $dru)
-
if [ "$action" = "lucistat" ]; then
echo "dsl.data_rate_down=$drd"
echo "dsl.data_rate_up=$dru"
-   echo "dsl.data_rate_down_s=\"$sdrd\""
-   echo "dsl.data_rate_up_s=\"$sdru\""
else
+   sdrd=$(scale $drd)
+   sdru=$(scale $dru)
+
echo "Data Rate:Down: ${sdrd}/s 
/ Up: ${sdru}/s"
fi
 }
@@ -426,17 +424,15 @@ latency_delay() {
idu_s="Fast"
fi
 
-   sidu=$(scale_latency $idu)
-   sidd=$(scale_latency $idd)
-
if [ "$action" = "lucistat" ]; then
echo "dsl.latency_down=\"$(scale_latency_us $idd)\""
echo "dsl.latency_up=\"$(scale_latency_us $idu)\""
-   echo "dsl.latency_num_down=\"$sidd\""
-   echo "dsl.latency_num_up=\"$sidu\""
echo "dsl.latency_s_down=\"$idd_s\""
echo "dsl.latency_s_up=\"$idu_s\""
else
+   sidu=$(scale_latency $idu)
+   sidd=$(scale_latency $idd)
+
echo "Latency [Interleave Delay]:   ${sidd} 
[${idd_s}]   ${sidu} [${idu_s}]"
fi
 }
@@ -536,26 +532,22 @@ line_uptime() {
 
[ -z "$et" ] && et=0
 
-   d=$(expr $et / 86400)
-   etr=$(expr $et % 86400)
-   h=$(expr $etr / 3600)
-   etr=$(expr $etr % 3600)
-   m=$(expr $etr / 60)
-   s=$(expr $etr % 60)
-
-
-   [ "${d}${h}${m}${s}" -ne 0 ] && rc="${s}s"
-   [ "${d}${h}${m}" -ne 0 ] && rc="${m}m ${rc}"
-   [ "${d}${h}" -ne 0 ] && rc="${h}h ${rc}"
-   [ "${d}" -ne 0 ] && rc="${d}d ${rc}"
-
-   [ -z "$rc" ] && rc="down"
-
-
if [ "$action" = "lucistat" ]; then
echo "dsl.line_uptime=${et}"
-   echo "dsl.line_uptime_s=\"${rc}\""
else
+   d=$(expr $et / 86400)
+   etr=$(expr $et % 86400)
+   h=$(expr $etr / 3600)
+   etr=$(expr $etr % 3600)
+   m=$(expr $etr / 60)
+   s=$(expr $etr % 60)
+
+   [ "${d}${h}${m}${s}" -ne 0 ] && rc="${s}s"
+   [ "${d}${h}${m}" -ne 0 ] && rc="${m}m ${rc}"
+   [ "${d}${h}" -ne 0 ] && rc="${h}h ${rc}"
+   [ "${d}" -ne 0 ] && rc="${d}d ${rc}"
+
+   [ -z "$rc" ] && rc="down"
 
echo "Line Uptime Seconds:  ${et}"
echo "Line Uptime:  ${rc}"
@@ -615,9 +607,6 @@ line_data() {
[ -z "$attndrd" ] && attndrd=0
[ -z "$attndru" ] && attndru=0
 
-   sattndrd=$(scale $attndrd)
-   sattndru=$(scale $attndru)
-   
if [ "$action" = "lucistat" ]; then
echo "dsl.line_attenuation_down=\"$latnd\""
echo "dsl.line_attenuation_up=\"$latnu\""
@@ -629,9 +618,10 @@ line_data() {
echo "dsl.actatp_up=\"$actatpu\""
echo "dsl.max_data_rate_down=$attndrd"
echo "dsl.max_data_rate_up=$attndru"
-   echo "dsl.max_data_rate_down_s=\"$sattndrd\""
-   echo "dsl.max_data_rate_up_s=\"$sattndru\""
else
+   sattndrd=$(scale $attndrd)
+   sattndru=$(scale $attndru)
+
echo "Line Attenuation (LATN):  Down: ${latnd} 
dB / Up: ${latnu} dB"
echo "Signal Attenuation (SATN):Down: ${satnd} 
dB / Up: ${satnu} dB"
echo "Noise Margin (SNR):   Down: ${snrd} 
dB / Up: ${snru} dB"
-- 
2.29.2


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[PATCH v3 1/3] ltq-dsl-base: only lock the dsl pipe once for all stats

2020-12-04 Thread Andre Heider
Instead of locking/unlocking it for every command.

Reduces the runtime for the dslstat/lucistat commands to ~66%.

Before:
real0m 2.66s
user0m 0.90s
sys 0m 1.76s

After:
real0m 1.76s
user0m 0.63s
sys 0m 1.13s

Signed-off-by: Andre Heider 
---
v2: bump PKG_RELEASE
v3: use flock style suggested by Jo, bump release in different patch

 .../files/lib/functions/lantiq_dsl.sh | 35 ++-
 1 file changed, 18 insertions(+), 17 deletions(-)

diff --git 
a/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh 
b/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
index 5842a7879f..1a28633c79 100755
--- a/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
+++ b/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
@@ -11,12 +11,8 @@ fi
 # Basic functions to send CLI commands to the vdsl_cpe_control daemon
 #
 dsl_cmd() {
-   killall -q -0 ${XDSL_CTRL} && (
-   lock /var/lock/dsl_pipe
-   echo "$@" > /tmp/pipe/dsl_cpe0_cmd
-   cat /tmp/pipe/dsl_cpe0_ack
-   lock -u /var/lock/dsl_pipe
-   )
+   echo "$@" > /tmp/pipe/dsl_cpe0_cmd
+   cat /tmp/pipe/dsl_cpe0_ack
 }
 dsl_val() {
expr "$1" : '.*'$2'=\([-\.[:alnum:]]*\).*'
@@ -729,17 +725,22 @@ profile() {
 }
 
 dslstat() {
-   vendor
-   chipset
-   xtse
-   profile
-   line_state
-   errors
-   power_mode
-   latency_delay
-   data_rates
-   line_data
-   line_uptime
+   killall -q -0 ${XDSL_CTRL} || exit 1
+   (
+   flock -x 323
+
+   vendor
+   chipset
+   xtse
+   profile
+   line_state
+   errors
+   power_mode
+   latency_delay
+   data_rates
+   line_data
+   line_uptime
+   ) 323> /var/lock/dsl_pipe
 }
 
 lucistat() {
-- 
2.29.2


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


RE: [PATCH] mvebu: macchiatobin-singleshot: enable heartbeat LED

2020-12-04 Thread Adrian Schmutzler
> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
> On Behalf Of Alexandra Alth
> Sent: Freitag, 4. Dezember 2020 13:59
> To: Tomasz Maciej Nowak 
> Cc: openwrt-devel@lists.openwrt.org
> Subject: Re: [PATCH] mvebu: macchiatobin-singleshot: enable heartbeat LED
> 
> Is this now approved and integrated in the nightly? tnx alexandra

Did anyone say so?

> 
> > Am 25.11.2020 um 17:53 schrieb Tomasz Maciej Nowak
> :
> >
> > With board revision 1.3, SolidRun moved the power LED to the middle of
> > the board. In old place of power LED a GPIO controllable heartbeat LED
> > was added. This commit touches only Single Shot variant, because all
> > have revision 1.3. Some boards could be placed in an enclosure,
> > therefore the LED0 is enabled by default, since that'll be the only
> > visible indicator that the board is operating.
> >
> > Ref:
> > http://wiki.macchiatobin.net/tiki-index.php?page=Schematics#Revision1.
> > 3_Electrical_Design_Changes
> > Ref:
> > http://macchiatobin.net/wp-content/uploads/2017/11/MACCHIATOBin-
> rev-1_
> > 3.pdf
> >
> > Reported-by: Alexandra Alth 
> > Signed-off-by: Tomasz Maciej Nowak 
> > ---
> > target/linux/mvebu/image/cortexa72.mk |  2 +-
> > ...s-mcbin-singleshot-add-heartbeat-LED.patch | 59
> +++
> > 2 files changed, 60 insertions(+), 1 deletion(-) create mode 100644
> > target/linux/mvebu/patches-5.4/100-arm64-dts-mcbin-singleshot-add-
> hear
> > tbeat-LED.patch
> >
> > diff --git a/target/linux/mvebu/image/cortexa72.mk
> > b/target/linux/mvebu/image/cortexa72.mk
> > index 1440c07a0b5f..8bd4581766c2 100644
> > --- a/target/linux/mvebu/image/cortexa72.mk
> > +++ b/target/linux/mvebu/image/cortexa72.mk
> > @@ -38,7 +38,7 @@ define Device/marvell_macchiatobin-singleshot
> >   DEVICE_ALT0_VENDOR := SolidRun
> >   DEVICE_ALT0_MODEL := Armada 8040 Community Board
> >   DEVICE_ALT0_VARIANT := Single Shot
> > -  DEVICE_PACKAGES += kmod-i2c-mux-pca954x
> > +  DEVICE_PACKAGES += kmod-i2c-mux-pca954x kmod-ledtrig-heartbeat
> >   DEVICE_DTS := armada-8040-mcbin-singleshot
> >   SUPPORTED_DEVICES := marvell,armada8040-mcbin-singleshot
> > endef
> > diff --git
> > a/target/linux/mvebu/patches-5.4/100-arm64-dts-mcbin-singleshot-add-
> he
> > artbeat-LED.patch
> > b/target/linux/mvebu/patches-5.4/100-arm64-dts-mcbin-singleshot-add-
> he
> > artbeat-LED.patch
> > new file mode 100644
> > index ..a5f37461360b
> > --- /dev/null
> > +++ b/target/linux/mvebu/patches-5.4/100-arm64-dts-mcbin-singleshot-
> ad
> > +++ d-heartbeat-LED.patch
> > @@ -0,0 +1,59 @@
> > +From 310b7883b64993da355ad5cc3e45f515ac2bef2f Mon Sep 17 00:00:00
> > +2001
> > +From: Tomasz Maciej Nowak 
> > +Date: Sat, 17 Oct 2020 16:53:20 +0200
> > +Subject: [PATCH] arm64: dts: mcbin-singleshot: add heartbeat LED
> > +
> > +With board revision 1.3, SolidRun moved the power LED to the middle
> > +of the board. In old place of power LED a GPIO controllable heartbeat
> > +LED was added. This commit only touches Single Shot variant, since
> > +only this variant is all revision 1.3.
> > +
> > +Reported-by: Alexandra Alth 
> > +Signed-off-by: Tomasz Maciej Nowak 
> > +---
> > + .../marvell/armada-8040-mcbin-singleshot.dts  | 22
> > 
> > + 1 file changed, 22 insertions(+)
> > +
> > +--- a/arch/arm64/boot/dts/marvell/armada-8040-mcbin-singleshot.dts
> >  b/arch/arm64/boot/dts/marvell/armada-8040-mcbin-singleshot.dts
> > +@@ -5,6 +5,8 @@
> > +  * Device Tree file for MACCHIATOBin Armada 8040 community board
> > +platform
> > +  */
> > +
> > ++#include 
> > ++
> > + #include "armada-8040-mcbin.dtsi"
> > +
> > + / {
> > +@@ -12,6 +14,20 @@
> > +   compatible = "marvell,armada8040-mcbin-singleshot",
> > +   "marvell,armada8040-mcbin", "marvell,armada8040",
> > +   "marvell,armada-ap806-quad", "marvell,armada-
> ap806";
> > ++
> > ++  leds {
> > ++  compatible = "gpio-leds";
> > ++  pinctrl-0 = <&cp0_led18_pins>;
> > ++  pinctrl-names = "default";
> > ++
> > ++  led18 {
> > ++  gpios = <&cp0_gpio2 1 GPIO_ACTIVE_LOW>;
> > ++  function = LED_FUNCTION_HEARTBEAT;
> > ++  color = ;
> > ++  linux,default-trigger = "heartbeat";
> > ++  default-state = "on";
> > ++  };
> > ++  };
> > + };
> > +
> > + &cp0_eth0 {
> > +@@ -27,3 +43,10 @@
> > +   managed = "in-band-status";
> > +   sfp = <&sfp_eth1>;
> > + };
> > ++
> > ++&cp0_pinctrl {
> > ++  cp0_led18_pins: led18-pins {
> > ++  marvell,pins = "mpp33";
> > ++  marvell,function = "gpio";
> > ++  };
> > ++};
> > --
> > 2.29.2
> >
> 
> 
> ___
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel


openpgp-digital-signature.asc
Description: PGP signature
___
openwrt-devel mailing l

Re: [PATCH] ltq-dsl-base: only lock the dsl pipe once for all stats

2020-12-04 Thread Andre Heider

On 04/12/2020 13:25, Andre Heider wrote:

Hi,

On 04/12/2020 13:03, Jo-Philipp Wich wrote:

Hi,

is there any reason not to use the flock style below? It should be more
reliable wrt. unlocking if the script is prematurely terminated.


I guess because it gets more difficult to fish out the answer for each 
command then (I didn't check if it's guaranteed to be one line for each)?


But with `trap` I introduced it should be just as reliable I think?

In the end the script is still a mess... The two cleanups I did were 
just the low hanging fruit.


The proper performance fix would be to move 'lucistat' to ltq-vdsl-app 
itself. But there's ltq-adsl-app too, so maybe that's not desired from a 
maintenance point of view.




I misunderstood, that flock style shound indeed work. Updating patch...

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [PATCH] mvebu: macchiatobin-singleshot: enable heartbeat LED

2020-12-04 Thread Alexandra Alth
Is this now approved and integrated in the nightly? tnx alexandra

> Am 25.11.2020 um 17:53 schrieb Tomasz Maciej Nowak :
> 
> With board revision 1.3, SolidRun moved the power LED to the middle of
> the board. In old place of power LED a GPIO controllable heartbeat LED
> was added. This commit touches only Single Shot variant, because all
> have revision 1.3. Some boards could be placed in an enclosure, therefore
> the LED0 is enabled by default, since that'll be the only visible
> indicator that the board is operating.
> 
> Ref: 
> http://wiki.macchiatobin.net/tiki-index.php?page=Schematics#Revision1.3_Electrical_Design_Changes
> Ref: 
> http://macchiatobin.net/wp-content/uploads/2017/11/MACCHIATOBin-rev-1_3.pdf
> 
> Reported-by: Alexandra Alth 
> Signed-off-by: Tomasz Maciej Nowak 
> ---
> target/linux/mvebu/image/cortexa72.mk |  2 +-
> ...s-mcbin-singleshot-add-heartbeat-LED.patch | 59 +++
> 2 files changed, 60 insertions(+), 1 deletion(-)
> create mode 100644 
> target/linux/mvebu/patches-5.4/100-arm64-dts-mcbin-singleshot-add-heartbeat-LED.patch
> 
> diff --git a/target/linux/mvebu/image/cortexa72.mk 
> b/target/linux/mvebu/image/cortexa72.mk
> index 1440c07a0b5f..8bd4581766c2 100644
> --- a/target/linux/mvebu/image/cortexa72.mk
> +++ b/target/linux/mvebu/image/cortexa72.mk
> @@ -38,7 +38,7 @@ define Device/marvell_macchiatobin-singleshot
>   DEVICE_ALT0_VENDOR := SolidRun
>   DEVICE_ALT0_MODEL := Armada 8040 Community Board
>   DEVICE_ALT0_VARIANT := Single Shot
> -  DEVICE_PACKAGES += kmod-i2c-mux-pca954x
> +  DEVICE_PACKAGES += kmod-i2c-mux-pca954x kmod-ledtrig-heartbeat
>   DEVICE_DTS := armada-8040-mcbin-singleshot
>   SUPPORTED_DEVICES := marvell,armada8040-mcbin-singleshot
> endef
> diff --git 
> a/target/linux/mvebu/patches-5.4/100-arm64-dts-mcbin-singleshot-add-heartbeat-LED.patch
>  
> b/target/linux/mvebu/patches-5.4/100-arm64-dts-mcbin-singleshot-add-heartbeat-LED.patch
> new file mode 100644
> index ..a5f37461360b
> --- /dev/null
> +++ 
> b/target/linux/mvebu/patches-5.4/100-arm64-dts-mcbin-singleshot-add-heartbeat-LED.patch
> @@ -0,0 +1,59 @@
> +From 310b7883b64993da355ad5cc3e45f515ac2bef2f Mon Sep 17 00:00:00 2001
> +From: Tomasz Maciej Nowak 
> +Date: Sat, 17 Oct 2020 16:53:20 +0200
> +Subject: [PATCH] arm64: dts: mcbin-singleshot: add heartbeat LED
> +
> +With board revision 1.3, SolidRun moved the power LED to the middle of
> +the board. In old place of power LED a GPIO controllable heartbeat LED
> +was added. This commit only touches Single Shot variant, since only this
> +variant is all revision 1.3.
> +
> +Reported-by: Alexandra Alth 
> +Signed-off-by: Tomasz Maciej Nowak 
> +---
> + .../marvell/armada-8040-mcbin-singleshot.dts  | 22 +++
> + 1 file changed, 22 insertions(+)
> +
> +--- a/arch/arm64/boot/dts/marvell/armada-8040-mcbin-singleshot.dts
>  b/arch/arm64/boot/dts/marvell/armada-8040-mcbin-singleshot.dts
> +@@ -5,6 +5,8 @@
> +  * Device Tree file for MACCHIATOBin Armada 8040 community board platform
> +  */
> + 
> ++#include 
> ++
> + #include "armada-8040-mcbin.dtsi"
> + 
> + / {
> +@@ -12,6 +14,20 @@
> + compatible = "marvell,armada8040-mcbin-singleshot",
> + "marvell,armada8040-mcbin", "marvell,armada8040",
> + "marvell,armada-ap806-quad", "marvell,armada-ap806";
> ++
> ++leds {
> ++compatible = "gpio-leds";
> ++pinctrl-0 = <&cp0_led18_pins>;
> ++pinctrl-names = "default";
> ++
> ++led18 {
> ++gpios = <&cp0_gpio2 1 GPIO_ACTIVE_LOW>;
> ++function = LED_FUNCTION_HEARTBEAT;
> ++color = ;
> ++linux,default-trigger = "heartbeat";
> ++default-state = "on";
> ++};
> ++};
> + };
> + 
> + &cp0_eth0 {
> +@@ -27,3 +43,10 @@
> + managed = "in-band-status";
> + sfp = <&sfp_eth1>;
> + };
> ++
> ++&cp0_pinctrl {
> ++cp0_led18_pins: led18-pins {
> ++marvell,pins = "mpp33";
> ++marvell,function = "gpio";
> ++};
> ++};
> -- 
> 2.29.2
> 


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: odhcp6c RENEW timeout issue leads to OOM/OOPS [Was: Re: QEMU x86/64 ubus issues ... ]

2020-12-04 Thread Hans Dedecker
On Fri, Dec 4, 2020 at 11:45 AM Petr Štetiar  wrote:
>
> Hans Dedecker  [2020-12-03 21:18:11]:
>
> Hi,
>
> > Looking into the new pcap capture I must admit I've never seen such a DHCPv6
> > server with such weird behavior.
>
> it's OpenWrt so odhcpd.
Could you run odhcpd with loglevel 7 as I would like to understand
what triggers the numerous transmission of the Reconfigure messages

Thx
Hans
>
> -- ynezz

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [PATCH] ltq-dsl-base: only lock the dsl pipe once for all stats

2020-12-04 Thread Andre Heider

Hi,

On 04/12/2020 13:03, Jo-Philipp Wich wrote:

Hi,

is there any reason not to use the flock style below? It should be more
reliable wrt. unlocking if the script is prematurely terminated.


I guess because it gets more difficult to fish out the answer for each 
command then (I didn't check if it's guaranteed to be one line for each)?


But with `trap` I introduced it should be just as reliable I think?

In the end the script is still a mess... The two cleanups I did were 
just the low hanging fruit.


The proper performance fix would be to move 'lucistat' to ltq-vdsl-app 
itself. But there's ltq-adsl-app too, so maybe that's not desired from a 
maintenance point of view.


Thanks,
Andre



-- 8< --
   {
   flock -x 1000

   command
   command
   command
   ...
   } 1000>/var/lock/dsl_pipe
-- >8 --


See also the fourth example at
https://man7.org/linux/man-pages/man1/flock.1.html#EXAMPLES

~ Jo


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel




___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [PATCH] ltq-dsl-base: only lock the dsl pipe once for all stats

2020-12-04 Thread Florian Eckert

Hi


is there any reason not to use the flock style below? It should be more
reliable wrt. unlocking if the script is prematurely terminated.

-- 8< --
  {
  flock -x 1000

  command
  command
  command
  ...
  } 1000>/var/lock/dsl_pipe
-- >8 --


We could also use the procd_lock function [1].
As I already use in mwan3 [2].

Florian

[1] https://github.com/openwrt/openwrt/search?q=procd_lock
[2] https://github.com/openwrt/packages/search?q=procd_lock

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: [PATCH] ltq-dsl-base: only lock the dsl pipe once for all stats

2020-12-04 Thread Jo-Philipp Wich
Hi,

is there any reason not to use the flock style below? It should be more
reliable wrt. unlocking if the script is prematurely terminated.

-- 8< --
  {
  flock -x 1000

  command
  command
  command
  ...
  } 1000>/var/lock/dsl_pipe
-- >8 --


See also the fourth example at
https://man7.org/linux/man-pages/man1/flock.1.html#EXAMPLES

~ Jo



signature.asc
Description: OpenPGP digital signature
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


[PATCH v2] ltq-dsl-base: only lock the dsl pipe once for all stats

2020-12-04 Thread Andre Heider
Instead of locking/unlocking it for every command.

Reduces the runtime for the dslstat/lucistat commands to ~66%.

Before:
real0m 2.66s
user0m 0.90s
sys 0m 1.76s

After:
real0m 1.76s
user0m 0.63s
sys 0m 1.13s

Signed-off-by: Andre Heider 
---
v2: bump PKG_RELEASE

 package/network/utils/ltq-dsl-base/Makefile   |  2 +-
 .../files/lib/functions/lantiq_dsl.sh | 21 +--
 2 files changed, 16 insertions(+), 7 deletions(-)

diff --git a/package/network/utils/ltq-dsl-base/Makefile 
b/package/network/utils/ltq-dsl-base/Makefile
index e2cfc4004c..aae07bc299 100644
--- a/package/network/utils/ltq-dsl-base/Makefile
+++ b/package/network/utils/ltq-dsl-base/Makefile
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ltq-dsl-base
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git 
a/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh 
b/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
index 39011f134f..89dc5c25c9 100755
--- a/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
+++ b/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
@@ -7,16 +7,24 @@ else
XDSL_CTRL=dsl_cpe_control
 fi
 
+DSL_PIPE_LOCKED=0
+
 #
 # Basic functions to send CLI commands to the vdsl_cpe_control daemon
 #
+dsl_init() {
+   killall -q -0 ${XDSL_CTRL} && lock /var/lock/dsl_pipe && 
DSL_PIPE_LOCKED=1
+   trap dsl_deinit EXIT INT KILL TERM
+}
+dsl_deinit() {
+   test $DSL_PIPE_LOCKED -gt 0 && lock -u /var/lock/dsl_pipe && 
DSL_PIPE_LOCKED=0
+   exit
+}
 dsl_cmd() {
-   killall -q -0 ${XDSL_CTRL} && (
-   lock /var/lock/dsl_pipe
-   echo "$@" > /tmp/pipe/dsl_cpe0_cmd
-   cat /tmp/pipe/dsl_cpe0_ack
-   lock -u /var/lock/dsl_pipe
-   )
+   test $DSL_PIPE_LOCKED -eq 0 && return
+
+   echo "$@" > /tmp/pipe/dsl_cpe0_cmd
+   cat /tmp/pipe/dsl_cpe0_ack
 }
 dsl_val() {
expr "$1" : '.*'$2'=\([-\.[:alnum:]]*\).*'
@@ -783,6 +791,7 @@ line_features() {
 }
 
 dslstat() {
+   dsl_init
vendor
chipset
xtse
-- 
2.29.2


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


RE: [PATCH] ltq-dsl-base: only lock the dsl pipe once for all stats

2020-12-04 Thread Adrian Schmutzler
Hi,

> -Original Message-
> From: openwrt-devel [mailto:openwrt-devel-boun...@lists.openwrt.org]
> On Behalf Of Andre Heider
> Sent: Freitag, 4. Dezember 2020 08:44
> To: openwrt-devel@lists.openwrt.org
> Subject: [PATCH] ltq-dsl-base: only lock the dsl pipe once for all stats
> 
> Instead of locking/unlocking it for every command.

please bump PKG_RELEASE.

Best

Adrian

> 
> Reduces the runtime for the dslstat/lucistat commands to ~66%.
> 
> Before:
> real  0m 2.66s
> user  0m 0.90s
> sys   0m 1.76s
> 
> After:
> real  0m 1.76s
> user  0m 0.63s
> sys   0m 1.13s
> 
> Signed-off-by: Andre Heider 
> ---
>  .../files/lib/functions/lantiq_dsl.sh | 21 +--
>  1 file changed, 15 insertions(+), 6 deletions(-)
> 
> diff --git a/package/network/utils/ltq-dsl-
> base/files/lib/functions/lantiq_dsl.sh b/package/network/utils/ltq-dsl-
> base/files/lib/functions/lantiq_dsl.sh
> index 39011f134f..89dc5c25c9 100755
> --- a/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.sh
> +++ b/package/network/utils/ltq-dsl-base/files/lib/functions/lantiq_dsl.
> +++ sh
> @@ -7,16 +7,24 @@ else
>   XDSL_CTRL=dsl_cpe_control
>  fi
> 
> +DSL_PIPE_LOCKED=0
> +
>  #
>  # Basic functions to send CLI commands to the vdsl_cpe_control daemon  #
> +dsl_init() {
> + killall -q -0 ${XDSL_CTRL} && lock /var/lock/dsl_pipe &&
> DSL_PIPE_LOCKED=1
> + trap dsl_deinit EXIT INT KILL TERM
> +}
> +dsl_deinit() {
> + test $DSL_PIPE_LOCKED -gt 0 && lock -u /var/lock/dsl_pipe &&
> DSL_PIPE_LOCKED=0
> + exit
> +}
>  dsl_cmd() {
> - killall -q -0 ${XDSL_CTRL} && (
> - lock /var/lock/dsl_pipe
> - echo "$@" > /tmp/pipe/dsl_cpe0_cmd
> - cat /tmp/pipe/dsl_cpe0_ack
> - lock -u /var/lock/dsl_pipe
> - )
> + test $DSL_PIPE_LOCKED -eq 0 && return
> +
> + echo "$@" > /tmp/pipe/dsl_cpe0_cmd
> + cat /tmp/pipe/dsl_cpe0_ack
>  }
>  dsl_val() {
>   expr "$1" : '.*'$2'=\([-\.[:alnum:]]*\).*'
> @@ -783,6 +791,7 @@ line_features() {
>  }
> 
>  dslstat() {
> + dsl_init
>   vendor
>   chipset
>   xtse
> --
> 2.29.2
> 
> 
> ___
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel


openpgp-digital-signature.asc
Description: PGP signature
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


Re: odhcp6c RENEW timeout issue leads to OOM/OOPS [Was: Re: QEMU x86/64 ubus issues ... ]

2020-12-04 Thread Petr Štetiar
Hans Dedecker  [2020-12-03 21:18:11]:

Hi,

> Looking into the new pcap capture I must admit I've never seen such a DHCPv6
> server with such weird behavior.

it's OpenWrt so odhcpd.

-- ynezz

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel