Re: [Qt5-feedback] QMetaObjectBuilder in QtDeclarative and QtSystems

2011-10-04 Thread Gábor Lehel
On Tue, Oct 4, 2011 at 2:58 AM,  alex.blas...@nokia.com wrote:


-Original Message-
From: qt5-feedback-bounces+alex.blasche=nokia@qt.nokia.com
[mailto:qt5-feedback-bounces+alex.blasche=nokia@qt.nokia.com] On
Behalf Of Knoll Lars (Nokia-MP-Qt/Oslo)

The reason why i don't like those is that it is really exposing a lot of
the
internals, and that using them is complicated.
A better alternative would be to have public API to do the things that we
want. That is, something like
QObject::addDynamicSignal(...)  QObject::addDynamicSlot() ... (and a
dynamicslotevent), or whatever that api is used for.

Now, if these classes stay private anyway, i don't object. (because
reducing
code duplication is a good thing)

I would also prefer to keep it private to start with :)

But yes, let's reduce the code duplication and rather have one well tested
version.

 I believe Lorn just forgot to mention this  tiny little detail Yes, it's 
 only going to be a private export.

If this is what I think it is and what it looks like it is, I wouldn't
be surprised if it were reimplemented a few times again in various
language bindings. (I would be a lot more surprised if it weren't).
Having it publicly available might be useful.


 --
 Alex
 ___
 Qt5-feedback mailing list
 Qt5-feedback@qt.nokia.com
 http://lists.qt.nokia.com/mailman/listinfo/qt5-feedback




-- 
Work is punishment for failing to procrastinate effectively.
___
Qt5-feedback mailing list
Qt5-feedback@qt.nokia.com
http://lists.qt.nokia.com/mailman/listinfo/qt5-feedback


[Qt5-feedback] QMetaObjectBuilder in QtDeclarative and QtSystems

2011-10-03 Thread Lorn Potter
Hi,

Currently, there are 3 instances of QMetaObjectBuilder, in QtDeclarative, 
QtSystems 
(serviceframework) and QtSystems (publish and subscribe). There are only 
trivial changes between 
these existing versions of QMetaObjectBuilder private class.



Any objections if I add a QMetaObjectBuilder to qtbase in qtcorelib, so to 
remove code duplication, 
(and I can use it as well)?
I will use the code from QtDeclarative module.


The respective owners of those modules/code should then probably remove their 
versions and convert 
their code to using the one in QtBase.


comments?

-- 
Lorn 'ljp' Potter
Software Engineer, Nokia, Qt R  D

___
Qt5-feedback mailing list
Qt5-feedback@qt.nokia.com
http://lists.qt.nokia.com/mailman/listinfo/qt5-feedback


Re: [Qt5-feedback] QMetaObjectBuilder in QtDeclarative and QtSystems

2011-10-03 Thread Thiago Macieira
On Monday, 3 de October de 2011 16:25:45 Lorn Potter wrote:
 Hi,
 
 Currently, there are 3 instances of QMetaObjectBuilder, in QtDeclarative,
 QtSystems (serviceframework) and QtSystems (publish and subscribe). There
 are only trivial changes between these existing versions of
 QMetaObjectBuilder private class.

Don't forget QDBusMetaObjectWriter and the original meta object creator in 
ActiveQt.

 Any objections if I add a QMetaObjectBuilder to qtbase in qtcorelib, so to
 remove code duplication, (and I can use it as well)?
 I will use the code from QtDeclarative module.
 
 The respective owners of those modules/code should then probably remove
 their versions and convert their code to using the one in QtBase.
 
 comments?

Good idea.

I just hope that a generic solution with the new code isn't performing much 
worse than the specific solutions the older codebases had.

-- 
Thiago Macieira - thiago (AT) macieira.info - thiago (AT) kde.org
   Software Architect - Intel Open Source Technology Center
  PGP/GPG: 0x6EF45358; fingerprint:
  E067 918B B660 DBD1 105C  966C 33F5 F005 6EF4 5358


signature.asc
Description: This is a digitally signed message part.
___
Qt5-feedback mailing list
Qt5-feedback@qt.nokia.com
http://lists.qt.nokia.com/mailman/listinfo/qt5-feedback


Re: [Qt5-feedback] QMetaObjectBuilder in QtDeclarative and QtSystems

2011-10-03 Thread Olivier Goffart
On Monday 03 October 2011 16:25:45 Lorn Potter wrote:
 Hi,
 
 Currently, there are 3 instances of QMetaObjectBuilder, in QtDeclarative,
 QtSystems (serviceframework) and QtSystems (publish and subscribe). There
 are only trivial changes between these existing versions of
 QMetaObjectBuilder private class.
 
 Any objections if I add a QMetaObjectBuilder to qtbase in qtcorelib, so to
 remove code duplication, (and I can use it as well)?
 I will use the code from QtDeclarative module.
 
 The respective owners of those modules/code should then probably remove
 their versions and convert their code to using the one in QtBase.
 

The reason why i don't like those is that it is really exposing a lot of the 
internals, and that using them is complicated.
A better alternative would be to have public API to do the things that we 
want. That is, something like
QObject::addDynamicSignal(...)  QObject::addDynamicSlot() ... (and a 
dynamicslotevent), or whatever that api is used for.

Now, if these classes stay private anyway, i don't object. (because reducing 
code duplication is a good thing)

___
Qt5-feedback mailing list
Qt5-feedback@qt.nokia.com
http://lists.qt.nokia.com/mailman/listinfo/qt5-feedback


Re: [Qt5-feedback] QMetaObjectBuilder in QtDeclarative and QtSystems

2011-10-03 Thread lars.knoll
On 10/3/11 5:29 PM, ext Olivier Goffart oliv...@woboq.com wrote:

On Monday 03 October 2011 16:25:45 Lorn Potter wrote:
 Hi,
 
 Currently, there are 3 instances of QMetaObjectBuilder, in
QtDeclarative,
 QtSystems (serviceframework) and QtSystems (publish and subscribe).
There
 are only trivial changes between these existing versions of
 QMetaObjectBuilder private class.
 
 Any objections if I add a QMetaObjectBuilder to qtbase in qtcorelib, so
to
 remove code duplication, (and I can use it as well)?
 I will use the code from QtDeclarative module.
 
 The respective owners of those modules/code should then probably remove
 their versions and convert their code to using the one in QtBase.
 

The reason why i don't like those is that it is really exposing a lot of
the 
internals, and that using them is complicated.
A better alternative would be to have public API to do the things that we
want. That is, something like
QObject::addDynamicSignal(...)  QObject::addDynamicSlot() ... (and a
dynamicslotevent), or whatever that api is used for.

Now, if these classes stay private anyway, i don't object. (because
reducing 
code duplication is a good thing)

I would also prefer to keep it private to start with :)

But yes, let's reduce the code duplication and rather have one well tested
version.

Cheers,
Lars


___
Qt5-feedback mailing list
Qt5-feedback@qt.nokia.com
http://lists.qt.nokia.com/mailman/listinfo/qt5-feedback

___
Qt5-feedback mailing list
Qt5-feedback@qt.nokia.com
http://lists.qt.nokia.com/mailman/listinfo/qt5-feedback