Change in vdsm[master]: storage: Rename storageConstants.py to constants.py

2015-12-17 Thread nsoffer
Nir Soffer has posted comments on this change.

Change subject: storage: Rename storageConstants.py to constants.py
..


Patch Set 2:

Adam, did you test this code with your new patches? Is it ready for merge?

-- 
To view, visit https://gerrit.ovirt.org/50633
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Gerrit-PatchSet: 2
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke 
Gerrit-Reviewer: Adam Litke 
Gerrit-Reviewer: Ala Hino 
Gerrit-Reviewer: Allon Mureinik 
Gerrit-Reviewer: Amit Aviram 
Gerrit-Reviewer: Daniel Erez 
Gerrit-Reviewer: Freddy Rolland 
Gerrit-Reviewer: Greg Padgett 
Gerrit-Reviewer: Idan Shaby 
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot 
Gerrit-Reviewer: Maor Lipchuk 
Gerrit-Reviewer: Nir Soffer 
Gerrit-Reviewer: Tal Nisan 
Gerrit-Reviewer: Vered Volansky 
Gerrit-Reviewer: gerrit-hooks 
Gerrit-HasComments: No
___
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches


Change in vdsm[master]: storage: Rename storageConstants.py to constants.py

2015-12-17 Thread alitke
Adam Litke has posted comments on this change.

Change subject: storage: Rename storageConstants.py to constants.py
..


Patch Set 2: Code-Review+1

-- 
To view, visit https://gerrit.ovirt.org/50633
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Gerrit-PatchSet: 2
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke 
Gerrit-Reviewer: Adam Litke 
Gerrit-Reviewer: Ala Hino 
Gerrit-Reviewer: Allon Mureinik 
Gerrit-Reviewer: Amit Aviram 
Gerrit-Reviewer: Daniel Erez 
Gerrit-Reviewer: Freddy Rolland 
Gerrit-Reviewer: Greg Padgett 
Gerrit-Reviewer: Idan Shaby 
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot 
Gerrit-Reviewer: Maor Lipchuk 
Gerrit-Reviewer: Nir Soffer 
Gerrit-Reviewer: Tal Nisan 
Gerrit-Reviewer: Vered Volansky 
Gerrit-Reviewer: gerrit-hooks 
Gerrit-HasComments: No
___
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches


Change in vdsm[master]: storage: Rename storageConstants.py to constants.py

2015-12-17 Thread alitke
Adam Litke has posted comments on this change.

Change subject: storage: Rename storageConstants.py to constants.py
..


Patch Set 2: Verified+1

Tested by running running a VM and doing a LSM and snapshot merge.

-- 
To view, visit https://gerrit.ovirt.org/50633
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Gerrit-PatchSet: 2
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke 
Gerrit-Reviewer: Adam Litke 
Gerrit-Reviewer: Ala Hino 
Gerrit-Reviewer: Allon Mureinik 
Gerrit-Reviewer: Amit Aviram 
Gerrit-Reviewer: Daniel Erez 
Gerrit-Reviewer: Freddy Rolland 
Gerrit-Reviewer: Greg Padgett 
Gerrit-Reviewer: Idan Shaby 
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot 
Gerrit-Reviewer: Maor Lipchuk 
Gerrit-Reviewer: Nir Soffer 
Gerrit-Reviewer: Tal Nisan 
Gerrit-Reviewer: Vered Volansky 
Gerrit-Reviewer: gerrit-hooks 
Gerrit-HasComments: No
___
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches


Change in vdsm[master]: storage: Rename storageConstants.py to constants.py

2015-12-17 Thread nsoffer
Nir Soffer has submitted this change and it was merged.

Change subject: storage: Rename storageConstants.py to constants.py
..


storage: Rename storageConstants.py to constants.py

The SDM work is beginning an effort to reorganize storage constants.
Currently constants are peppered throughout the various storage modules.
Getting access to these constants introduces complex module
interdependencies which can lead to circular import dependencies.

In this first step, rename storageConstants.py to constants.py and make
necessary adjustments to the code which currently imports this module.
The new name is shorter and does not have the redundant 'storage' as
part of its name.  Future patches will move constants into this module.

To prevent clashes with vdsm.constants, we always import storage
constants like this:

from storage.constants import FOO_BAR

Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Signed-off-by: Adam Litke 
Reviewed-on: https://gerrit.ovirt.org/50633
Reviewed-by: Nir Soffer 
Continuous-Integration: Jenkins CI
---
M debian/vdsm.install
M vdsm.spec.in
M vdsm/storage/Makefile.am
R vdsm/storage/constants.py
M vdsm/storage/hsm.py
M vdsm/storage/misc.py
M vdsm/storage/sp.py
7 files changed, 10 insertions(+), 7 deletions(-)

Approvals:
  Adam Litke: Verified; Looks good to me, but someone else must approve
  Nir Soffer: Looks good to me, approved
  Jenkins CI: Passed CI tests



-- 
To view, visit https://gerrit.ovirt.org/50633
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Gerrit-PatchSet: 3
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke 
Gerrit-Reviewer: Adam Litke 
Gerrit-Reviewer: Ala Hino 
Gerrit-Reviewer: Allon Mureinik 
Gerrit-Reviewer: Amit Aviram 
Gerrit-Reviewer: Daniel Erez 
Gerrit-Reviewer: Freddy Rolland 
Gerrit-Reviewer: Greg Padgett 
Gerrit-Reviewer: Idan Shaby 
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot 
Gerrit-Reviewer: Maor Lipchuk 
Gerrit-Reviewer: Nir Soffer 
Gerrit-Reviewer: Tal Nisan 
Gerrit-Reviewer: Vered Volansky 
Gerrit-Reviewer: gerrit-hooks 
___
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches


Change in vdsm[master]: storage: Rename storageConstants.py to constants.py

2015-12-17 Thread automation
gerrit-hooks has posted comments on this change.

Change subject: storage: Rename storageConstants.py to constants.py
..


Patch Set 3:

* Update tracker: IGNORE, no Bug-Url found
* Set MODIFIED::IGNORE, no Bug-Url found.

-- 
To view, visit https://gerrit.ovirt.org/50633
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Gerrit-PatchSet: 3
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke 
Gerrit-Reviewer: Adam Litke 
Gerrit-Reviewer: Ala Hino 
Gerrit-Reviewer: Allon Mureinik 
Gerrit-Reviewer: Amit Aviram 
Gerrit-Reviewer: Daniel Erez 
Gerrit-Reviewer: Freddy Rolland 
Gerrit-Reviewer: Greg Padgett 
Gerrit-Reviewer: Idan Shaby 
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot 
Gerrit-Reviewer: Maor Lipchuk 
Gerrit-Reviewer: Nir Soffer 
Gerrit-Reviewer: Tal Nisan 
Gerrit-Reviewer: Vered Volansky 
Gerrit-Reviewer: gerrit-hooks 
Gerrit-HasComments: No
___
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches


Change in vdsm[master]: storage: Rename storageConstants.py to constants.py

2015-12-16 Thread automation
gerrit-hooks has posted comments on this change.

Change subject: storage: Rename storageConstants.py to constants.py
..


Patch Set 2:

* Update tracker: IGNORE, no Bug-Url found
* Check Bug-Url::WARN, no bug url found, make sure header matches 'Bug-Url: ' 
and is a valid url.
* Check merged to previous::IGNORE, Not in stable branch (['ovirt-3.6', 
'ovirt-3.5', 'ovirt-3.4', 'ovirt-3.3'])

-- 
To view, visit https://gerrit.ovirt.org/50633
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Gerrit-PatchSet: 2
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke 
Gerrit-Reviewer: Ala Hino 
Gerrit-Reviewer: Allon Mureinik 
Gerrit-Reviewer: Amit Aviram 
Gerrit-Reviewer: Daniel Erez 
Gerrit-Reviewer: Freddy Rolland 
Gerrit-Reviewer: Greg Padgett 
Gerrit-Reviewer: Idan Shaby 
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot 
Gerrit-Reviewer: Maor Lipchuk 
Gerrit-Reviewer: Nir Soffer 
Gerrit-Reviewer: Tal Nisan 
Gerrit-Reviewer: Vered Volansky 
Gerrit-Reviewer: gerrit-hooks 
Gerrit-HasComments: No
___
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches


Change in vdsm[master]: storage: Rename storageConstants.py to constants.py

2015-12-16 Thread alitke
Adam Litke has uploaded a new change for review.

Change subject: storage: Rename storageConstants.py to constants.py
..

storage: Rename storageConstants.py to constants.py

The SDM work is beginning an effort to reorganize storage constants.
Currently constants are peppered throughout the various storage modules.
Getting access to these constants introduces complex module
interdependencies which can lead to circular import dependencies.

In this first step, rename storageConstants.py to constants.py and make
necessary adjustments to the code which currently imports this module.
The new name is shorter and does not have the redundant 'storage' as
part of its name.  Future patches will move constants into this module.

Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Signed-off-by: Adam Litke 
---
M debian/vdsm.install
M vdsm.spec.in
M vdsm/storage/Makefile.am
R vdsm/storage/constants.py
M vdsm/storage/hsm.py
M vdsm/storage/misc.py
M vdsm/storage/sp.py
7 files changed, 7 insertions(+), 7 deletions(-)


  git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/33/50633/1

diff --git a/debian/vdsm.install b/debian/vdsm.install
index 8495a4c..efa6045 100644
--- a/debian/vdsm.install
+++ b/debian/vdsm.install
@@ -83,6 +83,7 @@
 ./usr/share/vdsm/storage/blockSD.py
 ./usr/share/vdsm/storage/blockVolume.py
 ./usr/share/vdsm/storage/clusterlock.py
+./usr/share/vdsm/storage/constants.py
 ./usr/share/vdsm/storage/curlImgWrap.py
 ./usr/share/vdsm/storage/devicemapper.py
 ./usr/share/vdsm/storage/dispatcher.py
@@ -118,7 +119,6 @@
 ./usr/share/vdsm/storage/securable.py
 ./usr/share/vdsm/storage/sp.py
 ./usr/share/vdsm/storage/spbackends.py
-./usr/share/vdsm/storage/storageConstants.py
 ./usr/share/vdsm/storage/storageServer.py
 ./usr/share/vdsm/storage/storage_exception.py
 ./usr/share/vdsm/storage/storage_mailbox.py
diff --git a/vdsm.spec.in b/vdsm.spec.in
index d7b6ae8..4ca7827 100644
--- a/vdsm.spec.in
+++ b/vdsm.spec.in
@@ -899,6 +899,7 @@
 %{_datadir}/%{vdsm_name}/storage/__init__.py*
 %{_datadir}/%{vdsm_name}/storage/blockSD.py*
 %{_datadir}/%{vdsm_name}/storage/blockVolume.py*
+%{_datadir}/%{vdsm_name}/storage/constants.py*
 %{_datadir}/%{vdsm_name}/storage/curlImgWrap.py*
 %{_datadir}/%{vdsm_name}/storage/devicemapper.py*
 %{_datadir}/%{vdsm_name}/storage/dispatcher.py*
@@ -933,7 +934,6 @@
 %{_datadir}/%{vdsm_name}/storage/securable.py*
 %{_datadir}/%{vdsm_name}/storage/sp.py*
 %{_datadir}/%{vdsm_name}/storage/spbackends.py*
-%{_datadir}/%{vdsm_name}/storage/storageConstants.py*
 %{_datadir}/%{vdsm_name}/storage/storage_exception.py*
 %{_datadir}/%{vdsm_name}/storage/storage_mailbox.py*
 %{_datadir}/%{vdsm_name}/storage/storageServer.py*
diff --git a/vdsm/storage/Makefile.am b/vdsm/storage/Makefile.am
index e183e80..9ed7e61 100644
--- a/vdsm/storage/Makefile.am
+++ b/vdsm/storage/Makefile.am
@@ -28,6 +28,7 @@
blockSD.py \
blockVolume.py \
clusterlock.py \
+   constants.py \
curlImgWrap.py \
devicemapper.py \
dispatcher.py \
@@ -60,7 +61,6 @@
securable.py \
sp.py \
spbackends.py \
-   storageConstants.py \
storage_exception.py \
storage_mailbox.py \
 storageServer.py \
diff --git a/vdsm/storage/storageConstants.py b/vdsm/storage/constants.py
similarity index 100%
rename from vdsm/storage/storageConstants.py
rename to vdsm/storage/constants.py
diff --git a/vdsm/storage/hsm.py b/vdsm/storage/hsm.py
index 33be84b..2397d27 100644
--- a/vdsm/storage/hsm.py
+++ b/vdsm/storage/hsm.py
@@ -63,8 +63,8 @@
 import storage_exception as se
 from threadLocal import vars
 from vdsm import constants
-from storageConstants import STORAGE
-from storageConstants import SECTOR_SIZE
+from constants import STORAGE
+from constants import SECTOR_SIZE
 import resourceManager as rm
 from resourceFactories import IMAGE_NAMESPACE
 import devicemapper
diff --git a/vdsm/storage/misc.py b/vdsm/storage/misc.py
index c40b676..8fcffcd 100644
--- a/vdsm/storage/misc.py
+++ b/vdsm/storage/misc.py
@@ -49,7 +49,7 @@
 from vdsm import concurrent
 from vdsm import constants
 from vdsm import utils
-from storageConstants import SECTOR_SIZE
+from constants import SECTOR_SIZE
 import storage_exception as se
 import logUtils
 
diff --git a/vdsm/storage/sp.py b/vdsm/storage/sp.py
index 311eb5f..45cd85e 100644
--- a/vdsm/storage/sp.py
+++ b/vdsm/storage/sp.py
@@ -47,7 +47,7 @@
 from securable import secured, unsecured
 import image
 from resourceFactories import IMAGE_NAMESPACE
-from storageConstants import STORAGE
+from constants import STORAGE
 import resourceManager as rm
 import volume
 import mount


-- 
To view, visit https://gerrit.ovirt.org/50633
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master

Change in vdsm[master]: storage: Rename storageConstants.py to constants.py

2015-12-16 Thread automation
gerrit-hooks has posted comments on this change.

Change subject: storage: Rename storageConstants.py to constants.py
..


Patch Set 1:

* Update tracker: IGNORE, no Bug-Url found
* Check Bug-Url::WARN, no bug url found, make sure header matches 'Bug-Url: ' 
and is a valid url.
* Check merged to previous::IGNORE, Not in stable branch (['ovirt-3.6', 
'ovirt-3.5', 'ovirt-3.4', 'ovirt-3.3'])

-- 
To view, visit https://gerrit.ovirt.org/50633
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke 
Gerrit-Reviewer: gerrit-hooks 
Gerrit-HasComments: No
___
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches


Change in vdsm[master]: storage: Rename storageConstants.py to constants.py

2015-12-16 Thread nsoffer
Nir Soffer has posted comments on this change.

Change subject: storage: Rename storageConstants.py to constants.py
..


Patch Set 2: Code-Review+2

This version make the storage.constants import more clear, as in all modules 
using it, we also import vdsm.constants, and we have  lot of these imports.

-- 
To view, visit https://gerrit.ovirt.org/50633
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I74684fdf63fb08573dc2068dcfb32ba5febac82b
Gerrit-PatchSet: 2
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke 
Gerrit-Reviewer: Ala Hino 
Gerrit-Reviewer: Allon Mureinik 
Gerrit-Reviewer: Amit Aviram 
Gerrit-Reviewer: Daniel Erez 
Gerrit-Reviewer: Freddy Rolland 
Gerrit-Reviewer: Greg Padgett 
Gerrit-Reviewer: Idan Shaby 
Gerrit-Reviewer: Jenkins CI
Gerrit-Reviewer: Liron Aravot 
Gerrit-Reviewer: Maor Lipchuk 
Gerrit-Reviewer: Nir Soffer 
Gerrit-Reviewer: Tal Nisan 
Gerrit-Reviewer: Vered Volansky 
Gerrit-Reviewer: gerrit-hooks 
Gerrit-HasComments: No
___
vdsm-patches mailing list
vdsm-patches@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-patches