Re: AlwaysUp Utility to Run 4D Client as a Windows Service

2019-05-08 Thread Justin Leavens via 4D_Tech
You can move a license, I’ve done it. I forget the process but they are always super-helpful. And I do have one instance where I’m using it with 4D client. http://www.linkedin.com/in/justinleavens On May 7, 2019, 3:12 PM -0700, Tom Benedict via 4D_Tech <4d_tech@lists.4d.com>, wrote: > I’ve seen

4D View Pro Save Image of Current Sheet ?

2019-05-08 Thread Allan Udy via 4D_Tech
The 4D Tech Tip  (https://kb.4d.com/assetid=78210) showing how to use WA Evaluate JavaScript to save an image of a current 4DViewPro area is handy, but it appears that it only saves the current Viewport, not the whole sheet. Is anyone here capable enough with the use of WA Evaluate JavaScript

Re: Printing structures

2019-05-08 Thread Cannon Smith via 4D_Tech
Hi Alexander, This is great! Thank you for sharing. Just a heads up on a bit of code that won’t work in countries that use a decimal place instead of a comma. In the method xml_atts2ob, lines 50, 54, 58, and 62 convert the decimal point in the height, left, top, and width of the XML values to

Re: Printing structures

2019-05-08 Thread John J Foster via 4D_Tech
Alexander, Very nice. Makes me harkens back to my DataPulse/StructurePulse days. Appreciate, John… > On May 8, 2019, at 9:42 AM, Herr Alexander Heintz via 4D_Tech > <4d_tech@lists.4d.com > wrote: > > Hi folks, > > been a while, i know… > needed something to

Re: Printing structures

2019-05-08 Thread rooftop99--- via 4D_Tech
Very, very cool! Thanks for sharing, Alexander!! > On May 8, 2019, at 9:42 AM, Herr Alexander Heintz via 4D_Tech > <4d_tech@lists.4d.com> wrote: > > Hi folks, > > been a while, i know… > needed something to print structures in a moderately configurable way. > May have gone a bit overboard

RE: AlwaysUp Utility to Run 4D Client as a Windows Service

2019-05-08 Thread Michael McCall via 4D_Tech
We've been using Always up for years successfully. I haven't had trouble when we've needed to move a license from one computer to another. There support has been absolutely fantastic We've bought an OEM pack which provided us even more flexibility. That said we are using it for copies of 4D

Re: Printing structures

2019-05-08 Thread Patrick Emanuel via 4D_Tech
well done! Patrick - Patrick EMANUEL Administrator www.association-qualisoft.eu (Soft1002, Simply Asso & QS_Toolbox) -- Sent from: http://4d.1045681.n5.nabble.com/4D-Tech-f1376241.html

Printing structures

2019-05-08 Thread Herr Alexander Heintz via 4D_Tech
Hi folks, been a while, i know… needed something to print structures in a moderately configurable way. May have gone a bit overboard with the config options… It takes a XML structure dump and can stare presets and parsed structures. Also export to SVG, PNG and JPG Its V17Rx and you will find it

Re: Webarea Embedded rendering engine show blank pages in 64-bit

2019-05-08 Thread Kirk Brooks via 4D_Tech
Piotr, I also generate the webarea content on the fly and never found generating the temp html files an issue speed wise. The processing is exactly the same leaving on the time to write the file to disk. I added a routine to startup to clear out the temp folder. It also gets cleared whenever you

RE: Webarea Embedded rendering engine show blank pages in 64-bit

2019-05-08 Thread Piotr Chabot Stadhouders via 4D_Tech
Hi Kirk, Thanks for your input. We generate html on the fly, with data retrieved by queries on the database I preferably don't want to store these temp html files on disk, ending up with cleaning up a lot of temp pages As said, on 4Dv17R4 32-bit, WA SET PAGE CONTENT works fine with the

Re: Webarea Embedded rendering engine show blank pages in 64-bit

2019-05-08 Thread Kirk Brooks via 4D_Tech
Piotr, I use web areas quite a lot. WA SET PAGE CONTENT is tricky to make work if it's not initialized and generally not on the first page. I create pages on disk instead in a WA folder I setup in Resources. This also gives me a place to store Assets (CSS, JS, etc.) I use in the pages. Writing the

RE: Webarea Embedded rendering engine show blank pages in 64-bit

2019-05-08 Thread Piotr Chabot Stadhouders via 4D_Tech
Hi Pat, I found out that when using WA SET PAGE CONTENT(*;$area_object;$html;"file:///") it doesn't show up, but when saving it to file and assign "file:///"+Document to the URL variable it DOES The docs say: "Note: Under Windows, you cannot call this command unless a page has already been

Re: AlwaysUp Utility to Run 4D Client as a Windows Service

2019-05-08 Thread Paul Dennis via 4D_Tech
I use nssm works without a problem and its open source. https://nssm.cc/ Paul -- Sent from: http://4d.1045681.n5.nabble.com/4D-Tech-f1376241.html ** 4D Internet Users Group (4D iNUG) Archive: http://lists.4d.com/archives.html

Comprehensive example(s) for Write Pro v16

2019-05-08 Thread Jörg Knebel via 4D_Tech
Hi All, Are there comprehensive examples for Write Pro available somewhere? I’m looking for something that brings one up from zero to full speed in no time. Thanks for any and all help. Regards Jörg Knebel, M.Eng. - 4D Developer since 1991 TTT Data Systems Pty Ltd Phone: +61 (0)2 6601 7453