[PATCH 3/5] drm/amdgpu:implement guilty pointer

2017-10-19 Thread Monk Liu
for user context there will be a guilty pointer in entity that points to the guilty member of its context, thus we cant track if a given entity is not from kernel ctx and if it is already marked guilty. Change-Id: Ie0a30830d89f52a6c4a514e67206140698a46367 Signed-off-by: Monk Liu

[PATCH 5/5] drm/amdgpu:skip job for guilty ctx in parser_init

2017-10-19 Thread Monk Liu
Change-Id: I44019f6475b1eaaba55633cf5f8bb84284f19a2c Signed-off-by: Monk Liu --- drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c | 6 ++ 1 file changed, 6 insertions(+) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c index

[PATCH 4/5] drm/amdgpu:cleanup job reset routine

2017-10-19 Thread Monk Liu
merge the setting guilty on context into this function to avoid implement extra routine. Change-Id: I7a0063464fdc85d5ac9080046380e745565ff540 Signed-off-by: Monk Liu --- drivers/gpu/drm/amd/amdgpu/amdgpu_device.c| 4 ++-- drivers/gpu/drm/amd/scheduler/gpu_scheduler.c | 13

[PATCH 2/5] drm/amdgpu:add hang_limit for sched

2017-10-19 Thread Monk Liu
since gpu_scheduler source domain cannot access amdgpu variable so need create the hang_limit membewr for sched, and it can refer it for the upcoming GPU RESET patches Change-Id: I977ae2717e55a8b87c59e58a288bffc3b458b653 Signed-off-by: Monk Liu ---

[PATCH 1/5] drm/amdgpu:cleanup force_completion

2017-10-19 Thread Monk Liu
cleanups, now only operate on the given ring Change-Id: I42ee081696ac348660d38be68807f34090ffcce2 Signed-off-by: Monk Liu --- drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 6 +++--- drivers/gpu/drm/amd/amdgpu/amdgpu_fence.c | 29 +++--

RE: [PATCH 1/3] drm/amdgpu/sriov:now must reinit psp

2017-10-19 Thread Deucher, Alexander
I followed up on all of these. Alex From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf Of Liu, Monk Sent: Thursday, October 19, 2017 10:50 PM To: amd-gfx@lists.freedesktop.org Subject: RE: [PATCH 1/3] drm/amdgpu/sriov:now must reinit psp If no one review I’ll submit it soon

RE: [PATCH 2/3] drm/amdgpu:fix vf_error_put

2017-10-19 Thread Deucher, Alexander
> -Original Message- > From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf > Of Liu, Monk > Sent: Thursday, October 19, 2017 10:51 PM > To: Alex Deucher > Cc: amd-gfx list > Subject: RE: [PATCH 2/3] drm/amdgpu:fix vf_error_put > > ”amdgpu_vf_error_put“ now is already

RE: [PATCH 2/3] drm/amdgpu:fix vf_error_put

2017-10-19 Thread Liu, Monk
”amdgpu_vf_error_put“ now is already changed to protected by SRIOV_VF(), so the whole logic is okay -Original Message- From: Alex Deucher [mailto:alexdeuc...@gmail.com] Sent: 2017年10月19日 10:58 To: Liu, Monk Cc: amd-gfx list Subject:

RE: [PATCH 1/3] drm/amdgpu/sriov:now must reinit psp

2017-10-19 Thread Liu, Monk
If no one review I’ll submit it soon From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf Of Liu, Monk Sent: 2017年10月18日 18:11 To: amd-gfx@lists.freedesktop.org; Deucher, Alexander ; Koenig, Christian Subject: Re: [PATCH

Re: [PATCH] amdgpu: add padding to the fence to handle ioctl.

2017-10-19 Thread Alex Deucher
On Thu, Oct 19, 2017 at 8:52 PM, Dave Airlie wrote: > From: Dave Airlie > > I don't think this ioctl is in a Linus release yet. > > Signed-off-by: Dave Airlie Reviewed-by: Alex Deucher > --- >

[PATCH] amdgpu: add padding to the fence to handle ioctl.

2017-10-19 Thread Dave Airlie
From: Dave Airlie I don't think this ioctl is in a Linus release yet. Signed-off-by: Dave Airlie --- include/uapi/drm/amdgpu_drm.h | 1 + 1 file changed, 1 insertion(+) diff --git a/include/uapi/drm/amdgpu_drm.h b/include/uapi/drm/amdgpu_drm.h index

[PATCH 1/2] drm/amd/powerplay: add one smc message for Vega10

2017-10-19 Thread Eric Huang
This is used to fix performance drop caused by updated SMU FW. Signed-off-by: Eric Huang --- drivers/gpu/drm/amd/powerplay/inc/vega10_ppsmc.h | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/powerplay/inc/vega10_ppsmc.h

[PATCH 0/2] Some changes to fix performance drop on Vega10

2017-10-19 Thread Eric Huang
Eric Huang (2): drm/amd/powerplay: add one smc message for Vega10 drm/amd/powerplay: fix performance drop on Vega10 drivers/gpu/drm/amd/powerplay/hwmgr/vega10_hwmgr.c | 6 ++ drivers/gpu/drm/amd/powerplay/inc/vega10_ppsmc.h | 3 ++- 2 files changed, 8 insertions(+), 1 deletion(-) --

Re: [PATCH] drm/amdkfd: Make queue mapping interfaces more consistent

2017-10-19 Thread Felix Kuehling
On 2017-10-19 03:00 AM, Oded Gabbay wrote: > On Wed, Oct 18, 2017 at 4:47 PM, Kuehling, Felix > wrote: >>> Thanks Felix. >>> I'll add it to the next tree instead of the one from the patch-set. >>> >>> Oded >> I based this patch on your current amdkfd-next. Do you have

RE: [PATCH xf86-video-amdgpu 4/4] Always call drmModeFreeProperty after drmModeGetProperty

2017-10-19 Thread Deucher, Alexander
> -Original Message- > From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf > Of Michel Dänzer > Sent: Thursday, October 19, 2017 12:06 PM > To: amd-gfx@lists.freedesktop.org > Subject: [PATCH xf86-video-amdgpu 4/4] Always call drmModeFreeProperty > after

Re: [PATCH 11/28] drm/amd/display: Unify DRM state variable namings.

2017-10-19 Thread Tom St Denis
This fails to apply to drm-next even with 3-way merge enabled. error: sha1 information is lacking or useless (drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c). error: could not build fake ancestor Patch failed at 0011 drm/amd/display: Unify DRM state variable namings. Tom On 19/10/17 01:46

[PATCH] drm/amdgpu: Sync KFD fence only for move/evict

2017-10-19 Thread Harish Kasiviswanathan
A single KFD eviction fence is attached to all the BOs of a process including BOs imported. This fence ensures that all BOs belonging to that process stays resident when the process queues are active. Don't add this eviction fence to any sync object unless it is a move or evict job. These jobs

[PATCH 27/28] drm/amd/display: DMCU FW loading from PSP

2017-10-19 Thread Harry Wentland
From: Anthony Koo Update the programming sequence to allow DMCU firmware to be loaded by PSP. This code detects whether the firmware is loaded and does a check to verify the expected interface version and checks for correct response from micro controller. Added registry key

[PATCH 20/28] drm/amd/display: Fix no display on Fiji

2017-10-19 Thread Harry Wentland
From: Jerry Zuo Allocate memory for the second pipe allocate_mem_input() needs to be done prior to program pipe front end. It shows sensitive to Fiji. Failure to do so will cause error in allocate memory  allocate_mem_input() on the second connected display. Signed-off-by:

[PATCH 25/28] drm/amd/display: Should disable when new stream is null

2017-10-19 Thread Harry Wentland
From: "Leo (Sunpeng) Li" core_link_disable_stream should be called when the new stream is null (i.e. want to disable). Modify the if condition to reflect that. Signed-off-by: Leo (Sunpeng) Li Reviewed-by: Harry Wentland ---

[PATCH 07/28] drm/amd/display: Atomic freesync ASSERT fix

2017-10-19 Thread Harry Wentland
From: Bhawanpreet Lakha Changes to atomic set property for freesync. Now In set property, just set the freesync variables and return 0. Based on the variables call mod_freesync_set_user_enable() inside commit_tail Signed-off-by: Bhawanpreet Lakha

[PATCH 23/28] drm/amd/display: cleaning up hubp for dcn

2017-10-19 Thread Harry Wentland
From: Yue Hin Lau removing duplicate functions, renaming struct mi_regs, etc. Signed-off-by: Yue Hin Lau --- drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hubp.c | 16 +- drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hubp.h | 345 +++--

[PATCH 11/28] drm/amd/display: Unify DRM state variable namings.

2017-10-19 Thread Harry Wentland
From: "Leo (Sunpeng) Li" Use new_*_state and old_*_state for their respective new/old DRM object states. Signed-off-by: Leo (Sunpeng) Li Reviewed-by: Tony Cheng Reviewed-by: Harry Wentland ---

[PATCH 08/28] drm/amd/display: Add APU cap in dc_caps

2017-10-19 Thread Harry Wentland
From: Anthony Koo Some features should only be enabled on APUs or should not be enabled on APUs. Signed-off-by: Anthony Koo Reviewed-by: Tony Cheng Acked-by: Harry Wentland ---

[PATCH 28/28] drm/amd/display: Only add stream to freesync when modeset required

2017-10-19 Thread Harry Wentland
From: "Leo (Sunpeng) Li" This is a follow-up patch to: Leo (Sunpeng) LiCleanup code that enables freesync We should only add a stream to freesync if a modeset was requested, so we don't fill the core freesync map with pointless streams. Signed-off-by: Leo (Sunpeng) Li

[PATCH 04/28] amdgpu/dc: drop dml_util_is_420

2017-10-19 Thread Harry Wentland
From: Dave Airlie This is unused code. Signed-off-by: Dave Airlie Reviewed-by: Harry Wentland Signed-off-by: Alex Deucher --- .../gpu/drm/amd/display/dc/dml/dml_common_defs.c | 33

[PATCH 14/28] drm/amd/display: Remove useless pcrtc pointer

2017-10-19 Thread Harry Wentland
From: "Leo (Sunpeng) Li" in amdgpu_dm_atomic_commit_tail. Just use crtc instead. Signed-off-by: Leo (Sunpeng) Li Reviewed-by: Tony Cheng Reviewed-by: Harry Wentland ---

[PATCH 10/28] drm/amd/display: Use new DRM API where possible

2017-10-19 Thread Harry Wentland
From: "Leo (Sunpeng) Li" To conform to DRM's new API, we should not be accessing a DRM object's internal state directly. Rather, the DRM for_each_old/new_* iterators, and drm_atomic_get_old/new_* interface should be used. This is an ongoing process. For now, update the

[PATCH 21/28] drm/amd/display: Cleanup some fail labels in dcn10_resource

2017-10-19 Thread Harry Wentland
Signed-off-by: Harry Wentland Acked-by: Alex Deucher --- .../gpu/drm/amd/display/dc/dcn10/dcn10_resource.c | 37 -- 1 file changed, 13 insertions(+), 24 deletions(-) diff --git

[PATCH 26/28] drm/amd/display: Set cursor position as per address.

2017-10-19 Thread Harry Wentland
From: Yongqiang Sun In case of pipe split, cursor position should also be programmed as per cursor address. Signed-off-by: Yongqiang Sun Reviewed-by: Tony Cheng Acked-by: Harry Wentland ---

[PATCH 22/28] drm/amd/display: Clean some unneeded defines from ddc_service_types.h

2017-10-19 Thread Harry Wentland
Remove defines we no longer need Signed-off-by: Harry Wentland --- .../drm/amd/display/include/ddc_service_types.h| 33 -- 1 file changed, 33 deletions(-) diff --git a/drivers/gpu/drm/amd/display/include/ddc_service_types.h

[PATCH 24/28] drm/amd/display: Explicit casting for grph object ids

2017-10-19 Thread Harry Wentland
C++ compilers don't like the implicit conversion Signed-off-by: Harry Wentland --- drivers/gpu/drm/amd/display/include/grph_object_id.h | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/gpu/drm/amd/display/include/grph_object_id.h

[PATCH 12/28] drm/amd/display: Unify amdgpu_dm state variable namings.

2017-10-19 Thread Harry Wentland
From: "Leo (Sunpeng) Li" Use dm_new_*_state and dm_old_*_state for their respective amdgpu_dm new and old object states. Helps with readability, and enforces use of new DRM api (choose either new, or old). Signed-off-by: Leo (Sunpeng) Li Reviewed-by: Sun

[PATCH 01/28] drm/amd/display: Small comment on dc_commit_planes_to_stream

2017-10-19 Thread Harry Wentland
Having one struct on the stack was somewhat confusing. Also mention that the whole function should eventually go. Signed-off-by: Harry Wentland Reviewed-by: Andrey Grodzovsky --- drivers/gpu/drm/amd/display/dc/core/dc.c | 7 +++ 1 file

[PATCH 05/28] amdgpu/dc: inline dml_round_to_multiple

2017-10-19 Thread Harry Wentland
From: Dave Airlie turns out to be a win to inline this. Signed-off-by: Dave Airlie Reviewed-by: Harry Wentland Signed-off-by: Alex Deucher --- drivers/gpu/drm/amd/display/dc/dml/dml_common_defs.c | 19

[PATCH 16/28] drm/amd/display: Cleanup code that enables freesync

2017-10-19 Thread Harry Wentland
From: "Leo (Sunpeng) Li" This is a follow-up patch to: Bhawanpreet LakhaAtomic freesync ASSERT fix Changes: - Combine to use one iterator - Use new DRM iterators. Signed-off-by: Leo (Sunpeng) Li Reviewed-by: Bhawanpreet Lakha

[PATCH 19/28] drm/amd/display: Adding DCN1 registers

2017-10-19 Thread Harry Wentland
From: Mikita Lipski Registers added to definition list that are required for multi display synchronization Signed-off-by: Mikita Lipski Reviewed-by: Tony Cheng Acked-by: Harry Wentland ---

[PATCH 06/28] drm/amd/display: Add null check for 24BPP (xfm and dpp)

2017-10-19 Thread Harry Wentland
From: Bhawanpreet Lakha Fixes Nullptr error when trying 24BPP Signed-off-by: Bhawanpreet Lakha Reviewed-by: Tony Cheng Acked-by: Harry Wentland ---

[PATCH 17/28] drm/amd/display: Move lock to front end program.

2017-10-19 Thread Harry Wentland
From: Yongqiang Sun Moved lock and unlock to apply_ctx_to_surface, since all the front end programming is within apply_ctx_to_surface. Signed-off-by: Yongqiang Sun Reviewed-by: Tony Cheng Acked-by: Harry Wentland

[PATCH 18/28] drm/amd/display: Check cursor address before program.

2017-10-19 Thread Harry Wentland
From: Yongqiang Sun Program cursor attributes during set mode is only needed in case of pipe slipt, bottom pipe should be programmed same as top pipe. Need to program if address is 0. Signed-off-by: Yongqiang Sun Reviewed-by: Tony Cheng

[PATCH 02/28] amdgpu/dc: inline a bunch of the dml wrappers.

2017-10-19 Thread Harry Wentland
This reduces the code size. This is basically a redo of Dave's change with the same name on top of the latest DML. Signed-off-by: Harry Wentland --- .../gpu/drm/amd/display/dc/dml/display_mode_vba.c | 2 + .../drm/amd/display/dc/dml/display_rq_dlg_calc.c | 2 +

[PATCH 15/28] drm/amd/display: Do not release DC state on S3 resume

2017-10-19 Thread Harry Wentland
From: "Leo (Sunpeng) Li" Because of the following patch: Leo (Sunpeng) LiMove copy_construct from state_alloc to atomic_check We do not allocate the DC state within dm_atomic_state_alloc anymore. Since this function is a part of the S3 resume code path, we should not

[PATCH 00/28] DC Linux Patches Oct 19, 2017

2017-10-19 Thread Harry Wentland
* Fixed hotplug issue (mainly on HDMI, but affected DP as well) * Use new DRM state iterators * Couple of Dave's cleanups rerolled on new DML * Bunch of Raven work Anthony Koo (2): drm/amd/display: Add APU cap in dc_caps drm/amd/display: DMCU FW loading from PSP Bhawanpreet Lakha (2):

[PATCH 13/28] drm/amd/display: Fix typo

2017-10-19 Thread Harry Wentland
From: "Leo (Sunpeng) Li" undersacn -> underscan Signed-off-by: Leo (Sunpeng) Li Reviewed-by: Tony Cheng Reviewed-by: Harry Wentland --- drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 4 ++-- 1 file

[PATCH 09/28] drm/amd/display: Use DRM new-style object iterators.

2017-10-19 Thread Harry Wentland
From: Dave Airlie Use the correct for_each_new/old_* iterators instead of for_each_* The following functions were considered: amdgpu_dm_find_first_crtc_matching_connector: use for_each_new - Old from_state_var flag was always choosing the new state

RE: [PATCH xf86-video-amdgpu 2/2] Bail if there's a problem with ShadowFB

2017-10-19 Thread Deucher, Alexander
> -Original Message- > From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf > Of Michel Dänzer > Sent: Thursday, October 19, 2017 12:03 PM > To: amd-gfx@lists.freedesktop.org > Subject: [PATCH xf86-video-amdgpu 2/2] Bail if there's a problem with > ShadowFB > > From:

[PATCH xf86-video-ati] Unreference pixmap's FB with EXA as well in radeon_set_pixmap_bo

2017-10-19 Thread Michel Dänzer
From: Michel Dänzer Not doing so resulted in DRI2 page flips not actually changing the FB being scanned out, showing intermittent flicker of the "back" buffer rendering. Bugzilla: https://bugs.freedesktop.org/102643 Fixes: 55e513b978b2 "Use reference counting for

[PATCH xf86-video-ati] Clarify when TearFree is automatically enabled.

2017-10-19 Thread Michel Dänzer
From: Darren Salt (Ported from amdgpu commit 2f72be038d22c54620e436af30121dd89f79a003) Signed-off-by: Michel Dänzer --- man/radeon.man | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/man/radeon.man b/man/radeon.man

[PATCH xf86-video-amdgpu 2/4] Free memory returned by xf86GetEntityInfo

2017-10-19 Thread Michel Dänzer
From: Michel Dänzer We were leaking it. Signed-off-by: Michel Dänzer --- src/amdgpu_kms.c | 19 +-- src/amdgpu_probe.c | 6 -- 2 files changed, 17 insertions(+), 8 deletions(-) diff --git a/src/amdgpu_kms.c

[PATCH xf86-video-amdgpu 4/4] Always call drmModeFreeProperty after drmModeGetProperty

2017-10-19 Thread Michel Dänzer
From: Michel Dänzer We were not doing so in all cases, leaking memory allocated by the latter. Signed-off-by: Michel Dänzer --- src/drmmode_display.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/src/drmmode_display.c

[PATCH xf86-video-amdgpu 1/4] Free pAMDGPUEnt memory in AMDGPUFreeRec

2017-10-19 Thread Michel Dänzer
From: Michel Dänzer We were freeing it earlier but then still trying to access it in AMDGPUFreeRec. Signed-off-by: Michel Dänzer --- src/amdgpu_kms.c | 2 ++ src/amdgpu_probe.c | 8 ++-- 2 files changed, 4 insertions(+), 6 deletions(-)

[PATCH xf86-video-amdgpu 3/4] Call TimerFree for timer created in LeaveVT

2017-10-19 Thread Michel Dänzer
From: Michel Dänzer We were leaking the memory allocated by TimerSet. Signed-off-by: Michel Dänzer --- src/amdgpu_kms.c | 1 + 1 file changed, 1 insertion(+) diff --git a/src/amdgpu_kms.c b/src/amdgpu_kms.c index 7d582095b..cb0fb3b57 100644 ---

[PATCH xf86-video-amdgpu 1/2] Fix VT switching with ShadowFB

2017-10-19 Thread Michel Dänzer
From: Michel Dänzer We were trying to call acceleration specific functions from LeaveVT. Instead, memset the scanout buffer to all 0 in LeaveVT and allocate a new one in EnterVT. Bugzilla: https://bugs.freedesktop.org/102948 Fixes: c16ff42f927d ("Make all active CRTCs

[PATCH xf86-video-amdgpu 2/2] Bail if there's a problem with ShadowFB

2017-10-19 Thread Michel Dänzer
From: Michel Dänzer If we hit a problem while setting up ShadowFB, just carrying on trying to set up HW acceleration instead is unlikely to work. (Ported from radeon commit 7d435354099119234d443b07e2df1c7b9f97cf3c) Signed-off-by: Michel Dänzer

RE: [PATCH] drm/amdgpu: always consider virualised device for checking post (v3)

2017-10-19 Thread Deucher, Alexander
> -Original Message- > From: amd-gfx [mailto:amd-gfx-boun...@lists.freedesktop.org] On Behalf > Of Pixel Ding > Sent: Thursday, October 19, 2017 1:43 AM > To: amd-gfx@lists.freedesktop.org; Deucher, Alexander > Cc: Sun, Gary; Ding, Pixel > Subject: [PATCH] drm/amdgpu: always consider

Re: [pull] amdgpu drm-fixes-4.14

2017-10-19 Thread Christian König
Am 18.10.2017 um 18:58 schrieb Deucher, Alexander: -Original Message- From: Michel Dänzer [mailto:mic...@daenzer.net] Sent: Wednesday, October 18, 2017 12:06 PM To: Koenig, Christian; Alex Deucher Cc: Deucher, Alexander; Dave Airlie; amd-gfx list; Maling list - DRI developers Subject:

Re: [PATCH] drm/amdkfd: Make queue mapping interfaces more consistent

2017-10-19 Thread Oded Gabbay
On Wed, Oct 18, 2017 at 4:47 PM, Kuehling, Felix wrote: >> Thanks Felix. >> I'll add it to the next tree instead of the one from the patch-set. >> >> Oded > > I based this patch on your current amdkfd-next. Do you have another "next > tree"? No, that's fine. I simply