Re: [PATCH] unzip: -d should create the dir

2020-04-17 Thread Johannes Schindelin
Hi, On Wed, 15 Apr 2020, Lauri Kasanen wrote: > The official Info-Zip unzip creates the dir if it doesn't exist. This bit me recently, too. However, > Signed-off-by: Lauri Kasanen > --- > archival/unzip.c | 4 +++- > 1 file changed, 3 insertions(+), 1 deletion(-) > > diff --git

Re: [PATCH] xargs: support -a args-file

2017-08-30 Thread Johannes Schindelin
Hi Xabier, On Wed, 30 Aug 2017, Xabier Oneca -- xOneca wrote: > 2017-08-29 21:06 GMT+02:00 Denys Vlasenko <vda.li...@googlemail.com>: > > > > On Fri, Aug 25, 2017 at 10:42 PM, Johannes Schindelin > > <johannes.schinde...@gmx.de> wrote: > >> @

Re: [PATCH 1/1] xargs: support -P (parallel execution)

2017-08-25 Thread Johannes Schindelin
Hi Walter, On Fri, 25 Aug 2017, walter harms wrote: > Am 24.08.2017 13:19, schrieb Denys Vlasenko: > > > +/* > > + * Returns 0 if xargs should continue (but may set G.xargs_exitcode to > > 123). > > + * Else sets G.xargs_exitcode to error code and returns nonzero. > > + * > > + * If G.max_procs

[PATCH 1/1] xargs: support -P (parallel execution)

2017-08-23 Thread Johannes Schindelin
-to solutions for running the test suite in parallel). It so just happens that this patch also addresses the feature requested in https://bugs.busybox.net/show_bug.cgi?id=9511. Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- findutils/xargs.c

[PATCH 0/1] xargs: support spawning processes in parallel

2017-08-23 Thread Johannes Schindelin
and no development tools such as `make` or `prove`. Please give this a good look-over, as I want to make sure that this is correct. It seems to work alright in my tests, yet I would feel more comfortable if I got at least one other developer to agree that the feature is implemented correctly. Johannes

[PATCH 2/2] ash: when cd fails, say why

2017-08-22 Thread Johannes Schindelin
Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- shell/ash.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/shell/ash.c b/shell/ash.c index a67a45376..60bcd1b0a 100644 --- a/shell/ash.c +++ b/shell/ash.c @@ -2748,7 +2748,7 @@ cdcmd(int argc UNUSED

[PATCH 0/2] Use the new ash_msg_and_raise_perror() in more places

2017-08-22 Thread Johannes Schindelin
are useful for other developers, too. Johannes Schindelin (2): ash: report reason when a script file could not be opened ash: when cd fails, say why shell/ash.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) base-commit: 3505e38bd1e5714fa1203e6752c573861aab8521 Published-

[PATCH 1/2] ash: report reason when a script file could not be opened

2017-08-22 Thread Johannes Schindelin
It is always nicer to give the user some sort of indication why an operation failed. Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- shell/ash.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/shell/ash.c b/shell/ash.c index 703802ff5..a67a45376

Re: [PATCH] Silence misguided GCC warning about alignment issues

2017-08-09 Thread Johannes Schindelin
Hi Emmanuel, On Tue, 8 Aug 2017, Emmanuel Deloget wrote: > On Tue, Aug 8, 2017 at 1:19 PM, Johannes Schindelin < > johannes.schinde...@gmx.de> wrote: > > > On Mon, 7 Aug 2017, Emmanuel Deloget wrote: > > > > > And yes, its seems that the get_le32() macro in

[PATCH v2 2/2] hush: implement -d DELIM option for `read`

2017-08-08 Thread Johannes Schindelin
-- (add/remove: 0/0 grow/shrink: 2/0 up/down: 23/0) Total: 23 bytes Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- shell/hush.c | 21 - 1 file changed, 20 insertions(+), 1 deletion(-) diff --git a/shell/hush.c b/shell/hush.c index d4e

Re: [PATCH] ash/hush: implement -d DELIM option for `read`

2017-08-08 Thread Johannes Schindelin
Hi, On Tue, 8 Aug 2017, Kang-Che Sung wrote: > On Mon, Aug 7, 2017 at 6:18 PM, Johannes Schindelin > <johannes.schinde...@gmx.de> wrote: > > The POSIX standard only requires the `read` builtin to handle `-r`: > > http://pubs.opengroup.org/onlinepubs/9699919799/utilities/r

[PATCH v2 1/2] ash: implement -d DELIM option for `read`

2017-08-08 Thread Johannes Schindelin
Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- shell/ash.c | 19 --- shell/hush.c | 3 ++- shell/shell_common.c | 10 +++--- shell/shell_common.h | 3 ++- 4 files changed, 27 insertions(+), 8 deletions(-) diff --git a/shell/ash.c b

[PATCH v2 0/2] Support for `read -d`

2017-08-08 Thread Johannes Schindelin
, as suggested by Kang-Che Sung. Johannes Schindelin (2): ash: implement -d DELIM option for `read` hush: implement -d DELIM option for `read` shell/ash.c | 19 --- shell/hush.c | 24 ++-- shell/shell_common.c | 10 +++--- shell

Re: [PATCH] Silence misguided GCC warning about alignment issues

2017-08-08 Thread Johannes Schindelin
Hi Emmanuel, On Mon, 7 Aug 2017, Emmanuel Deloget wrote: > And yes, its seems that the get_le32() macro in xz_private.h is a bit > illegal with respect to strict aliasing, as it casts a uint8_t * into a > const uint32_t *. It would seem so. Until you realize that it is used only on s->temp.buf

[PATCH v2] Silence misguided GCC warning about alignment issues

2017-08-07 Thread Johannes Schindelin
t from accessing already-aligned bytes one by one) was a bit heavy-handed. But we can help GCC by turning the get_le32() macro into an inline function. So let's do that, it also helps compile time safety by making the code a little bit stricter. Signed-off-by: Johannes Schindelin <johanne

Re: [PATCH] Silence misguided GCC warning about alignment issues

2017-08-07 Thread Johannes Schindelin
Hi Emmanuel, On Mon, 7 Aug 2017, Emmanuel Deloget wrote: > On Mon, Aug 7, 2017 at 12:25 PM, Lauri Kasanen <c...@gmx.com> wrote: > > On Mon, 7 Aug 2017 12:09:45 +0200 (CEST) > > Johannes Schindelin <johannes.schinde...@gmx.de> wrote: > >> Meaning: GCC gets th

Re: [PATCH] Silence misguided GCC warning about alignment issues

2017-08-07 Thread Johannes Schindelin
Hi, On Mon, 7 Aug 2017, Johannes Schindelin wrote: > On Mon, 7 Aug 2017, Denys Vlasenko wrote: > > > On Mon, Aug 7, 2017 at 12:09 PM, Johannes Schindelin > > <johannes.schinde...@gmx.de> wrote: > > > When compiling xz_dec_stream.c wi

Re: [PATCH] Silence misguided GCC warning about alignment issues

2017-08-07 Thread Johannes Schindelin
Hi Denys, On Mon, 7 Aug 2017, Denys Vlasenko wrote: > On Mon, Aug 7, 2017 at 12:09 PM, Johannes Schindelin > <johannes.schinde...@gmx.de> wrote: > > When compiling xz_dec_stream.c with GCC 7.1.0, it complains thusly: > > > > In function 'dec_str

[PATCH] ash/hush: implement -d DELIM option for `read`

2017-08-07 Thread Johannes Schindelin
, so let's do that. The motivation: This option is used by Git's test suite. Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- Published-As: https://github.com/dscho/busybox-w32/releases/tag/busybox-read-d-v1 Fetch-It-Via: git fetch https://github.com/dscho/busybox-w32 busybo

[PATCH] Silence misguided GCC warning about alignment issues

2017-08-07 Thread Johannes Schindelin
couple of lines. Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- archival/libarchive/unxz/xz_dec_stream.c | 12 1 file changed, 12 insertions(+) diff --git a/archival/libarchive/unxz/xz_dec_stream.c b/archival/libarchive/unxz/xz_dec_stream.c index bf791055

Re: [PATCH] ash: avoid GLIBC'ism %m

2017-08-04 Thread Johannes Schindelin
Hi Markus, On Wed, 19 Jul 2017, Markus Gothe wrote: > However it should be noted that this [scanf's %m format] seems not to be > the same as glibc %m: "To use the dynamic allocation conversion > specifier in C99 and C11, specify m as a length modifier as per > POSIX.1-2008. That is, use %ms or

[PATCH] ash: support BASH_XTRACEFD when built Bash compatibly

2017-08-04 Thread Johannes Schindelin
, and very easily implemented. Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- shell/ash.c | 7 +++ 1 file changed, 7 insertions(+) diff --git a/shell/ash.c b/shell/ash.c index 8c9f4adc6..1d1596fec 100644 --- a/shell/ash.c +++ b/shell/ash.c @@ -182,6 +182,8 @@ #

[PATCH] ash: remove no-longer-used variable

2017-08-04 Thread Johannes Schindelin
As of 035486c75 (ash: significant overhaul of redirect saving logic, 2017-07-31), the sv_pos variable is no longer used (just assigned to, with no further effect). Let's just remove it. Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- Published-As: https://github.com

Re: [PATCH] ash: avoid GLIBC'ism %m

2017-08-03 Thread Johannes Schindelin
Hi Denys, On Sun, 23 Jul 2017, Denys Vlasenko wrote: > On Sat, Jul 22, 2017 at 8:56 PM, Johannes Schindelin > <johannes.schinde...@gmx.de> wrote: > > On Fri, 21 Jul 2017, Denys Vlasenko wrote: > > > >> On Wed, Jul 19, 2017 at 3:47 AM, Jody Bruchon <j...@jodyb

[PATCH v3 0/2] Avoid GLIBC'ism "%m"

2017-07-25 Thread Johannes Schindelin
st (thanks, Ron). - inserted the missing %s in the same fprintf() statement. Johannes Schindelin (2): ash: introduce ash_perror_msg_and_raise_error() ash: avoid GLIBC'ism %m shell/ash.c | 49 + 1 file changed, 33 insertions(+), 16 deletions

Re: [PATCH v2 1/2] ash: introduce ash_perror_msg_and_raise_error()

2017-07-25 Thread Johannes Schindelin
Hi Ron, On Sun, 23 Jul 2017, Ron Yorston wrote: > Johannes Schindelin wrote: > >@@ -1263,6 +1263,8 @@ ash_vmsg(const char *msg, va_list ap) > > fprintf(stderr, "line %d: ", startlinno); > > } > > vfprintf(stderr, msg, ap); > &g

Re: [PATCH] ash: avoid GLIBC'ism %m

2017-07-22 Thread Johannes Schindelin
Hi Denys, On Fri, 21 Jul 2017, Denys Vlasenko wrote: > On Wed, Jul 19, 2017 at 3:47 AM, Jody Bruchon wrote: > > On 2017-07-18 9:15 PM, Kang-Che Sung wrote: > >> > >> On Wed, Jul 19, 2017 at 2:11 AM, Markus Gothe > >> wrote: > >>> > >>> Actually

[PATCH v2 1/2] ash: introduce ash_perror_msg_and_raise_error()

2017-07-19 Thread Johannes Schindelin
This new helper does the very same thing as ash_msg_and_raise_error() with one additional feature: if errno is not 0, it appends ": " (where is the output of strerror(errno)). Helped-by: Kang-Che Sung <explore...@gmail.com> Signed-off-by: Johannes Schindelin <johanne

[PATCH v2 0/2] Avoid GLIBC'ism "%m"

2017-07-19 Thread Johannes Schindelin
very elegant. Sadly, we cannot use bb_perror_msg() here because the functionality of that helper is very different (and lacks support for ash's TRACE). Happily, I could easily follow bb_perror_msg()'s example and introduce a new helper in ash's source code. Johannes Schindelin (

[PATCH v2 2/2] ash: avoid GLIBC'ism %m

2017-07-19 Thread Johannes Schindelin
. Helped-by: Kang-Che Sung <explore...@gmail.com> Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- shell/ash.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/shell/ash.c b/shell/ash.c index c21b25ab7..51d13e537 100644 --- a/shell/ash.c +++ b

[PATCH] ash: avoid GLIBC'ism %m

2017-07-16 Thread Johannes Schindelin
GLIBC's printf() family supports the extension where the placeholder %m is interpolated to strerror(errno). This is not portable. So don't use it. (It was only used in ash's source code to begin with.) Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- Published-As:

[PATCH v2 0/2] (Re-)instate some build guards

2017-07-14 Thread Johannes Schindelin
as 7d7c7bb22 (libbb: hide getnetbyaddr() inside "#if ENABLE_FEATURE_ETC_NETWORKS" block, 2017-07-14) (silently dropping my authorship, and smooshing it together with plenty of `#if DEBUG bb_error_msg(...) #endif` => `dbg(...)` conversions, making it hard to see the functional chang

[PATCH v2 1/2] copyfd: reinstate proper guard around munmap()

2017-07-14 Thread Johannes Schindelin
ost likely a mistake, as the corresponding mmap() call is *still* inside an equivalent #if ... #endif guard. Let's revert the mistaken change. Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- libbb/copyfd.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/libbb/copyfd.

[PATCH v2 2/2] ash: use JOBS as the compile time option it actually is

2017-07-14 Thread Johannes Schindelin
(where JOBS has to be set to 0). This partially reverts 4700fb5be (ash: make dowait() a bit more readable. Logic is unchanged, 2015-10-09). Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- shell/ash.c | 12 +--- 1 file changed, 9 insertions(+), 3 deletions(-) diff

Re: [PATCH 1/3] copyfd: reinstate proper guard around munmap()

2017-07-14 Thread Johannes Schindelin
Hi Denys, On Fri, 14 Jul 2017, Denys Vlasenko wrote: > On Fri, Jul 14, 2017 at 4:11 PM, Johannes Schindelin > <johannes.schinde...@gmx.de> wrote: > > In 4c1392296 (Introduce FEATURE_COPYBUF_KB, 2007-12-02), a feature was > > introduced where a large stac

Re: [PATCH 3/3] ash: use JOBS as the compile time option it actually is

2017-07-14 Thread Johannes Schindelin
Hi Denys, On Fri, 14 Jul 2017, Denys Vlasenko wrote: > On Fri, Jul 14, 2017 at 4:11 PM, Johannes Schindelin > <johannes.schinde...@gmx.de> wrote: > > Using the constant in a regular `if (...)` pretends that this is > > anything but a compile time option. Let's use `#if J

Re: [PATCH 3/3] ash: use JOBS as the compile time option it actually is

2017-07-14 Thread Johannes Schindelin
Hi Xabier, On Fri, 14 Jul 2017, Xabier Oneca -- xOneca wrote: > 2017-07-14 16:11 GMT+02:00 Johannes Schindelin <johannes.schinde...@gmx.de>: > > @@ -4182,7 +4186,9 @@ dowait(int block, struct job *job) > > goto out; > > } > > /

[PATCH 1/3] copyfd: reinstate proper guard around munmap()

2017-07-14 Thread Johannes Schindelin
ost likely a mistake, as the corresponding mmap() call is *still* inside an equivalent #if ... #endif guard. Let's revert the mistaken change. Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- libbb/copyfd.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/libbb/copyfd.

[PATCH 3/3] ash: use JOBS as the compile time option it actually is

2017-07-14 Thread Johannes Schindelin
(where JOBS has to be set to 0). This partially reverts 4700fb5be (ash: make dowait() a bit more readable. Logic is unchanged, 2015-10-09). Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- shell/ash.c | 12 +--- 1 file changed, 9 insertions(+), 3 deletions(-) diff

[PATCH 2/3] inet_common: handle FEATURE_ETC_NETWORKS as a compile-time flag

2017-07-14 Thread Johannes Schindelin
on systems where the getnetbyaddr() function is not available and the /etc/networks feature is disabled. Signed-off-by: Johannes Schindelin <johannes.schinde...@gmx.de> --- libbb/inet_common.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/libbb/inet_common.c b

[PATCH 0/3] (Re-)instate some build guards

2017-07-14 Thread Johannes Schindelin
leading to build errors where features are disabled because the required functions are unavailable. Johannes Schindelin (3): copyfd: reinstate proper guard around munmap() inet_common: handle FEATURE_ETC_NETWORKS as a compile-time flag ash: use JOBS as the compile time option it actually