[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-09-07 Thread Balogh , Ádám via Phabricator via cfe-commits
baloghadamsoftware marked an inline comment as done. baloghadamsoftware added inline comments. Comment at: clang/lib/StaticAnalyzer/Checkers/ContainerModeling.cpp:36 + void handleAssignment(CheckerContext &C, const Expr *CE, SVal Cont, +Optional = None) c

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-09-07 Thread Balogh , Ádám via Phabricator via cfe-commits
baloghadamsoftware updated this revision to Diff 290248. baloghadamsoftware added a comment. Wrong diff uploaded previously. (Accidentally compared to //master// instead of the prerequisite.) CHANGES SINCE LAST ACTION https://reviews.llvm.org/D76590/new/ https://reviews.llvm.org/D76590 File

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-09-07 Thread Kristóf Umann via Phabricator via cfe-commits
Szelethus added a comment. I'm in favor of most, if not all of the changes, though I will admit that this patch seems pretty cluttered, you are doing a lot of refactoring under the same hood. You're moving, adding, removing and changing helper functions and their invocations. Would be possible

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-09-04 Thread Balogh , Ádám via Phabricator via cfe-commits
baloghadamsoftware updated this revision to Diff 289981. baloghadamsoftware added a comment. `isIterator()` updated because it did not work perfectly with the refactored `handleBegin()` after rebase. (Why did it work before the rebase?) The problem was that it only looked for the necessary opera

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-08-04 Thread Balogh , Ádám via Phabricator via cfe-commits
baloghadamsoftware updated this revision to Diff 282914. baloghadamsoftware marked 2 inline comments as done. baloghadamsoftware added a comment. Minor fix. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D76590/new/ https://reviews.llvm.org/D76590 Files: clang/lib/StaticAnalyzer/Checke

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-08-04 Thread Balogh , Ádám via Phabricator via cfe-commits
baloghadamsoftware updated this revision to Diff 282909. baloghadamsoftware added a comment. Updated according to the comments. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D76590/new/ https://reviews.llvm.org/D76590 Files: clang/lib/StaticAnalyzer/Checkers/ContainerModeling.cpp cl

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-08-04 Thread Balogh , Ádám via Phabricator via cfe-commits
baloghadamsoftware marked 2 inline comments as done. baloghadamsoftware added inline comments. Comment at: clang/lib/StaticAnalyzer/Checkers/ContainerModeling.cpp:56 +SVal RetVal) const; + void handleErase(CheckerContext &C, const Expr *CE, SVal Cont, SVal It

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-07-17 Thread Balogh , Ádám via Phabricator via cfe-commits
baloghadamsoftware updated this revision to Diff 278832. baloghadamsoftware added a comment. Rebased, updated. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D76590/new/ https://reviews.llvm.org/D76590 Files: clang/lib/StaticAnalyzer/Checkers/ContainerModeling.cpp clang/lib/StaticAna

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-03-23 Thread Gabor Marton via Phabricator via cfe-commits
martong added inline comments. Comment at: clang/lib/StaticAnalyzer/Checkers/Iterator.cpp:297 + +ProgramStateRef relateSymbols(ProgramStateRef State, SymbolRef Sym1, + SymbolRef Sym2, bool Equal) { Would `assumeEqual` be a better name

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-03-23 Thread Gabor Marton via Phabricator via cfe-commits
martong added inline comments. Comment at: clang/lib/StaticAnalyzer/Checkers/ContainerModeling.cpp:34 - void handleBegin(CheckerContext &C, const Expr *CE, const SVal &RetVal, - const SVal &Cont) const; - void handleEnd(CheckerContext &C, const Expr *CE, con

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-03-23 Thread Balogh, Ádám via Phabricator via cfe-commits
baloghadamsoftware marked 3 inline comments as done. baloghadamsoftware added inline comments. Comment at: clang/lib/StaticAnalyzer/Checkers/IteratorModeling.cpp:359 State = State->BindExpr(CE, LCtx, RetVal); } Maybe I should move these lines into a sep

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-03-23 Thread Balogh, Ádám via Phabricator via cfe-commits
baloghadamsoftware added a comment. Supersedes D62688 . Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D76590/new/ https://reviews.llvm.org/D76590 ___ cfe-commits mailing

[PATCH] D76590: [Analyzer] Model `empty()` member function of containers

2020-03-23 Thread Balogh, Ádám via Phabricator via cfe-commits
baloghadamsoftware created this revision. baloghadamsoftware added reviewers: NoQ, Szelethus. baloghadamsoftware added a project: clang. Herald added subscribers: ASDenysPetrov, martong, steakhal, Charusso, gamesh411, dkrupp, donat.nagy, mikhail.ramalho, a.sidorin, rnkovacs, szepet, xazax.hun, wh